"Widow" control for *subheaders* in a long document

Hi all,

Here’s my problem. I have a ~2000 word document. It’s got lots of 2- or 3-line subheaders. Many of them are split by a page break when I compile. If this were a short document, I’d just fix that manually after compiling. But in this long document–while I am regularly revising and re-compiling and re-sharing with a working group–the manual solution is not realistic.

Here’s the specific question. I would love to be able to somehow mark these subheaderswith a conditional page break. Something like,
IF EITHER this 2-line title OR the 3 lines of text following it are broken by a page break,
…THEN activate/insert this page break
…ELSE just have a single space breaker

I feel like this could maybe be done with Scrivener sections, but I can’t figure it out. I also feel like maybe there would be a way to do this in Word, but I can’t figure THAT out either. It’s also possible that this just isn’t a thing. (But surely this problem isn’t so unusual in publishing that no one has developed a way to handle it?) I’m love loving the “Section Types” in the new Scrivener, and hoping that somehow they will help me solve this problem too . . . .

Thanks for any thoughts!

p.s. I’ve read through some of the forum posts on “widows,” which I thought might be relevant. But it doesn’t sound like they are (and it sounds like maybe that feature is best left to Word anyway), since those are stray lines in paragraphs rather than entire section headers. The problem is certainly related though, so I mention it in the topic title.

Does this help?

literatureandlatte.com/foru … 92#p269692

Slàinte mhòr.

JoRo is right, the option you want here is “Keep with Next” (available in Format > Paragraph). If you apply this to your subheadings, it ensures they stay on the same page as the paragraph that follows. In theory, this should do exactly what you want. I say “in theory”, though, because there is currently a slight inconsistency in the way Keep-with-Next works: if the next paragraph is on the next page, then the whole Keep-with-Next paragraph gets moved down. However, if the KWN paragraph is split across pages so that some of it appears on the same paragraph, it is not pushed down, and in this case it won’t help you much.

However, the good news here is that, purely by coincidence, I have spent the past month-and-a-half of my life working on widow and orphan control and improved Keep with Next (and improved scriptwriting layout, which is related by not relevant here). As of the next update, Keep with Next will have two modes - the default mode will always push the entire KWN paragraph across to the next page if necessary and will never let it split across pages, which is exactly what you want. Then there’s a “Can split across pages” option that can be turned on for individual KWN paragraphs to let them split. Then widow and orphan control on its own will ensure that three-line paragraphs are always kept together on the same page anyway.

So, for a start you should definitely use Keep-with-Next for your subheadings. This may fix things right now. If after adding this option (if it’s not already turned on) you still see some subheadings split across pages, then the next update should fix this. That said, the next update is unlikely to be out before September (since I have some 10.14 work to do on it and I’m about to go away for my summer hols), so it might not be out in time to help with your current document. At least it should not be an issue in future, though.

All the best,

Yes! This seems to work! I’ve played with this by adding the setting to the relevant Style definitions, and the change is workig like a dream (so far . . … )

Thank you!!

This sounds amazing – thank you!! Your workflow / schedule is my kismet indeed : )