Windows 11 crashing unable to load random files

Are there any known issues with Windows 11 and Scrivener? I’ve just got a new PC and two of my projects that worked fine on my old Windows 10 laptop have started behaving oddly. When selecting a random file in the binder, Scrivener closes without warning and when trying to open it again gives me a message 'RTF Inspector could not load document file… with a list of instructions of how to resolve the problem for that particular file, but no indication why it’s happening. And I’ve just lost a big chunk of work that was contained in comments linked to the last file that I had to remove and re-paste in from a Notepad file. Seriously worried about opening and working on this project right now. Help please!

Try whitelisting Scrivener in your anti-virus.
It looks like what it’d do. (Deny access to files, shut down abruptly etc.)

You set it as an exception / exclusion. Whatever the terminology is for your AV.

AVG, for e.g., will say it is allowed/unwatched for ransomware.

Added Scrivener to Avast’s whitelist and did a test with one of the problem files, re-adding it to a copy of the project. It still doesn’t like it and refuses to open the project on the first attempt, then gives the same error message on the second. I’m guessing there’s some erroneous formatting in it that Windows 11 hates? Any ideas? I really don’t want to have to re-paste every single file in this massive (250K word) project.

Well, you could try and paste it once more, but this time make sure to use Paste and Match style (Ctrl-Shift-V) which will strip all foreign formatting.

With any luck…

1 Like

I’ve been using Windows 11 since its release without Scrivener related OS problems.
Your Avatar indicates you’re on Scrivener version 3.1.4. If this is still true, download the latest version 3.1.5.1 from here: Scrivener Release Notes | Literature & Latte (literatureandlatte.com)
Ensure you’ve exited Scrivener, then double-click on the download to install the update.

Sorry, I’d forgotten to update that! Thanks for the reminder. These problems were on version 3.1.5.1 on this new Windows 11 machine.

1 Like

Fingers and toes crossed, I’ve managed to find all the old text and comments in some older compiles and pasted it all in without any further problems… so far.

In all, four files were affected in two projects, but I can’t find anything similar in them that might have caused the problem, so I guess I’ll have to hope it keeps behaving. Could do without this kind of stress! :grimacing:

I would love to hear more about this. I am experiencing the same thing and the automated error message is both unenlightening as to the cause and pretty worrying – the proposed solution is to cut and paste text? What about associated notes, data, the corkboard? Super frustrating.

What’s the message? And what were you doing before this happened?

Thanks for replying-- someone from Scrivener’s help team has separately responded and I am fumbling toward a solution. But FWIW, I was opening a file and it closed without warning, then upon re-opening said “Scrivener was not able to parse the rtf in the following file” then “Could not load document notes for [file]” and “RTF Inspector could not load notes file: ” and instructions to backup, delete the files, and ultimately do some copying and pasting. This seesm to be happening for every Notes file for every subgroup in a project. It’s worrisome and if nothing else labor intensive, and I was surprised not to see much here about it, other than this question.

1 Like

Frustrating is an understatement. I’ve now got 8 files this has happened to. Mostly in my somewhat vast series bible project. The latest file is several thousand words long and has many, many comments in it. Trying to manually cut and paste everything into a new clean file from within the mess of formatting the raw data contains is beyond me right now.

What have L&L told you? Any idea why it’s happening?

That actually would not be my first recommendation.

Instead, I’d create a new project using the same project template that I used on the original project. I’d use the title bars of the new project and the old to arrange both side-by-side on my display.

Then, I’d use Ctrl+Click and Shift+Click to select the materials in the old project. I’d drag-and-drop all the selected files onto the binder of the new project to copy them over.

I could then test the new project and see if it has the same problems.

If it does, then I would repeat the process but with chunks of documents. I’d test after moving each chunk of documents to see if I can isolate which group might have issues.

That would allow me to then test only the document or documents that are a problem and recreate them if needed.

Sorry, I’m not following. Once this problem occurs the problem files are blank within Scrivener when you re-open the project. The only way to view the content/comments/synopsis/notes is to go into the file structure of the .scriv files, open them in Notepad or whatever and then copy & paste from there. So how would moving them to a new project help? Will the content magically reappear because I’ve copied them to a new location?

In the error Festus1 reported, nothing was mentioned about the document actually being blank. Just that an error said the notes couldn’t be read and that a new document was needed.

For that situation, my suggestions could be helpful to avoid extensive cutting and pasting.

For something like the documents being blank, I’d look to whatever backup tools are used and ensure that services like OneDrive or another cloud service are allowing all project data to be available offline.

If the cloud storage is automatically uploading the data from the project and defaulting to online-only, it could be a factor in the blank documents. Vincent’s suggestion of the anti-virus is also a good avenue to review.

All my projects are stored on an external SSD. Only the backups are on a cloud (OneDrive). And as I posted above, it’s whitelisted on my anti virus with no effect on this issue.

If you move those projects to the computer’s internal hard drive, do you continue to have issues with the materials?

My first thought would be to test that. The SSD’s connection could be a factor in the behavior. Or, it could be going bad.

By paring out any extra layers of storage between the computer and the projects, you might find the cause of the behavior.

1 Like

System interrupts ?
Google that.

That or USB selective suspend.

2 Likes

As others said, an important clue. Move all the projects to the local hard disk not in a cloud synced folder and see if problem ameliorated.

I also would recommend not putting backups in a cloud synced folder. Not secure as any flaw is synced and poof, backup gone. Rely on your routine system backups to backup both projects and the backups.

1 Like

Thank you for the suggestions.

System interrupts looks fine. It’s barely registering 1%.

USB selective suspend I’ve just disabled. Is that a new Windows 11 thing? I didn’t get this issue on my old Windows 10 laptop. I’m running on a desktop now, so not sure if it was actually doing anything…but hey, if it helps. :woman_shrugging:

My live files are not cloud sync’d. It is a local hard disc. Just not inside my desktop. It sits on top so I can hide it when I’m out, so if my PC gets nicked, I’ve not lost all my work.

Very confused by what you say re backups & cloud folders. It’s a single zip file what problem would it have? If Scrivener can’t backup without a flaw then it’s surely not fit for purpose?