Windows applies outline to font when opening MacOS project

When I bring my S3 for macOS project into S3 for Windows, several documents now have “outline” applied to them. This is because I didn’t know about “Paste and Match Style”, so I was manually clicking “No Style” to get any pasted resources into my desired font, size and line spacing. For some reason, Windows now reads this copy as outlined. This is not a font compatibility issue; it only happens on copy pasted from the web.

Here’s what I’ve tried

  1. Convert Documents to Default Text Format. This does not remove character attributes, so my copy remains outlined.

  2. The Windows version of Scrivener doesn’t let me select multiple documents in Scrivenings, so I can’t just select all and toggle outline off. [Note: I thought this was coming with S3 for Windows? Did it get dropped as a feature?]

  3. Even if I could “replace format”, Find by Formatting → Character Format does not have outline as an option

I think Option 2 would be the best so I can keep anything I’ve bolded, underlined, etc., but I can’t figure out how to do this on Windows. Note that I can’t fix this on the macOS version, because the font isn’t outline in macOS.

[attachment=0]Illustration.jpg[/attachment]

Solution
I determined the issue was around leftover or hidden formatting from copy/pasting that was causing Windows to read the fonts incorrectly. My theory was that if I cleared the bad formatting prior to sending the project to Windows, then Windows wouldn’t apply the outline. The solution wasn’t around removing the additional outline that Windows added, but to stop Windows from wanting to apply the outline in the first place.

I did this (in the MacOS version) by using Documents → Convert → Text to Default Formatting at each of my top level folders (make sure you click inside the editor window before doing this. If you try this directly from Binder in MacOS, it doesn’t work.)

My settings were:

  • Remove all Styles
  • Preserve Alignment
  • Preserve Tabs and indents

This let me keep the intentional character attributes that I applied (bold, italics, underline and strikethrough), while clearing the hidden formatting that Windows didn’t like.

This is also a good time to do a Select All and change the font color to “No Color”, or Dark Mode might read font color as black, and then you can’t read your copy.

Zap Gremlins might have done the job (maybe), but I think only the Mac version has that for now.

Why do you always quote before you answer? Isn’t it obvious that you are answering the post above? Especially when there is only one post?

Quoting so that you name who you are quoting from creates a notification for the user the next time they log on, and they can go straight to your response from their notifications. Simply replying does not do this.

Some selective trimming would occasionally seem to be in order, though.

… which is why I quoted the way I did. 8)

Good for you!

Apologies to both of you. I wrote that last bit about selective trimming when I was extremely tired and did not stop to consider that it would come off as a shot against either/both of you. That was not what I intended. My practices on quoting come from the old days of Usenet and I editorialized where there was no need to.

Again, I apologize for adding the unnecessary commentary.

Don’t worry about hurting my feelings, devinganger! You voiced a valid point, and I greatly appreciate what you’re doing to help all of us. I sometimes try to trim quotes and fail to remove the correct open and close tags, so I don’t always try. I’ll work on that.

The problem with not trimming is that the post become verrrrry loooong after a while and you have scroll and scroll and scroll before reaching the new addition at the end.

If someone posts a question, you might assume that they would be interested in checking if they got an answer… and thus not need the quote at all?

Yes? No?

Nah.