Windows Bloat [NO BLOAT - JUST A BUG]

I recently downloaded Scrivener, in part because a friend showed it to me on her Mac a few months back and I really thought it a neat way to write, as its very similar to my manual sort of methods of writing. I however am not really a mac user, nothing against them, I just find I tend to use linux and windows machines, so I really didn’t get too interested in the program as I didn’t want to get too envious of “yet another awesome creative Mac application”. I looked into it again recently and noticed the Windows Beta Test a few days ago and I downloaded and installed it.

Love the look, yes I get it’s beta and chances are stuff I write might get eaten, crap happens. But, I confess I am Scrooge like about stuff running in memory or how much space stuff takes on my hard drive. If something is taking what I consider to be too much space, I start to evaluate if the program is really worth keeping around. Granted I have a LOT of space on my drive, so I shouldn’t be so darn stingy, but I keep an eye on how much a program takes… and looking up Scrivener, it has a larger hard drive footprint than your typical Word Processor, Scrivener is 1.91GB. My current ‘Office’ suite is OpenOffice, which comes in at 352mb, and that is the whole suite Writer Calc Impress Base Draw Math. Now is this something windows is getting wrong? Because the download is only 40mb so finding its taking almost 2 gigs on my main volume is kind of bizarre.

Am I the only one who noticed this? I have more than enough space, its just highly unusual.

When I have Scrivener open, it only uses between 47,000k to 51,000k. There must be something else going on there.

On my Win7 PC, I come out at around 42000k…

Now that number 1.91gb I get from the control panel -> programs and features list of programs. The Directory where it is installed (C:\Program Files (x86)\Scrivener) reads as 75.2Mb, this obviously does not include any files installed in other directories, of which I doubt there are many. Now under the programs and features, it’s like windows has sequestered 1.91 gb for scrivener activity. I am starting to suspect that its more a windows fault than a scrivener fault, that when this particular beta ends in a few days that I can remove it and with the re-installation, we can see how that fares.

I think something’s screwy there. It’s only taking up 145MB on my hard drive and with my biggest project taking up the entire screen, I use a negligible amount of RAM.

My number is 76.1mb when I look in control pannel. Interestingly the first beta 1.0 was 102mb. Anyone know how I can remove the beta 1.0 registry entries?

Interesting. I can see a similar result on my Eee PC running w7 Starter. In my control panel, I have several instances of Scrivener being installed (looks like I was lax about uninstalling when upgrading a few times). The first instance is allocated 3.8GB, second 1.59GB, third 1.91GB.

So I proceeded to uninstall the first instance using this panel, which required a reboot oddly. After that I had two instances left, both of which fussed when I tried to uninstall them (quite expectedly), but allowed me to remove them from the list. I then cleaned out the Program Files\Scrivener folder to remove anything extra the uninstaller might have missed (especially given I don’t know which uninstaller version I ran!). 1.3MB were trashed.

Downloaded a fresh copy of 1.6 and ran the installer, and now I have an entry listing 1.91GB (so the third entry must have been the correct one). Weird. It’s definitely not taking up that much space. Properties on the application folder show 76MB of disk usage.

I checked on other thing. Reported free disk space on the C: drive with Scrivener uninstalled and installed. In both cases I had 179GB free on the drive; so it seems to be a reporting problem, it isn’t actually physically taking up that much space.

Maybe you have one of those old P60 processors? You know, the ones that can’t do math very well…

Runs at about that speed, come to mention it.

1.11 GB footprint for the entire application on my machine, and running two Scrivener projects at once like I usually do results in the program using 57,200K (Task Manager) on first glance…but every time I go in or out of the projects, it ticks up. Currently it’s using 57520 (Lenovo G560, dual-core P6100; 64-bit Win7)

Now granted, unless I open the project that I use for my articles, I NEVER have performance issues…it’s’ just weird.

The number in the Windows program manager is wrong. I got the same on my machine (I’m running Windows 7 on an i5). There’s no way Scrivener has bloated from 46 megs to 1.7 gigs. Something is going on with the way our computers are calculating the number.

Interesting - thanks for the post.

The full foot print for Scrivener is max 120Mb. There are no other hidden files or directories.

Yes, I too can see 1.1GB in the control panel uninstall. This is incorrect of course. I think this might have something to do with the installer as I do not specify files sizes of each and every component. I’m guessing because of this something is just pumping in a ridiculously large number. I will look into this and fix. Thanks for raising this.