Windows + iOS Sync not working

I’m using the latest version for Windows, and the iOS version on the latest version of iOS on an iPhone 6S Plus. The sync to Dropbox mostly works - I get no errors and all the files seem to be there. But some of the files are empty when I open them on iOS, but they have text in them if I open them in Windows. I’ve also opened the RTF files on Dropbox with MS Word, and the text is in there. But when I sync to my phone, it acts like everything worked, but some files are empty.

You can try the current workaround for problems occurring with initial Windows Scrivener project conversions. The fix will apparently be in the next release.

Make some small change in the project, once you get it converted and open – I suggest changing the order of two documents in the binder, simple as that.

Close Windows Scrivener, just to be sure this special small increment is recorded.

Wait until Dropbox tells you it has all the files – it will say ‘up to date’ if you cross the small icon to the right or hidden by the up arrow there, in the Windows taskbar. Usually doesn’t take more than a small seconds portion of a minute, but internet lag moments can make it take longer.

Now sync from iOS Scrivener – you should be good, with your content restored.

Best fortune on this, as ever,

I tried this, and initially, it didn’t work. However, I looked through the folders and noticed that there were several files that had had conflicts during syncing. The binder file was one of them, but several others as well. I deleted the filenames that had “conflict” in their names, then I opened up Scrivener and made a change like you recommended. Upon syncing again, everything worked. Thanks! :smiley:

I can confirm that the “make small change” fix works on the Mac, too. I had moved a project out of my sync folder, and then later moved it back in. Thereafter, I was getting errors trying to open the project on iOS (telling me it was created with an earlier version of Scrivener, which it wasn’t). When I went back to the Mac, the text part of every section (scene) was now empty. I tried this a couple of time, restoring from backups, with the same result. I then cleared out my projects on my iOS devices, made a small change on the Mac (reordered a section), and sync worked fine thereafter.

I opened desktop Scrivener, navigated to a Dropbox file and opened it, moved some files and added some text and saved the changes, watched the dropbox icon until it stopped spinning and was up to date, closed Scrivener completely. Then went to Scrivener ios and opened it, tapped the sync button and still no files, but said it was up to date. I just don’t understand what’s going on. I’m going to check to make sure the version of dropbox on my desktop is the same as the version on ios. :cry:

If iOS Scrivener says ‘no files’ then the app is not looking in the same folder where you saved your project.

In Project view, tap on Edit and then on the settings gear wheel at the bottom, and point to the correct folder.

Even though what I posted above fixed my issue, it seems it was only temporary. After syncing a few more times, the file went back to being emtpy again.

… and you chevked that Dropbox had time to update the files on the server?

Thanks for responding, lunk. I tapped the ‘edit’ in ios Scrivener, found Apps/Scrivener, screen said syncing with dropbox, screen said Dropbox up to date, still no files appear on the ipad. I went to and checked my account preferences. Scrivener is not listed as one of the accounts that can access Dropbox, and I don’t see any way to add it. This could be the problem? Any ideas?

So I tried going to Dropbox and exporting the Dropbox file to Scrivener and got 'invalid project. Could not be imported because it does not contain all necessary structure files. Please try importing it via itunes instead. I’ll try that.

You have a Mac. Have you opened the project in Mac Scrivener, made some small change, and made sure that you actually save it in the designated folder under your Dropbox folder?

Yes. I open desktop Scrivener, open the file via Finder and Dropbox, make change, save, wait for Dropbox to load changes, log out of desktop Scrivener, go to ios Scrivener, open, sync, says Dropbox is up to date. No files there. I tried edit>gear> and tried all dropbox settings, update from iTunes, everything but unlink Dropbox. I tried tweaking settings via iTunes with ipad plugged into computer with usb cable, nothing changes. Re-booted computer, turned ipad off and back on - No matter what I do it stays the same. Bewildered!! I have the nagging suspicion that it’s something really simple that I’m missing. Surely it can’t be THAT complicated!!

Which folder are you saving your project to when you are in desktop Scrivener, and are you saving, not any other menu command?

Wooooohoooo, it WAS that simple. I shut down Dropbox on Scrivener ios, opened it up again, set it to the correct file on Dropbox, it uploaded my files and there they are. Whew! A three day ordeal and all I had to do was turn off Dropbox in iosScrivener and set it back up.
MISOHAPPY!!! Thanks to anyone and everyone who responded, the answer to MY problem was to go into iosScrivener, turn off Dropbox, turn it back on, choose the correct folder, (even though it was the same one I’d been saving to) and it loaded the Dropbox files into iosScrivener onto my Project screen.

A bit too simple perhaps? :wink:

Good luck with your writing!

LOL thanks!!

Yes, I waited until it was done. In fact, it was several hours later when I synced my phone. I had moved one of the files in the binder up or down in the list, and the change to the order synced across fine. But the content of the file was gone.

I think I resd in one post somewhere about someone who simple disconnected Dropbox in the iOS Scrivener app, re-booted the iDevice, connected anew, and everything worked.

I’ll give that a try.

The thing is, it’s not really a question of “syncing”. The iOS app reads the normal Scrivener projects, even if you don’t have the desktop app, so if it doesn’t, there must be some fundamental error in either the projects or in the app. The only way to pinpoint the error is to eliminate all potential handling errors and do some experimenting.

Did you try deleting and re-installing the app? Did you try creating a new project in the iOS app, closing and re-opening it, editing and then saving the changes? Did you then try to open it on the dedktop, editing and closing, and re-opening on the iOS app?
You write that you have updated the iOS, to what version?