Windows Setting Display Size Problem

I recently purchased a new 13" laptop for use on the move. The recommended windows display setting under ‘Change the size of text, apps and other items’ is 150% which is fine for all other apps but Scrivenere displays uncomfortably large.
Messing with the setting options of 100, 125, 150 and 175% it seems that Scrivener will only display in 2 sizes:
100/125% which is too small and 150/175% which is too large!. There is no inbetween. It seems to be either 100 or 175%.
On my 15" laptop (recommended 125%) all 4settings work fine as expected!
Both have screen resolutions of 1920 x 1080.
Any ideas? Is this a Scrivener, Windows or laptop problem?

Lenovo L13

If I change settings to 125%, open Scrivener, then change settings to 150% it looks fine.
If I open Scrivener with Windows set to 150% then it is too large (displaying at 175% I think)

I run the beta on a 14" Lenovo with 1920 x 1080 screen, at 125%, with no problems.

The developer has said that there is a minimum resolution required to run Scriv Windows, although I can’t seem to find the thread now. :frowning: This in response to people who were posting that some beta windows were too large for their display settings.


Have you tied to right-click on Scrivener -> Properties -> Compatibility -> “Change high DPI settings”, and change the settings there so to override the scaling behavior?

I’m not sure it would help, but it’s worth trying.


Might be worth seeing if there is an updated display driver for your chipset. Sometimes Lenovo’s official current drivers have quirks that are not present in the current chipset drivers, especially if those chipset drivers are provided through Windows Update.

Lenovo also has a utility where you can check their servers for their specific updates to their drivers. Anything graphics related, that’s where I start troubleshooting, after MANY years of IBM/Lenovos in my career.

Krastev & Devin - good points.

On my 2019 Lenovo, the utility Devin refers to is called Lenovo Vantage, and I use it to keep my laptop up-to-date. (At least I think it’s the one he’s referring to. :slight_smile: ) You might want to see if that’s loaded on your PC.

This the best I could find:

Basically, after your scaling factor and everything is taken into account, you need to have “1080px effective height” for Scrivener windows to properly display.

So if you have 1920x1080 pixels but are running at anything higher than 100%, you will not have enough vertical real estate for some windows to properly display.

I played around with some common hardware screen sizes and put out this table:

[code]1,920 x 1,080 (16:9 aspect ratio)
@ 100% = 1,920 x 1,080 (Meets requirement)
@ 125% = 1,536 x 864 (Does not meet requirement)
@ 150% = 1,280 x 720 (Does not meet requirement)
@ 175% = 1,097 x 617 (Does not meet requirement)

1,920 x 1,200 (16:10 aspect ratio)
@ 100% = 1,920 x 1,200 (Meets requirement)
@ 125% = 1,536 x 960 (Does not meet requirement)
@ 150% = 1,280 x 800 (Does not meet requirement)
@ 175% = 1,097 x 686 (Does not meet requirement)

2,048 x 1,536 (4:3 aspect ratio)
@ 100% = 2,048 x 1,536 (Meets requirement)
@ 125% = 1,638 x 1,229 (Meets requirement)
@ 150% = 1,365 x 1,024 (Does not meet requirement)
@ 175% = 1,170 x 878 (Does not meet requirement)

2,160 x 1,440 (3:2 aspect ratio)
@ 100% = 2,160 x 1,440 (Meets requirement)
@ 125% = 1,728 x 1,152 (Meets requirement)
@ 150% = 1,440 x 960 (Does not meet requirement)
@ 175% = 1,234 x 823 (Does not meet requirement)

2,560 x 1,440 (16:9 aspect ratio)
@ 100% = 2,560 x 1,440 (Meets requirement)
@ 125% = 2,048 x 1,152 (Meets requirement)
@ 150% = 1,707 x 960 (Does not meet requirement)
@ 175% = 1,463 x 823 (Does not meet requirement)

3,440 x 1,440 (21:9 aspect ratio)
@ 100% = 3,440 x 1,440 (Meets requirement)
@ 125% = 2,752 x 1,152 (Meets requirement)
@ 150% = 2,293 x 960 (Does not meet requirement)
@ 175% = 1,966 x 823 (Does not meet requirement)

3,840 x 2,160 (16:9 aspect ratio)
@ 100% = 3,840 x 2,160 (Meets requirement)
@ 125% = 3,072 x 1,728 (Meets requirement)
@ 150% = 2,560 x 1,440 (Meets requirement)
@ 175% = 2,194 x 1,234 (Meets requirement)[/code]

That’s one of the names it goes by, depending on how old your system is and which line of machines it belongs to. Another common one is Lenovo System Update.

I don’t know about this. On one of my computers, the monitor is 1680x1050 at 100% scaling, on the other 1280×960 100% scaling. The beta works just fine on both of them. Windows 10 on both of them.

At 1920x1080 125%, the beta works beautifully for me.

At 1920x1080 150%, the beta’s panels just barely fit. Particularly the compile screen.

This on a 14" monitor.

Thanks for all your replies.
Further update:
My lenovo L13 is brand new, all drivers checked and up to date.

I am now sure that this is a Scrivener bug or at least bad behaviour for the following reasons:
a) All other apps work fine at all display scales. I have tested Word, Chrome, Edge and Unity.
b) The problem is easy to replicate. I have replicated on my Lenovo 15.6" and a borrowed HP 15.6".

To replicate:

  1. BEFORE opening scrivener set the display scale to 150% (this is the recommended default for my 13" laptop and the reason why I discovered the problem).
  2. Open Scrivener.
  3. Now try changing the display scale. Other apps scale fine but Scrivener only has 2 results. 100 & 125% are both scaled to 100% (too small) and 150 & 175% are both scaled 175% (too large). There is no inbetween.

To openScrivener on my 13" laptop I have to first set the display scale to 125%, then open Scrivener, then reset the scale to 150%. Everything then works fine. All 4 scale settings work OK.

I’m just reporting what Tiho said in the earlier thread. The specific complaint was about the Compile/Edit Format window. On my 3440x1440 display, I set it to 150% (which should have resulted in an effective pixel height of 960) and was able to open the Edit Format window in its entirety. However, when I took a screenshot of the window to measure the size, it was more than 960, so I suspect that since my monitor is technically a high DPI monitor, there are actually more physical pixels in there to play with so the scaling all works as expected.

This is the output from qtdiag.exe:

[code]Screens: 1, High DPI scaling: inactive

0 “\.\DISPLAY1” Depth: 32 Primary: yes

Serial number:
Geometry: 3440x1440+0+0 Available: 3440x1410+0+0
Physical size: 254x106 mm Refresh: 59 Hz Power state: 0
Physical DPI: 344,345.057 Logical DPI: 96,96 Subpixel_None
DevicePixelRatio: 1 Pixel density: 1
Primary orientation: 2 Orientation: 2 Native orientation: 0 OrientationUpdateMask: 0[/code]

Also of note, I do not have High DPI settings enabled on the Scrivener executable:


However, this is Windows 10 1909, so I do have the Scaling settings enabled OS-wide:


I din’t think it can be anything like that.
If I first set the display scale to 125%, then open Scrivener, then reset the scale to 150% everything works fine. All 4 scale settings work OK and Scrivener displays in proportion.
It is not the size of the edit window that is a problem but all buttons, icons and toolbars are unnecessarily large.
As I mentioned it is easy to replicate this (done on two 15.6" laptops).

I’m not saying that this is your problem, merely that there is already a lot of wonkiness going on behind the scenes with scaling and HighDPI and it’s a known problem area still.

OK, thanks.
I have the workaround as mentioned, so I’ll leave it there and hope for a fix.
A nuisance but no big deal.