Won't open from Dropbox (Mac to Windows)

I have Scrivener for both Mac and Windows. 99% of the time, I use it on my Mac. Both computers have Dropbox installed locally, and share the same account.

My mac was out of battery and I left my charger at work, so I wanted to get some work done on my Windows desktop. I tried to open my .scriv from the Dropbox but it wouldn’t work. Here’s the chronological order:

  1. Open .scriv from dropbox, get (open on other computer warning). I select “make a copy”. This duplicates the folder that carries the .scriv in the Dropbox, but reverts it back to a previous file name. For example, my folders are named by date.

So let’s say my folder in the Root Dropbox folder was called “X_10-14-14” and the scrivener file inside was called “Project_X_10-14-14.scriv”…

After I “made a copy”, it made a new folder in the Root Dropbox folder called “X_10-13-14” and the scrivener file inside that was “Project_X_10-13-14.scriv”

  1. I tried to open up the correct date “Project_X_10-14-14.scriv” from Dropbox, but it was just an empty folder? No executable files inside.

  2. So then I try the outdated file ““Project_X_10-13-14.scriv”” and that didn’t open up either in Scrivener…just the Select a Project dialogue box.

  3. So then I go back to my Mac and I check my Dropbox there, and in the Root folder, it doesn’t even show the outdated folder. Only the most current one.

  4. I’m stumped. From my Windows Dropbox, there’s no .scriv file in the current folder and the .scriv in the outdated folder (which doesn’t appear on mac) won’t execute either.

I know this is confusing to read but it’s just as confusing in person. I used to be fairly tech savvy and have no idea what’s going on here.

Has anyone else had this sort of issue with a phantom outdated folder appearing and not being able to open .scriv’s originated from Macs?

It sounds like Dropbox isn’t properly syncing between the machines, to start, since the new folders/files created on Windows in Dropbox aren’t showing up on your Mac. That could also explain why the project folders are appearing empty on Windows, if the contents aren’t all syncing. I’d check out Dropbox’s articles on clearing the cache and anything else in their FAQ that seems pertinent.

When you get the “already open” message and choose to make a copy, you should be prompted with a Save As dialogue to choose where you want to save the copy and what to call it. You could certainly have selected a folder in Dropbox, but all of that should have been manually done on Scrivener’s end, so the reversions and dates all sound like a Dropbox sync issue.

The project folders, when viewed on Windows, should contain a project .scrivx file, which will have the same name as the project if it’s coming fro the Mac, and at a Files and a Settings folder. You’ll probably have QuickLook there too, from the Mac, and possibly Snapshots. The .scrivx file with the yellow Scrivener icon is the one that ought to open the project, and it should have a modified date from your most recent session. (Not all the files in the project are modified in each session, but that one will be.) Did you notice if that was the case in the outdated project folder (the one that launched Scrivener, though not the project)?

Conflicted Dropbox files–even without the more bizarre problems you’re seeing–can prevent Scrivener on Windows from opening a project, so normally you’d want to check for any files within the project folder with “conflicted” in their name, or a duplicate project .scrivx file. These would be from a sync conflict where for instance the files hadn’t all completed syncing before you opened on the second machine, and so Dropbox ended up with two versions of a file. I’d still check for that in your case, but since you’ve got files entirely missing, there’s something else going on here too.

Thanks for your quick response, much appreciated.

I cleared the cache on both Mac and Windows, but the phantom folder of the past is still appearing in only the Windows Dropbox. I cleared caches again, deleted the folder from Dropbox, and then uninstalled and reinstalled Dropbox…

It’s still there, alongside the correct, current date folder. I still can’t open the .scriv file shown in the correct folder, and there’s no .scrivx to be found inside that folder.

I can still toggle the .scrivx in the phantom outdated folder, but even that just loads up Scrivener but doesn’t open up a file (just as before).

Completely stumped still. Any other ideas?

I’m having a similar but not quite the same issue. I changed from a Windows PC to Mac as my main computer in September and opened my project from Dropbox without any issues. Recently I tried to open the project from Dropbox on a Windows PC again. Any folders that had been created on the Mac do not show in the Windows environment. However, any edits made to documents in folders that were originally created on the PC do show up in Windows. To see if this was a Dropbox issue I saved the entire project with a new name to a USB drive. Opening on the Windows PC gives exactly the same problem with missing folders.
I did on one occasion manage to get the new folders to show from Dropbox on opening but all of the documents in the folders were empty yet had the correct names. How I achieved that I have no idea.
Clearly we are both having some sort of sync issue but not being that PC savvy is there something simple we are both not doing here? It would appear that the folders are there just that the PC cannot see them.
I would have opened this as a new thread but thought it was closely related to ericw’s issue.

Now it is getting strange. I opened the latest backup file created by the Mac on the PC from Dropbox. I can now see all the folders created on the Mac. I can see the document titles in the folders, but all the documents are blank.
I think I may have to abandon the idea of working on the PC as well. I do not want to find I have emptied a 50k+ project in both original and backup form.