word convertion problem (Japanese, Multi bite language)

I use Japanese Language.

I prefer to edit text with BLACK BACKGROUND and WHTE TEXT than reverse one. So I have changed Appearance setting of Scrivener. Options>Appearance>Colors>Editor>Text and Page.

I entered some text. and tried to convert words. But I could not see the converting words because the text color and convertion area color is almost same. Other applications do NOT have this problem. They obeys IME(Input Method Editor) appearance setting or they have appearance setting properties about it. But Scrivener do not obey the rule, do not have the properties.

How can people who use Japanese edit text on Black Ground with scrivener?

Thank you for bringing this to our attention. Until we’re able to fix this, I’m afraid all I can suggest is to adjust the text colour slightly–if you use a mid-range grey, you may still be able to work in your preferred light-on-black colour scheme but also be able to view the converting words.

Thank you, Jennifer.

if you use a mid-range grey

No, I never use such color. Scrivener ignores IME appearance setting and forced me the color. I cannot change the color of converting text because Scrivener do not have color property of converting text. I want scrivener only to obey IME IME appearance setting, or it is no, to have have color property of converting text itself. If you can not edit text on black background, what do you think about it? It is very lethal to some people.

And I added another problem about converting text.

While converting words, IME menu covers the words. So I can not see the converting word.

Screen shot is blow.

I use ATOK – ATOK is the most popular Jananese IME for professional editor. Its menu appears over the text. Other applications do not have this problem. In other applications IME menu appears beneath the text. Please fix it.