Word Count off?

I am using Scrivener for NaNoWriMo. I entered all my text into their word count verifier, and it comes up different that the word count Scrivener is giving me. It’s off by over 2,000 words, so I know nothing is missing. I’ve tried shutting down and restarting. I’ve tried cutting and pasting all the words. I have no idea what to try next. Please help!

Try Tools > Save and Rebuild Indexes. Close and reopen the project.

Tried that, didn’t work. :frowning:
It’s still showing up as a lower count than it should be.

I am now up to a discrepancy of over 3100 words.

Any explanation?

Different programs count words differently, so some discrepancy is inevitable; and the larger the project, the larger the word-count difference is likely to be as a raw number.

That said, 3,100 words is a significant difference, though not impossible to conceive of in some circumstances.

Some thoughts…

Are you sure you are extracting all the text from Scrivener?

Are you copying and pasting, or compiling to a new file?

If compiling, are all the files and folders being included? No project filters running?

Start a file and type in ten words. Is the count accurate?

This short sample sentence contains exactly ten words in total.

Copy those ten words and paste them ten times. A count of 100 words?

Copy the 100 words and paste them ten times. 1,000 words?

Copy the 1,000 words and paste them ten times. 10,000 words?

Copy those words to the other tool. Same count? Or a discrepancy?

If the count is the same for the test words, it would suggest that something is amiss with how the words are being extracted from the main Scrivener file. If there is a discrepancy, it would suggest that the remote tool is errant as you would know that the source count is accurate.

Have you got other software that can count the words for you, such as Word? If yes, is the count it gives closer to Scrivener or the other tool you used online?

Scrivener gives a word count for each file. If you copy and paste individual files, do you see any material discrepancies in file counts?

Hello Busweet,
Probably stating the obvious, sorry if so, but have you also checked in project / project statistics / options and set all the options how you want them? Can make a huge difference sometimes.

I think that the file must have had a glitch in it. I copied and pasted in a new file, and the word count was “correct.” The one that was wrong was a recovery file, so I wonder if it had something to do with that.

Thanks for all the suggestions!