Word Count Session Target No Longer Updating

Hi there, I’m not sure if this is a bug or if I’m not understanding some of the setting options. I’ve searched through the forums a bit and found other people having word count tracker issues, but none of them seem to be exactly what I’m seeing.

My Session Target no longer makes any sense. I’ll add in some screenshots to show what I mean:

Actually, I can’t attach screen shots because I’m new to this forum so let me paint a word picture.
" Manuscript Target 62963 of 120,000"
" Session Target 0 of 967"
“Deadline: Aug 31st; Days left 59”

The manuscript target portion is accurate, but the Session Target doesn’t correspond with the settings:

Target Options Menu, Draft Target
Count Current Compile Group Only: Checked
Count documents included in Compile: Checked
Overrun: not checked
Deadline checked and set to Aug 31

Session Target Menu
Reset at midnight
Count text anywhere? Not checked
Allow negatives: Checked
Automatically calculate from draft deadline: NOT CHECKED

Note the “Automatically calculate from deadline” is NOT checked. And that’s because when I DO check it, my Session Target disappears completely.

" Manuscript Target 62963 of 120,000"
" Session Target 0 of BLANK"
“Deadline: Aug 31st; Days left 59”

So when I leave it unchecked, I do have a session target and can use that for the day’s word count goal. But then the next day, the total word count session target doesn’t update, it stays at the same number it was yesterday, whether I was under or over my target. For example, it shows I should write 600 some words here–if I write like 3000, as I did yesterday, it will still say 600 session target for tomorrow. To get around this, I have to go into the options, check that box, save, go into the options again, uncheck the box, save, and then I have my word count goal for the day.

This is happening across all of my projects. I have closed down scrivener and reopened. I have checked that everything that I want in the compile is checkmarked for compiling, and I have run a compile to make sure that the compile settings are firm. I cannot remember when this started, but it’s been a while. I’ve been ignoring it because it’s just a few extra button clicks each day, but it’s getting annoying!

Can anyone advise on whether I’m missing something in some other setting menu elsewhere? Or is this a bug? If so, how can I resolve it? I’m slightly terrified of the concept of uninstalling and reinstalling :sweat_smile:


PS, sorry for the lack of screenshots. I’ll update this later if it will let me.

The whole of your issue is there.
But despite having tried for the last 10 minutes, I can’t reproduce.


If someone can figure out how you end up with a blank daily target when you have it calculated per the deadline, what causes it is your problem.

. . . . . . . . . . .
Else, if you happen to have two issues, as for your daily target not reporting anything you write, make sure the document you are writing in is in the draft/manuscript folder :

Also, go to the compile panel, and make sure the filter is not activated. (The funnel. You don’t want it blue.)

As a matter of fact, if you are running a deadline, I think it’d be best not to check “count current compile group only”. You’ll logically want it to track your whole draft (documents to be include in compile) no matter what… (Else, if you have side documents that for some reason you sometimes want to compile (??) then make sure you set the compile panel back on your main draft/manuscript folder after the fact.)

Thanks for your reply!

Yes, the text is in the manuscript folder (two subfolders deep, if that matters). No, the compile filter was not on. The dropdown is set to Manuscript, and the filter is set to Compile: All.

I just changed the settings you mentioned to see what would happen, so Count Text Anywhere, is now checked, but nothing changed. Which is confusing to me in and of itself–I thought that option would then count text in the front matter, character sheets, etc.

Also switched the Count Current Compile Group to unchecked and nothing changed. I also closed and reopened the project after changing all the settings.

I feel like it’s going to be something really stupid that I’m missing and I’m going to have a bright red palm print on my forehead after it’s figured out. :rofl: :woman_facepalming:

Not your current issue, but that’s wrong.
It should be set to “included documents”.

Ok, I’ll change that! Thanks!

You could ask that someone from LL looks at your project…
Since this is all project related settings, they’ll see what’s wrong.
And if nothing is wrong (meaning that the target behaves normally), then I guess it is something local (your computer), and at least you’d know.

Alrighty, that sounds like a good next step. Thanks for your help!

1 Like

Goodness, I knew it was going to be something stupid. I figured it out by chance!

The target number is not blank. It’s the same color as the background, so it’s invisible. When I opened my project on a different computer which was set to a different theme, everything was fine.

The theme I’m using is Grey Matter Dark.

In the meantime, I’ll just switch themes, but does anybody know if any of the display setting in the options menus related fonts in those kinds of calculated fields?

Everything else is fine?
The font color is wrong only for this one setting?

@AntoniDol might know where and what to change.

1 Like


I’ll check and report back…

Here are my screenshots now that I can upload images:

Here’s the shot from Gray Matter Dark
Screenshot 2023-07-08 212349

And now in Dark Mode:
Screenshot 2023-07-08 211713

No settings changed between, other than the themes. Let me know if I can help by providing any other info.



It’s the consequence of disabled text because your daily calculated target is already reached. Apparently the disabled state of this control has a wrong color for the text. I should be white, but is gray or transparent.

Hi there, thanks for your reply. I’m not sure that’s the case though. It’s always blank, not just after I reach the target.

Here’s my view today before I’ve started writing.
Screenshot 2023-07-09 123107

As soon as you check the use of a Deadline, the Spinbox gets disabled and the text in it will be unreadable. When you uncheck the deadline, the text becomes enabled and the text will be white again.

This seems more like a Feature than a Bug, because this works the same for every Spinbox in the GreyMatterDark Theme. When you start the Options dialog. you can see the same thing happening in the “Automatically quit after an inactive period of” Spinbox on the General tab pane.
Curious enough, the disabled text in the Drop-down list just below that Spinbox CAN be read: Daily, Weekly or Monthly (but only just).

Considering this a bug, the solution is to set the text color of the disabled Spinbutton in the Project Targets Dialog to a different color in the QSS Stylesheet of the Theme:

 SCRProjectTargetsDialog QSpinBox:disabled {
    color: gray;   


That will make the disabled text in the Spinbox visible (and also color the arrows to the right of it).

All other Spinboxes will still have invisible text in the disabled state. To correct every Spinbox, remove the SCRProjectTargetsDialog widget from the statement above.

When you don’t want to update the QSS of the GreyMatterDark Theme yourself, you can download this Theme and Import it at the bottom of the Window > Themes menu. When you’ve done that, remember to load the Theme from the same menu and restart Windows.

GrayMatterUpdated.scrtheme (19.0 KB)

Hope this helps


Thank you so much for working on this and for the modified theme. I have no experience with any of that side of things, so I appreciate your help. I loaded up the theme you linked and it worked a charm.