Word Joiner Expands Line / Paragraph Spacing

Insert > Break > Word Joiner visibly expands Line/Paragraph Spacing, though the menu options don’t show any difference.
Example: The name T-Systems. I selected Insert > Break > Word Joiner between the hyphen and the S, and this happened.
I also tested it with unicode FEFF (Zero-Width Non-Break Space) and got the same experience.
If I copy the hyphen from Wikipedia and paste it into Scrivener, or Paste & Match Style, it shows towards the top of the lowecase letters. See image.


Tried it for the first time, so can’t say if it’s a new error.

Unable to reproduce. I tried a couple of different fonts.
(Does the hyphen need to be pasted from wikipedia? (And if so, why would you want to do that?) - I just typed T-Systems and messed around with it.)

My goal is to have hyphenated names on one line. My font is Calibri 11 pt.

You may not be experiencing it because your line / paragraph spacing might be standard. I use the following settings:

So I approached it (1.1) from the zero-width non-breaking space perspective (which might be a deprecated feature if I read some sites correctly, and therefore may not be supported by certain fonts) or (1.2) the Word Joiner alternative and (2) from the non-break hyphen point of view.

Options 1.1 and 1.2 displays my text as expanded.
Option 2 elevates the hyphen higher than usual.

Resolved through OneNote where I was able to find a Non-Breaking Hyphen under Symbols that does not affect my line spacing.

I now have a substitution that replaces the hyphen in T-Systems with a non-breaking hyphen (unicode 2011) not available in Character Map.

That said, certain fonts in Scrivener place the non-breaking hyphen higher than a normal hyphen. This does not happen in Office products like Word or OneNote.

See here in Scrivener: Non-Breaking Hyphen and Normal Hyphen used next to one another for illustration purposes.

Calibri 11 pt

Tahoma 10 pt

Since I’m finnicky about changing fonts, I’ve settled for leaving the non-break (elevated) hyphen (character code: 2011) with my Calibri 11 pt default font.
According to what I’ve read, Calibri doesn’t (or no longer for some obscure reason) support the particular code, so the “system” chooses the character from another font, hence the misalignment. Same goes for more than half the other available fonts I worked through. And the same applies when using the Word Joiner option, where the zero width non-breaking space is most probably pulled from a random font, or from a close font family relative, if such exists.

Compiling to PDF, I get the same misalignment.
But when compiling to Word, Word auto fixes it to look like a normal hyphen but retaining its functionality. Then saving that compilation as a PDF, leaves it in its fixed state. I can only surmise that the Microsoft developers found their own fix that they’re not willing to share because it’s their IP and IP translates to more users and more money in their bulging pockets, which means they’re just full of it.