Word wrap?

Word Wrap may be the wrong term?

  • I started a new project -
  • For some reason was looking at “preferances”
  • Went back to write and my typing went on for infinity on the first line.

How do I get it to go back to wrapping? I have no idea what I did to stop it from wrapping to the next line,

Thank you - knick1

Check the right indent marker on your ruler and adjust to within the viewable editor. It will vary from user to user, dependant on your screen resolution settings and the level of scaling you tolerate for your comfort.

I’m sorry, but I don’t understand this. If I select right alignment then type the typing will align from right to left. If I select left align it will align left to right but at the end of the page it just keeps typing with no stop, never going to to the next line.

Nothing I do keeps the typing on the page. I could type two pages worth of information and it would all appear on one line, running off the end out of sight.

Check your Scrivener Settings/Preferences > Appearance > Main Editor:

I think you have probably switched “Fixed width editor” off.

HTH :slight_smile:



That shouldn’t explain this effect. Try turning it off, or turn it on and enter an absurd value (larger than your screen width). The lines wrap according to the editor width. (or the fixed width if that’s shorter, of course)

To my knowledge, there is no way to have text out of sight (horizontally) in the editor.

I’d reboot.

1 Like

thank you for your trouble, it was the ruler’s right margin tab -

1 Like

OH, I’ll have to look! Thank you!

A bit confused here…

Is the issue resolved or not ?

There is one way to get this result: View ▸ Text Editing ▸ Show Page View (or the preference that would enable that by default in new projects), and then increase your editor zoom so the page is wider than the window. This will work like most word processors do when given those two conflicting requests: you won’t see all of each line and will have to horizontally scroll around a lot.

Scrivener offers some better alternatives in my opinion:

  • For one thing, you can edit using whatever font is most comfortable to you. Having to depend upon magnification is there for familiarity, but unlike a standard word processor it is not your primary tool for making the text easier to read. You can use a 20pt writing font if you really want to, because when you compile this can be converted back down to 12pt or whatever you need.
  • The fixed width view, which is default when Page View is turned off, is often a better choice for keeping line lengths of a readable length, but while acting more like a text editor that wraps to the width of the editor, in the sense that magnifying the text doesn’t increase the size of the fixed width lines beyond the width of the window.
  • And of course you can turn that off as well and have text wrap to however wide the editor is. This can lead to very long and difficult to read lines with smaller fonts, though if your preference is for larger fonts, that probably won’t be an issue. It won’t really matter too much either way though, because as noted above fixed width doesn’t expand beyond the editor anyway, and thus acts as though it were turned off if the editor is narrower than the requested width. Overall this option is better for those insane people that like 14pt text stretching across an entire screen. :crazy_face:
1 Like

It’s called the right-indent marker, like I said, only you replied that you didn’t understand, and then went on to find it yourself anyway.