Wordcount in compiled document has full stop, not comma

Hope it’s okay to have my first post be a bug report.

I did look to see if I could find a report of this already.

When I compile a document (short story) in standard manuscript format, the wordcount tag, $wc100, returns a number with a full stop where the comma used to be. E.g. a story with 7,467 words will return a first page with 7.500 words instead of 7,500 words.

This isn’t a problem for the majority of markets that want doc or rtf files, as I can open the file in a different word processor and change it to a comma, but occasionally a market wants a pdf.

It’s probably not very high priority, but it seems odd that this has changed. I just noticed it one day.


Are you seeing this with other wordcount tags, like 500 or 1000?

(Sorry for the delay in response.)

Yes. It’s showing up there, as well. It’s also not format dependent (so it doesn’t matter whether it’s doc, docx or rtf, for instance).

Thanks for getting back to me.


I think this might be a Windows issue.

Go to “change the date, time or number format” and check what language format you’re set to.

I’m in UK English. My date settings are dd/mm/yyyy. Does this make a difference?

Thanks, Sam

English UK should be okay. It’s just that I was playing around with the Windows options and noticed that it affects how Scrivener compiles.

Under ‘Windows Start’, go to ‘Change the date, time or number format’. Click on ‘Additional Settings’. In the ‘Numbers’ tab, the ‘digit grouping symbol’ should be a comma.

You are a complete star. That has sorted it.

Thank you so much.



Excellent! Glad to hear it :smiley: