Words where "learn spelling" has been applied

I just transferred from Windows to Mac, specifically because of Scrivener, and I’m having so many problems. Per other threads, I found the ~/Library/Spelling/dictionary…and all of my custom words are there. But when I type the word and “right click” to select the correct spelling, it’s not presented in that list. The words already in the document are not being flagged as misspelled, but the new typing/words I can’t change. Most of these words are Gaelic, and have the little tick marks over certain vowels…in Window this wasn’t a problem…so I am hoping this is a simple new-Mac user problem. Hope, hope, hope…

I don’t think I’m having the problem you are describing. If I follow these steps, I get the desired result:

  • Type in something fictitious, like “ewäyf”.
  • Right-click on it and choose “Learn spelling”.
  • Type in “ewyäf” elsewhere.
  • Right-click on it, and “ewäyf” should be one of the options.

I’m not sure how it selects potential words, but if the attempt is too far away from the correct spelling, it may not discover it.

Thank you AmberV for replying -

No, you are not seeing the same thing I am seeing.

For example: “Áed” is in my personal dictionary. I can unlearn the word, relearn it, type in “Aed”, right click and not have “Áed” given to me as an option as a possible spelling…which in Window, I was.

To be fair - it doesn’t look like I get it presented to me in Mac anywhere (like this posting here)…so again, I suspect this is a Mac problem, and how Scrivener uses the Mac dictionary/spelling.

Oh - and the problem I am having is specifically with words that have the accent tick in them…
I’m talking to Apple Support now - with not much luck.

One thing you might not know yet is that it is pretty easy to insert these characters on a Mac. For example to type in the Á character, you just hit Opt-E (might be Alt-E on some keyboards) and then type in the letter you wish to accent that way, capital A in this case. Here is a handy page on the topic. There are a bunch of other symbols as well. Showing the Keyboard Viewer can help you find common symbols. I find them easier to remember than the Alt-### combinations on Windows.

Another thing you could consider is a tool like Typinator or TextExpander. It costs a little, but they are useful for all kinds of things, such as creating extensive auto-correct dictionaries that work Mac-wide.

As you note, we do make use of the global Mac spell check. It is nice to have it everywhere like that, but it does have some limitations, chief among them is that we can’t really do much to change anything about it.

Edit > Spelling & Grammar > Check Spelling While Typing
…ticked/turned on?

System Preferences>Keyboard>Text>Correct spelling automatically
…ticked/turned on?

I tried Ioa’s example on my Mac and it worked fine.

As a workaround, you can set up a system-wide autocorrect list in…
System Preferences>Keyboard>Text
…by adding entries in the symbol and text substitution list.

In addition to Ioa’s suggestion, you can also type accented characters just by holding down the key you want. This is from Apple’s help pages:


Perhaps words which start with a diacritic character aren’t visible in the list of possible corrections because the software looks for the closest/most likely words.

Given that Á probably/possibly appears at the end of the alphabet but A appears at the start of the alphabet, perhaps the spellchecker doesn’t regard Áed as being anywhere close to Aed, and offers other more likely (in its opinion) options instead of the option you expect.

In Norwegian, for example, A is the first letter of the alphabet, but Å is the last.

I think creating autocorrections as mentioned above would do what you want.

I think that Briar Kit has hit the nail on the head. I’ve just done a quick test here. When I typed Áed into Scrivener, it was underlined with red. Selected the option to learn spelling. I then typed in Áde, and one of the options in suggested corrections was Áed. However, when I typed Ade, that option was not present.

Unless you incorrectly spell your word with a fada over the initial letter, it appears that the word you’re looking for won’t be presented as an alternative spelling. When I have occasion to use the fada, I find i easier to simply use the keyboard shortcut outlined by Amber V. Shift-OPT-A in this case for Á, or simply OPT-a for á. This will work on any vowel.

Incidentally, if you’re new to Mac, then the option key actually has alt written on it on it (on my keyboard), along with this symbol: ⌥

Thank you everyone for your replies.
It is not only words that start with the diacritic character…it appears that if the word has a diacritic mark anywhere, it will add it to the global Mac dictionary, but won’t offer it up as an option.

My conversation with Apple Support took me to much of the same place. “As a workaround, you can set up a system-wide autocorrect list in…System Preferences>Keyboard>Text…by adding entries in the symbol and text substitution list.”
This works great if you know how to spell the word.
If you don’t…well, laziness under Windows allowed me to get close enough…guess it’s time to learn how to spell all these words the first time.
For example: Draíochta.
For now, and it seems to be hit or miss on when it picks it up, I added “learned spelling” on Draiochta, and then put the substitution in on the list.

Is…Edit > Spelling & Grammar > Check Spelling While Typing
…ticked/turned on? Yes
Is…System Preferences>Keyboard>Text>Correct spelling automatically
…ticked/turned on? Yes

Thank you so much for your replies. I am VERY new to Mac, really want to fall in love, but there is a learning curve, obviously. Thank you for the couple tips below…these will help!
Holding the key down, and the -a or -a.