Wrong font

I selected a text from the Web,pasted it in the Research folder, opened the Editor from the Draft folder, dragged the text from the Research folder to the Editor, selected the text, entered a font of my choice (courrier-regular-12pt) and pressed the Return key.

The selected text (arial 14pt) changed to the right size (12pt) but remained as Arial, not to the selected Courrier font. I spent the next hour trying different things but Scrivener refused to change the selected text to Courrier.

It is important to note that previous to that, and in the same project, I had no problem with converting any text to Courrier.

Thanks for your help,


I would like to add, that I have no problem (just found that out) with selecting the text and changing it to “Courier New” or some other font. The problem seems to exist only with Courier.

Strange. I will check if the problem is with my Font Manager (FontExplorer X Pro).


I have checked my Font Manager, no problem. I have tested the use of Courier with other writing programs (TextEdit, Mellel) and found no problems. I have followed Scrivener’s instructions about setting Preferences (B.8 Formatting existing document) and my problem remains.

Other strange things are also happening when changing the font in a selected text, at times the font only changes if the existing font size also needs changing … ???

Thanks for your help,



I’m writing this in Scrivener: Is this font Courier ? Yes, but it is “Courier New” not Courier. Courier refuses to be my default font. Now I’m typing this message with Courier New 12pt Regular, and Scrivener’s Formatting window tells me that it is Courier BOLD 12. It is not BOLD …! (of course when pasted in this forum it is no longer in Courier)

Read on the web: “formatting in Scrivener is a huge problem” I think that Scrivener is probably doing the best it can with this very complex subject, the article suggests copying whatever text we want to import from the web, paste it in TextEdit, format it there then copy and paste it in Scrivener. I did that but in Mellel instead of TextEdit and it turned out pretty good, Scrivener pasted it from Mellel using Courier, not Courier New (so my Scrivener can paste Courier text from Mellel but will not start a new document with Courier) ??
Mellel is better than TextEdit for copying text from the web, and can also include images that happen to be within the text being copied. Once Mellel has it correctly reformatted it’s a simple copy and paste to Scrivener (text and images).
Copying stuff from the web, saving it to the Research folder then selecting bits and pieces to include in my Draft, and reformatting all to my chosen font is fundamental for my work. Seems to me that Scrivener should make that process much easier or perhaps Scrivener is not the program that I need for the work that I’m doing (?)


Is Courier set as your default font in preferences, or is it refusing to accept that setting? I ask, because if it is the default font, you can select the document(s) in the binder and Documents->Convert->Formatting to default text style. If that’s not acceptable, then I’ll just butt out and let someone more qualified address your issue.

Thanks for your reply Robert,
When I select Preferences, Formatting, Notes font: I choose English, Courier, Regular,size 12, Scrivener automatically enters BOLD ( in caps) instead of regular but it accepts “Courier” and “12”.

So the “Notes font” window now displays: Courier BOLD 12, when I return to the Editor the format bar shows Courier, Regular, 12

When I start typing (in the Editor) the font is Courier New regular 12 not Courier regular 12. However if I choose Courier Bold 12 then everything becomes normal and I get Courier Bold 12… but I want Normal not Bold…

You may wonder why I do not accept to write with Courier New and the reason is that it is a very different font, lighter, thinner letters.


Sorry Robert, I did not answer your question: you asked if Courier was my default font, no it is not my default font because Scrivener will not let me make Courier-Regular my default font. It will only allow me to have Courier-Bold, not Regular.

I wish someone out there would try making Courier-Regular his/her default font and let me know if Scrivener accepts it. I’m on a MacBook Pro running OS X 10.6.8




I have no problems using Courier regular as the default font. I also have no problems pasting website text in and converting it to Courier. This is on Lion on both a MBP and an iMac.

In my experience (I’ve been using it since Version 1.5 on several OSX versions), Scrivener doesn’t really have any problems with basic formatting such as this: it all ‘just works’, within the known limitations of the Apple text system. This tends to suggest that there’s something amiss with your setup, rather than a bug in Scrivener.

Unfortunately, I have no idea what could be causing your problems. Sorry.

The non-standard aspect of your set-up is FontExplorer X Pro. If I were you, my suspicions would turn towards that program. I would investigate using the standard OS Font Book and see if that turns up anything. A corrupt font file looks like the probable cause, though I hasten to add that I am no expert on these things. I am merely following (or trying to follow) the logic of the case. It would be worth looking at the forums for FontExplorer X Pro (if they exist). I note that on MacUpdate.com the page for FontExplorer X Pro mentions a bug with Adobe CS5 and missing fonts. Worth looking at, I would say.


Thanks for your replies Brookter and Mbbntu,
And huge thanks for taking the time to test Courier-Regular in Scrivener, this tells me that the problem I’m having might be due to my setup here (MacBook Pro, OS X 10.6.8, FontExplorer X Pro font manager). Yes there must be something amiss with my setup.

Mbbntu, I searched for problems with FontExplorer but could not see anything that matched mine.
Just noticed that I have the SAME PROBLEM with TextEdit (not being able to select Courier-Regular for my default font). HOWEVER I don’t have this problem with my Mellel word processor …
Can someone make sense of this ? I feel that I’m wasting way too much time on this problem which might,after all,not be Scriveners’ !


Easy, Andre, the Redlers (Mellel) have written their own text engine; Scrivener — and Nisus and Bean, Yojimbo and many others — uses the text engine provided by Apple, of which TextEdit is Apple’s basic version. So if it doesn’t work in TextEdit and it doesn’t work in Scrivener, it is something that is up with your system.

I don’t use Courier, but on my system — currently MBA running 10.7.4 — Courier works normally and I reckon it would in Scrivener too, though I haven’t tried. I also use the original, free version of FontExplorer X, not the Pro version and have no problem. So this suggests either a corruption in the font on your machine that is not showing up, or some sort of problem with FontExplorer X Pro running under 10.6.8 on your machine.


Thanks Mark,
I agree that “something” must be up with my system, I’ve been running that system (Apple OS X) using many other programs and have not seen that problem elsewhere (doing text in Illustrator and InDesign) . I’ll keep looking for a solution but in the mean time, for my immediate needs, I will explore other programs and might come back to Scrivener later.



Illustrator and InDesign also use Adobe’s own text engine! I’m sure Keith would love to be able to write a text engine specially for Scrivener, but that is a huge undertaking. Nisus have been working on modifying the Apple one for years — since roughly OS-X 10.1 — to get where they are now in terms of functionality, and they have a team, not just one single brilliant programmer.


Hello Mark,Martin and Robert,

I finally solved the problem I had with the Courier font. Never thought to check if it was in the System/Font folder and sure enough it wasn’t there. The Courier font that I had in the folder (and didn’t want) was “Courier New” which apparently is Apple’s default Courier font. I pasted the correct font in the folder and now everything is OK with Scrivener.

Thanks guys, your replies were encouraging.


I have a completely standard system set-up, and Courier is in my System:Fonts folder, so I would assume that at some time it must have been swapped on your system. One is forced to assume that Font Explorer might have been involved, though I’m only guessing. M$ Word might be another possible culprit. Or Adobe.