Yikes! Coverted Files to Folders and underlying text gone

I was messing around with structure on a late-stage novel outline, and decided to convert chapters from files to folders, for no reason other than this has been mentioned several times on the board as a Good Thing, organizationally speaking, and it’s been on my list of things to do for some time.

Trouble is, the files I converted to folders all contained the long, detailed descriptions about what was going to happen in that chapter and why–pretty much a year of work. And now that they’re folders, there’s no text to be seen–under them, arround them, anywhere. I tried converting them back to files, but they’re now blank files.

So how do I get back my year of work? Hopefully without losing the four hours of work that came before the bright idea to perform what seemed such a simple act and turned out to be a disaster.

I backed up the whole drive to an external drive last night and can recover the file as of last night, but that means the four hours this morning is gone–better than losing a year, but maybe there’s another simple thing I’m missing.


I’m afraid this is a long-shot, but: I’ve noticed that if you set your navigation preferences to display Folders as an Edit Scrivenings session by default (in the most recent beta), Scrivener does not display the text associated with that particular folder itself by default when the folder is marked as not to be included in the export. This explains how text could seem to disappear when you convert a file at the top of a hierarchy to a folder. If you perchance enabled this particular navigation setting, and then locked the Edit Scrivenings session (or never exited it by clicking on another file in the binder), you might still not see the text even after you converted the folder back to a file. If that is the case, try making sure the editor is not locked and clicking again on the file (which you converted back from a folder) to exit the session and see if its contents then appear there. Yes, I’m afraid that was a long-shot… --Bryce

1 Like

Thanks for the long shot. As it happens, I was just coming here to reply to myself and tell me that I had been spelunking around in the Preference menu and found something called “When in editor mode, open folders using:”

This was set to “As Corkboard”. I set it to “Using default document mode”, and a year of work magically reappeared.

So, much ado about nothing. Though at the time it didn’t seem like nothing; more like an infarction.

Glad you got this sorted. One of the differences between files and folders is that their default view can be different in the Preferences, as you discovered - folders are by default set to open in corkboard mode, displaying their children. You can of course just click on the corkboard icon to deselect this mode and reveal the text beneath, or you can change the preferences, as you did.

I would generally recommend using folders for items that either don’t require text and are just being used to organise other files, or for items that have text that is used as a title or some such that you will not have to edit very often. But, of course, it’s entirely up to you - and as you have discovered, you don don’t lose any text by messing around with it.

All the best,

Thanks, Keith. What I’ll do, now that my pulse is again stable, is create new files beneath the chapter folders to contain all the plotting foofaraw I had stuffed in the chapter files that became folders. This, of course, is split-new-file-at-selection country, Scivener’s most useful feature after split-screenery.

Hi Ahab,
I’ve just had the exact same problem - converting a file with lots of text to a folder, then losing the text.

Your second post, saying you found a solution in Preferences sounds wonderful! I’ve been looking in Preferences, but so far not found where it says “When in editor mode, open folders using:”
I’m certain this is my problem: Can you remember where you found this in Preferences?
Thanks, Johnn

1 Like

Hi Ahab,
Rather like you, I’ve just a found a solution - by clicking on the text icon at the top next to the corkboard icon. Recovered all text! Thanks, anyway

You do realise that that thread was from 2007, i.e. 17 years ago, and concerned Scrivener v. 1!


Wow. I’ve got, like, Hair again. And my creaky arthritis is miraculously cured. And these old blue jeans totally fit. I could have sworn I binned them after the great Boxing Day leftovers debacle of 2012.

1 Like