Zooming a Multiple Selection

I’m finding that I can not zoom in or out on containers, and multiple selections generally. Has something changed? Or have I managed to not notice that before?

I updated to earlier.

The zoom in/out commands are getting through, but are not reflected in the editor until selecting a single doc. The display stays at whatever zoom level held when the multi was created.

There is a bug with the zoom in Scrivenings mode, tied to the way that the editors are stacked. This has been an unfixable problem for a while, but further changes to Scrienings in 1.7.3 to fix other problems seems to have slightly changed the zoom bug’s behaviour. You may find that although the text doesn’t initially appear to change, if you start clicking around in the editor the text of the paragraph where you click gets larger or smaller, with odd spacing. Or if you scroll after clicking into the editor, you may find paragraphs appearing at different text sizes because of the zoom display bug. Scrivenings text could appear this way prior to 1.7.3 also, particularly for higher zooms or longer documents, but you usually then did see an immediate effect in the editor when scaling with the zoom command, and for smaller sections the bug didn’t always appear.

All that to say, the zoom behaviour you’re seeing is a bug that has been around for a while and but is showing a new face with 1.7.3. We are working to overhaul Scrivenings mode for the next major update, which will make the whole mode work much more smoothly and will resolve this bug.

That’s interesting. It sounds similar or related to something I reported a while back, while still in beta, where when a project is first opened, it displays at a reduced zoom level for a moment before jumping to the last saved setting. There was also a variation of that, where the zoom would not display correctly until the editor’s size was manually adjusted, which forced a redraw at the proper zoom level. In both cases, the status bar always indicates the correct the level, but the display itself is incorrect, which is what’s happening with Scrivenings now.

I still see this fairly regularly when first opening a project, but it seems benign (and perhaps related to my computer being slow, though it’s not otherwise terribly slow) so I’ve been just ignoring it.

FWIW, there are screen shots here. Zoom glitch on project open?