Add a new section layout for a custom scriptwriting format

For my own amusement, I’ve added commentary to a screenplay I’m writing. I’d also like to format the commentary differently, which may be a mistake. I created a new project format (“Script with commentary”) and a new section layout (“Commentary”):

I think I did something wrong. When I try to edit that section layout, it doesn’t have a name and nothing happens when I click the Edit button:

Several questions:

  1. Do scriptwriting formats have a whole lot less flexibility when it comes to compile formatting? In other words, is this a fool’s errand?
  2. If it’s possible to have a script with different section layouts (with different formatting), where did I go wrong, and what can I do better?

I primarily use Scrivener on macOS, but I also use it on Windows (shown above) and iOS.



Not that I am aware of.

Did you, perhaps, skip the part where you “connect” a section type to a section layout ?

1 Like

Do scriptwriting formats have a whole lot less flexibility when it comes to compile formatting? In other words, is this a fool’s errand?

It looks like you are using PDF, which isn’t technically speaking a script format (like Fountain or FDX); you can do whatever you want with it. Bear in mind that Scrivener “scripting” is only a matter of how the text looks. The scriptwriting feature imposes a series of strict formatting rules and an easy way to apply and switch between them. None of that means it ceases to become formatting, and indeed if you created a Layout that overrides formatting it would cease to look like a script.

If it’s possible to have a script with different section layouts (with different formatting), where did I go wrong, and what can I do better?

So given the above, the answer should be clear, but if not: yes you can have a thousand layouts. It’s not a “script”, it just looks like one and will continue to do so unless the sections that have “script” text within them are assigned to Layouts that do not override formatting.

What you are seeing then, is looking more like a bug to me. It should not be possible to create a Section Layout that has no name. I suppose you could create one with a space, but from your screenshot the quotes look empty rather than enclosing a space. Maybe it’s some other kind of weird character that doesn’t have a width—my guess is that you did a typo while creating the layout, and now it isn’t having a good time working with it.

  1. Don’t try to edit it from the preview column, double-click on the “Script with commentary” Format in the left sidebar, instead.
  2. In the Section Layouts pane, arrow through the entries in the top list, looking for a blank row. If you see one, press F2 and type in a proper name.
  3. Save settings—it should now be working as expected, at least to the point of the UI not working right.

If I understand correctly, for what you want to do, you still have some further configuration to work on since your intention is to format “Commentary” sections differently, but currently the layout you’ve made for it doesn’t override formatting.

In case the above does not work, the format may need repair if whatever is wrong is past the point of the front-end being able to fix it. Use the Gear button in the lower left of the compile window to export a copy of the format, and attach it to a response so I can try to get it fixed by hand for you (or just start over from scratch if you haven’t done much yet!).

@Vincent_Vincent : Did you, perhaps, skip the part where you “connect” a section type to a section layout ?

It wouldn’t show up in the preview column at all if it wasn’t assigned to at least one of the Section Types in the project, and we can see from the label above the preview that the “Commentary” section type is using it.

I guess I got confused by the fact that it says “as is”.
I’m not at my computer atm, but I’ll check this out later.
Somehow I’m pretty sure a custom layout is never “as is”.

1 Like

Oh I see what you mean, yeah that could explain the issue as well! They should definitely check to make sure they are using their Layout first.

I was thrown by the fact that it has an edit button in the first place. As a setting that isn’t actually a layout, it should not have one, and if that’s what is going on, that is a bug.



Indeed, pretty useless to have a button to edit a layout that isn’t one. (Not to mention the confusion.)

And like the OP said, clicking on the " Edit “” " button does nothing.

Yes, I did forget. :smiley:

What I really needed to do is go into the Compile Format Designer, click the plus sign in Section Layouts, and create a new section layout (“Comment section”), then assign that section layout to the Commentary section type.

Sadly, unless I select “Override text and notes formatting,” I can’t change the typeface, line spacing, or anything else. (I changed the type size with “Override…” and that seems to have stuck. Confusing.) All those controls are grayed out.

Even then, I don’t know how to change paragraph spacing – blank line before – for only my Commentary section type. Maybe that can only be done in editing, not compiling.


Minor interesting thing: Earlier, I assigned the Commentary section type to the Text Section layout. (The New Page, Title Page, and As-Is layouts all seemed less appropriate.) On macOS (11.6.6, with Scrivener 3.2.3), the Scene and Commentary section layouts are shown together:

On Windows (10.0.19044.1766, with Scrivener, they’re shown separately:

but either way they’re really the same layout. I know, Mac and Windows versions are 99% the same and this is part of the 1%.

Yes. That is how it is supposed to be. Without the override, the output will be according to what is in the editor. So, unless you check the option to override text and notes formatting, you can’t edit the way the demo text looks.
(It would be pointless and uselessly confusing to let the user edit his/her layout’s demo text’s formatting to then not apply those modifications to the output file…)

Once you check the option to Override text and notes formatting, you get full control.
You need to click in the demo text. Then you can tweak the formatting as you please.
Remember that this is per section layout. So make sure you are modifying the right one from the list in the top section.



There is nothing (or at least that I can think of) that can’t be modified at compile.
Anything you do in the editor can be further tweaked (or even changed drastically) at this final stage.

. . . . . . . . . . . . . . . . .
In case you were gonna later ask, these are the paragraph’s indent :

→ First line indent at the top; general indent at the bottom.
And that tiny rectangle below the bottom one moves them both together.

1 Like

Line spacing: I saw “Other” but didn’t click it. That’s exactly what I needed!

Makes sense.

That also makes sense, and mostly works. I did that:

but both in the Compile Overview screen and my compiled document, the commentary text stubbornly continues to look like Courier Prime:

I’m also not seeing separators show up in the compiled output:

Would it help if I duplicated the project, shortened it, replaced the text with Lorem ipsum, and uploaded both the project and the compiled output?

Thanks for all your help, Vincent!

No need at this stage. We’re fine :slight_smile:

Forget that, I just saw that you did it right. (But I’ll leave my screenshot for posterity.)

Your issue is actually here:

It should be like this:

. . . . . . . . . . . .

And for your separators :

Either set the section layouts separators to use default separators, or tweak them the way you want.
As it is, you probably have this option unchecked for them, so, not being told to, your section layouts don’t actually use the separators that you have set (the default separators, in your screenshot).

1 Like

I never in a million years would have scrolled through that huge list of fonts and found “Determined by Section Layout.” (To quote a dotcom executive I used to know, “It’s intuitive once you know how it works.” :grinning:) Thank you so much!

Separators: Yeah, I wasn’t changing the Comment Section layout. I am now:

and it’s working just fine.

I’ve run into a known bug about PDF metadata, but other than that I’m all set.

Thanks again for all your help!

1 Like