Adding Subtitles under Chapters

Hi Guys,

I’m trying to add the first text name as a sub-chapter, but to no avail.

This is my chapter structure:

FOLDER (That’s the Chapter Name)

1st TEXT (That’s the Chapter sub name)

All other texts should have no name.

So the chapters would look like this:



And then the text would follow.

How do I do that? I tried everything, codes, formatting tab, everything.

Many thanks!

The first thing to say is that you do this through the Compilation process, which is very flexible and powerful and can seem daunting – but it’s absolutely at the heart of using Scrivener effectively.

It would really be worth your while over to spend an hour reading through the Interactive Tutorial. It will explain compilation and very much more which will make using Scrivener a lot easier!

Having said that, here’s a quick run through of what you’ll have to do. It looks complicated, but in practice, it’s not really – and you can save these settings so you only have to do it once.

BTW I use a Mac, not Windows, so some of the button names may be slightly different, but this is the general process…

Just to be clear: you want your chapters both numbered and titled:

Chapter One

“You cannot be Sirius,” she said…

This is easy to do when you compile the document.

Basically, you don’t name your chapters ‘Chapter One’, ‘Chapter Two’ etc, you simply name them appropriately in the binder (e.g. ‘Sirius’) and let Scrivener add the ‘Chapter One’ etc automatically.

Go to the Compile dialogue and choose All Options (not Summary). On the left hand side there should be an entry for ‘Formatting’ – select it and you’ll see a table with the headings: Section Type, Title, Meta-data, Synopsis, Notes, Text, with checkboxes for the rows.

The rows themselves may differ according to how you’ve set up your documents but it always have at least 3 rows: a folder, a document group (looks like a stack of papers) and a document (a single sheet of paper). These will be marked Level 1 or 1+. There may be other rows indented below these.

Assuming you’ve got the basic setup in the binder: i.e. your Chapters are folders (and they have no text in them), and your scenes are in documents below the Chapters:

Make sure the Folder Level 1 row has the Title option ticked and all the other entries cleared.

Make sure the Document Level 1 row has only the Text option ticked.

Now click on the Folder Level 1 row – you’ll see the display box below show just the word Title. When you compile the document, this will be changed to display the name of the folder from the Binder – Sirius and so on in your case…

Now you need to add the 'Chapter ’ element. Click on Section Layout. You’ll get a dialogue box which will allow you to add a prefix and a suffix. Type in CHAPTER <$W> and then a carriage return or two (as you want – because you want Sirius to appear on a different line).

The <$W> is a format tag meaning ‘Upper Case Numbers’. You could choose <$t> for title case, or <$n> for arabic numerals or several other options – see the Placeholder Tags List on the Help menu for details.

Close the dialogue box and you’ll see the dummy text now says



NB If you want to format the title, check the ‘Override text and notes formatting’ option above the Folder / Document row panel. You can then select the title components and format them (colour, bold, italic, font etc).

Once it looks the way you want it to, then click on Compile and see what it’s done…

This sounds complicated, I know, but it’s actually fairly logical — and very flexible and powerful — once you’ve grasped the basics.

I’ve given you a quick run-through, but you really need to read the Tutorial to get a full handle on what’s going on.

I hope this gives you a flavour though. Hope it helps…

I tried that, but it didn’t work. : (

So this is how I have my chapters ordered

What I’d like is for the chapters to be like this:

Mr Weltman
All other text files under the Mr. Weltman folder wouldn’t be named, just the first one.

By the way, thank you so much for your quick reply! :slight_smile:

Sorry, what do you mean, it doesn’t work?

Are you saying that the document ‘James’ is a normal scene like the other two in that it has text, but you want only James to have a printed title? I misunderstood, sorry.

The simplest solution I can think of to that is to set up it up as I suggested before (i.e. in the formatting pane of the compile document, Folder has Title checked, Document has Text checked), with optional prefix.

Then, simply type the title (James) at the top of the relevant text in the editor and format it as you want (Bold, italic, whatever). Ie you’ll name it in the Binder (where it will be ignored at compile time), and type it in manually in the text itself (which will are printed). Do this for the first scene in each Chapter (only) and that should do what you want, I think.

I hope!

You put all the text documents in each chapter, except the first, as sub-documents under the first.

In Compile they will show up as different levels, and you click both Title and Text on the first doc, but only Text on the sub’s.

I tried but then James was too close to the text, and I want it to come right after the title, with space toward the text. Like this:

Mr. Weltman

It was a perfect sunny day blah blah…

If I just write the name on the beginning of the chapter, it comes of like this

Mr Weltman

It was a perfect sunny day blah blah…

I tried to do the other setting as you said, but it didn’t work…

My alternative does work.
Don’t make it a folder, just put the rest of the documents in the chapter underneath the first, for which you want the title to appear. Documents can contain documents you know.

Not with Scrivener for Windows.

@Kiara: Documents can contain documents with Scrivener for Windows too.


Your instructions will work, of course (there are many ways of achieving the same result in Scrivener) but only I think if you check the title and text box on the Document Group row (not the Document row) as well. (Document Groups look like a stack of papers.)


If you go down this route, then the compilation formatting panel should look like this (ignore the yellow highlight, that’s only a feature on the Mac I think).

Whichever approach you take (and both will work, you’re going to have to tinker with the spaces between the titles and text. That’s because Scrivener can automatically add a line or a marker between documents when they’re compiled. It’s how you automatically add ### between scenes, for example.

So in the example I showed you, Scrivener has added an extra line-feed between the Folder (Mr Wellman) and the first scene (James).

To adjust this, choose ‘Separators’ in the left hand column (above ‘Formatting’).

You’ll need to adjust the setting for ‘Folder and text separator’ to ‘Single Return’. This will reduce the space between the Title and the subtitle.

You’ll then need to increase the spacing between the subtitle and the text.

If you take my suggestion, you can format the subtitle (James) and the space below in the document itself – you have to do it for every first document of course, but it’s easy to do.

If you follow Lunk’s (equally acceptable) method, you’ll have to make the adjustment in the Compile > Formatting pane. Select the Document Group row, then highlight the word ‘Title’ in the dummy text box. Then click on the spacing tool above the ruler and choose Other and increase the Paragraph Spacing After value to whatever you want. The dummy text will change so you can see the effect.

Whichever way you choose will work, but both will take a little bit of tinkering with to get exactly the effect you want. Once you’ve set it up as you like it, Lunk’s suggestion is less work.

BTW, you began by asking for numbered chapters (CHAPTER ONE) — if you no longer need them, then you don’t need to use Section Layout.


Almost there guys!

The thing is, I can only create a folder below the main chapter (which is also a folder) followed by the scenes. But then the title of the sub-chapter has the same formatting of the first, greater, chapter because it’s a folder too. : (

So I get this:


Bla bla blah

When I need it to be:

Mr. Weltman

blah blah blah

Scrivener doesn’t give me an option to format the sub-chapter heading differently than the main chapter heading : (


I think this is why it would be helpful for you to spend a hour glancing through the tutorial – Folders / Document Groups / Documents are a basic part of Scrivener and they are well explained there, and it will help to visualise what we’re trying to do better.

Basically, both folders and documents can have sub-documents (or sub-folders, in fact) nested many levels deep in any combination.

In your project, you have

Folder (Mr Wellman)
– Document (James)
– Document (Scene 2)

In the binder, drag and drop Scene 2 onto James. You’ll see Scene 2 become indented and James will have a different icon (a stack of papers) to reflect that it is now a Document Group.

Folder (Mr Wellman)
– Document Group (James)
---- Document (Scene 2)

Document Groups and Folders are almost identical (they both contain other folders or documents), but there are subtle differences in the way they behave. One of those differences is that you can format the way the titles look separately for Folders and Document Groups – and that’s why Link is suggesting you use Document Groups: they can be formatted differently from Folders.(*)

BTW, if you’ve created a folder by accident (by the New Folder command), you can turn it into a Document (no sub-documents) or Document Group (with sub-documents) by right clicking and choosing ‘Convert to File’. (You can also turn it back to a folder if you want).

Once you’ve set your binder up this way, you should find that the changes I suggested in the compilation formatting box for Link’s approach will take affect properly.

BTW, please don’t be put off by what must feel like a lot of complexity. You’re trying to do something a little out of the ordinary, so we need to use the advanced features. You would see none of this if you just needed the standard ‘Chapter title, no title for scenes’ layout as that’s a default.


  • There’s a bit more to it that that, because Scrivener is very flexible: you can have different formats for multiple layers of folders, document groups and documents which can cater for several layers of Chapter / Section / Sub-section / sub-sub-section! But that’s not necessary for the approach we’re taking at the moment so you can safely ignore it for now.

Thank you very much brookter : )

I see it now. But what do I do if I have only one scene in a chapter? Like BINDER and then scene one (James) and that’s it? Do I have to create an extra scene?

No. The document directly under the folder level is always the same level.

@brookter: The yellow compile/binder format highlight has been newly added in Scrivener for Windows v1.9.7.0. It is no longer a Mac only feature. :slight_smile:

If I’m reading the above correctly, you could create another document and indent it under your single scene document. This is the only way to change the icon of that scene into that ‘stack’ icon. So create an “intentionally blank” document, indent it under the scene, and then un-check the “include in compile” checkbox in the inspector for the “intentionally blank” document.

In my opinion, if having only one scene in a chapter is uncommon, that this is the easier approach. It’s not the only one, but it’s easier than others that I can think of.

Cool, thanks everyone!


The highlighting is one of the most helpful additions - really makes it clear what’s going on with the compile levels.

There are indeed many ways to achieve the desired result, but I think it would be more intuitive if a chapter subtitle belongs to the chapter container and not to the first scene within it. Because in Scrivener folders can have text too, I would suggest to name the folder “Mr. Wellman” as you did already and then only put “James” in the folder text. In compile settings you select folder title and text and via spacing settings you can arrange the title and subtitle as desired. All scenes, starting with the “James”-scene, then simply add their text to the compile output - no necessity any more to treat the first scene in a chapter different from the rest.

I really tried that but instead of taking the chapter name, Scrivener just gets Chapter One. If I remove the chapter, the title is still ONE when it should be “Mr. Weltman”. I think the must be some sort of code to avoid that <$t or w> or something, but I don’t know which.

I also tried stacking the documents under one document and seeing if it’d take the title of that document. It did, but the problem was that other chapters with only one scene didn’t get picked, and titles appeared also in scenes that weren’t supposed to get titles (because the scenes belonged in the same chapter).
All in all, impossible.

I had to use the folders as sub-chapters and then I had to download Sigil to format one by one.