Another ODF compile problem

Hi using Scrivener 2.4 for Mac and compiling to ODT (in order to use the excellent Zotero ODF scan …).
When you create a footnote in Libre Office it will automatically set it to the ‘Footnote’ style, and that means you can adjust style-wide font etc. My problem is that although Scrivener footnotes correctly land as footnotes in ODT when I compile and then open in Libre Office, they are formatted in LO according to ‘Default Style’. The output I am getting contains a mix of stuff that originated in Scrivener and Zotero, and lands in the footnotes in LO with a mix of fonts and sizes. LO doesn’t allow footnotes to be handled en masse other than by manipulating the style settings - which means I have to individually select each footnote and allocate the correct style … not much fun with hundreds of footnotes!

Is this a problem (ie bug) with the Scrivener compile or something I can address in settings? Or is it a LO problem?

Thanks for any help!


It’s not a bug, it’s just that Scrivener doesn’t support styles and so there is no way to assign the footnote style in the export, I’m afraid.

All the best,

Thanks Keith …
By way of resolving my own problem and for anyone else who may be running into this - as Libre Office doesn’t allow a find/replace for styles eg to convert all Calibri 10 to Footnote style, I tried converting to rtf then doing that in MS Word after running the Zotero ODF scan. Unfortunately even with the footnotes all set to the Footnote style they don’t ‘snap’ back to the right font and I still had to correct them manually.
The best solution (workaround) I have found is to convert all the footnotes to endnotes and then select them as a block and re-impose a font/size on them - then reconvert back to footnotes. Libre Office - you guessed it - won’t do that. I believe Word will, but ended up using Nisus Writer Pro which handled it beautifully.
Cheers Evan


Try This. Create a “new” paragraph style based on default, but don’t change anything in the new style. Name it “Fake_Default” or something like that. Now, select all the text (but not the footnotes/endnotes) in your document and change the style to “Fake_Default.” Next, search and replace paragraph style “Default” as paragraph style “Footnote.”

You might also take a look at “Alternative dialog Find & Replace for Writer,” which is a super-duper tool for the kind of things we need to do as research writers using Scrivener, Zotero, and LibreOffice.

I’ve been kind of fussy about the odt compile recently, but maybe KB will take pity on us and enable us to compile to odt with footnotes and not merely endnotes (in the Windows version, which I use). Does the MAC version support compile to true footnotes in odt?


Scrivener’s inability to deal with footnotes in compile is problematic, particularly when it offers footnote functionality. Though Scrivener does not generally support styles, surely it would not be too difficult to provide that footnotes are properly defined as footnotes when a document is compiled?

The advantage is considerable for those who use Scrivener and Zotero, which I think is becoming the preferred workflow for most academics. Footnotes allow one to hide the Zotero wrappers that can be very distracting to read, particularly if there are many references.

If this could be fixed it would be excellent.

I’m not sure what you mean - Scrivener does export footnotes as footnotes. Footnotes become end-of-page footnotes in ODF, DOC, DOCX and RTF (and PDF when using “Proofing”). If you’re not seeing real footnotes in ODF export, then it may be that the advanced ODF converters aren’t working on your machine for some reason. One thing to try is exporting to RTF and opening that in OpenOffice to check that looks fine.

I’ve had no problems with footnotes in Scrivener, although I don’t export to ODF.

Writing as an academic, few of my colleagues use Scrivener (although the number I have converted is steadily increasing) and I don’t know any academics who use Zotero. So, while I’m sure many academics do use both, I’m equally confident the combination is not “the preferred workflow for most academics” (emphasis added).

Thanks for the response Keith. The issue with footnotes is that those footnotes originating in Scrivener do not behave like other footnotes. This is a problem when (as is always the case), one wants to add further footnotes.

The numbering works, and they are located at the foot of the page, but that’s it. Normal footnotes have footnote style for the text and footnote ref style for the numbering. This means real footnotes and Scrivener footnotes are different sized fonts and different formatting, both in ODF and RTF. The Scrivener ‘footnotes’ are then a devil to change. Even changing each one manually is difficult.

Is there not an easy way to ensure that the Scrivener footnotes are properly created on compile? It would make the use of Zotero close to perfect integration.

@nom: I’d be interested to know which bibliography software, if any, you use with Scrivener, and if it is not Zotero, how you manage to integrate it?

Ah, I think I see what you mean. Are we talking purely about styles here? If so, Scrivener doesn’t support styles, so it can’t export styles in the document. Styles are on the list for Scrivener 3.0.

All the best,

@KB: Yes, that’s about it. Though Scrivener currently doesn’t use styles, is there not a simple addition that could be used at least to add a footnote style to the RTF of ODF on conversion? It would make life much easier.

I (mainly) use EndNote, although am planning to switch to Papers*. Almost all of my colleagues use EndNote (including many of those who use Scrivener), although a few use Papers (to the best of my knowledge, all of these colleagues use Scrivener).

As to how: add the EndNote citation (drag’n’drop or copy & paste usually) when writing, then compile to Word, then prepare bibliography/reference list, then format everything using styles.

*I have used Papers for reference management for many years, since the early days of version 1 long before they added bibliography support in v2, and typically export any references I use from Papers into EndNote for inserting as a citation. This is easy and less time consuming than it sounds. Note: When Mekentosj added bibliography support to Papers 2, it was pretty patchy and I was already part way through my thesis so kept my existing workflow. Now they have released v3.0, citation support looks more capable and so I expect that I will make the switch this year as I begin some new papers for publication.

@nom: with that workflow, do not you not experience exactly the same problems in formatting with either Word or LibreOffice?

I mentioned earlier that I’ve had no problems with footnotes in Word, so I’m not sure which formatting problem you mean. :confused:

The compile issue for foot-or endnotes to either rtf or odf persists when used with Zotero’s odf-scan. Can confirm descriptions by epedrick and later in the thread by alawyer. While odf endnotes compiled from Scrivener appear with even font size as endnotes in Libre or Neo they look like endnotes but are not or only partially responsive to the formatting options. I’m conscious that Scrivener doesn’t do styles (yet) but this does not explain why some of the notes from the same Scriverner document are responsive and others aren’t; if this was purely a style’s issue they either would or wouldn’t be – but not both.
Compiling to rtf of the same document from Scrivener produces an even appearance of fonts, the numbering works, the notes are where they are supposed to be; as long as the doc isn’t scanned with Zotero’s odf-plugin, all looks seemingly well. After the scan the notes appear uneven again and don’t respond to some of the formatting options in Libre. Again, this happens with some but not with others of the notes. I’m still not sure whether this can be fixed from Scrivener’s side, has to do with Libre’s handling of notes or is Zotero’s plugin’s doing.

My current solution is basically epederick’s workaround from earlier in this thread (kramls trick with the Fake_Default didn’t work in my setup):

  • export to rtf from Scriv
  • open the rtf in Nisus, select notes > define as endnote style > save
  • open in Libre, verify notes are recognized as endnote-style (use alt & search) > save as odt
  • scan last odt with Zotero’s odf-scan
    – change the now responsive endnotes as you like

I can live with the workaround but hope the description of the issue to help towards a better solution.

For anyone else using scrivener with Zotero for academic writing - the
problem that I originally reported and that kithairon has just posted on seems to arise from forgetting how Zotero likes to work! The Zotero workaround for Scrivener inserts a text citation marker which can be converted to live citations using the RTF/ODF Scan after having compiled Scrivener to .odt format (more reliably, compile to RTF then convert to .odt). My mistake was to be inserting the text citation markers into scrivener footnotes (either linked or inline). It compiles OK though as others have remarked, sans styles. The Zotero RTF/ODF Scan runs accurately and produces correct live citations in the .odt file, but garbles fonts.
I just edited a section of my work converting the citation text markers from inline footnotes to body text. This does require a bit of basic editing eg. When your footnote had not only the citation but also some comment, although the citation marker itself has a space for prefix and suffix text. Also material that you want in a footnote other than citations can still be left as footnotes.
On compile, the result is perfect - ie I had forgotten the basic fact that Zotero creates footnotes for you when you use a footnote style like Chicago 16 full note. Result - all live citations set up in numbered footnotes with ‘Footer’ style (using Libre Office). The non-citation footnotes that were compiled out of scrivener (eg the occasional cross reference or explanatory comment) are correctly numbered in the eventual LO document but don’t have the Footer style. In my case there aren’t so many of these and it is easy to apply the style manually, especially if you display them as endnotes.
I’m playing with his some more but have to admit it looks like it was neither a Scrivener problem nor a Zotero problem but a user problem …