Attribution style suddenly activated

Ok, there I am, happily typing away at my project when suddenly the text style changes to ‘attribution’ from ‘no style.’ I don’t know why this happens (hence this post) and I cannot replicate it. “It just happens.” It isn’t a big deal as I can just highlight the text and change the style back, but it often refuses to do that. I sometimes have to change the style to ‘block quote’ or something and then to ‘no style’ and all is well.

It’s an annoying disruption. I’m just typing away, not using any keyboard commands or shortcuts or whatever (unless I’m hitting one by accident.)

Not a fix to the bug in itself (say it is a bug to begin with), but I would first check see if that style has a shortcut and remove it.
If no shortcut, I’d delete the style altogether if I am not using it.
If after that it still happens but with another style, I’d seriously investigate.

Hypothesis : Could you by any chance have some remnants in your clipboard ?

According to the styles panel, attribution has no shortcut.

Only ‘attribution’ suddenly appears, never another style.

I don’t think I’m accidenally hitting CMD-V, since nothing is pasted, just the paragraph I’m in gets changed. (Oh, and that is the key point I neglected, it’s just the paragraph I’m in, not any surrounding text. Sometimes it might be just the sentence. I’ll keep track from now on.) So, the clipboard isn’t the reason as far as I can tell.

It’s not just the current project. This happens in others, too. The Project Template doesn’t matter. I’m currently using the Lester Dent template, but it happens in non-fiction and novels.


Do you use that style at all ? What if you delete it ?

“AutoHotKey?” I never heard of that; had to do a search. It appears to be a Windows thing? I use Macs.

Yes, AutoHotKey, or anything equivalent. (I am just brainstorming possible causes.)
Anything that hijacks specific keyboard inputs and spits them out as key combinations.

That’s OK. You’re doing an admirable job of trying to figure this out.

Well, my typing isn’t the best (never took a typing class back in school; I’m ‘self-taught’ by the writing of endless papers in high school and college. As well as pointless stories since then that never see the light of day except by those unfortunates who innocently agreed to read them. So I could be hitting something unintentionally. What that is…?

I might have resolved the issue. Two or three days ago I deleted the attribution style from the project.

Since then…

block quote

…has appeared as mysteriously as attribution had (it’s now on top of the styles list) but only two times. Attribution had been appearing with annoying frequency. So, twice, over a few days for block quote, versus several times over a few hours for attribution.

I can live with that, but it’s still weird. Still don’t know what keystrokes activate this gremlin.

(Not that anyone’s asked, but this isn’t a ‘deal breaker’ for my using Scrivener. I ain’t nevuh givin’ it up.)

1 Like

Looks like keyboard menu navigation to me. (Now more than ever.)
Perhaps blockquote requires one or more extra keystrokes, and that’s why you don’t get it as much. (?)

That’s why I asked about AutoHotKey or anything alike earlier.

There aren’t any keyboard commands for attribution. Block quote is option-command-2, which is weird as I actually recall where my hands were both times and ‘2’ wasn’t near either.

I don’t use any Mac equivalent of AHK.

Beside shortcuts, the menus can be navigated using the keyboard…
Under Windows it’s Alt plus the underscore letter of the desired menu/sub-menu.
Surely Mac has the same (?)

Styles can be selected this way.

Yes, that’s what the screenshot is: a to make block quote I have to either highlight the desired text and select from the styales panel or just have the cursor within the paragraph and then depress the option, command and number 2 keys. But I didn’t do that (at least not all three keys.)

There is a third way. That I described above, and that you might be using unknowingly/accidentaly.

Oh, I understand. I have no idea. I just spent some time poking through all the keyboard settings, accessibility settings involving the keyboard, and any other likely culprit within Mac, there doesn’t appear to be anything along those lines I’m knowingly using.

Oh, well, I’ll just have to keep paying attention and see if it happens while I’m actually looking at the keyboard. Then, try and replicate it.

Try the keys cmd, ctrl whatever a mac has while looking at the top menu.
If their first letter becomes underscored while pressing one of those keys, I put my money on it, that’s step one of your current issue.

Could some mac user please let us know whether the Mac version has this or not ? Thanks.
@kewms @November_Sierra @xiamenese

The only way I can think of is by accidentally entering the “menu search”, but after that point you see what you’re doing, so this is unlikely to cause anything without the user’s active participation.

See also: macos - What is the shortcut to access the menubar in Mac OS X? - Super User

Is there any way to just disable the ability to activate style selection by via keyboard commands?

The problem I outlined in my OP still happens, and it’s always the first style on the list (in this case, Block Quote, since I deleted Attribution.) There doesn’t seem to be any rhyme or reason as to what keys are tapped. Once, I thought it was the OPT or CMD key, followed by another which I didn’t see; but when it has happened since, I am aware of where my hands are on the keyboard, and I swear I’m not hitting the same keys each time. It varies.

I’ve done a search online for Scrivener keyboard commands, just to see what keys need to be tapped to activate a style (and why the first style is always selected, which seems to be a useless option. I can see if I’m hitting keys and random styles are applied, but no!) Came up with nothing.

I am just wondering if there is a way to just prevent the whole thing from happening in the first place. (Afterwards, when I need to apply a style, I would just go directly to the styles menu and go through the drop down menu and pick one that way.)

Sorry to be a bother about this, but it’s annoying. I actually toyed with the idea of using Word (Pages not having a dark mode) to write, but sanity returned and the feeling went away.

FWIW, this has stopped happening. I didn’t do anything, but I think it stopped after Apple released Sonoma 14.3.1 back in February which fixed a bug that seemed to be related, but quite not exactly:
text may unexpectedly duplicate or overlap while typing

Sonoma still does weird things, like all of a sudden Launchpad or Mission Control gets activated for no apparent reason, but I just grumble, whack the ESC key and resume writing.

Over time, Apple assigned more system shortcuts to the Fn key; so it’s possible that you (accidentally) hit it before (I do when I miss ) without noticing negative side effects, but now weird things start to happen, e.g.

Fn A = move focus to Dock
Fn A = open Launchpad
Fn C = open Control Center (menu bar)
Fn D = start Siri dictation (if enabled)
Fn E = open Emoji picker
Fn F = app as Fullscreen window
Fn H = “hide” windows / show Desktop
Fn M = focus to Apple Menu (menu bar)
Fn N = open Notification Center
Fn Q = new Quick note (Notes app)

There are likely more of them lurking in the shadows.