<b24> Jumping cursor revisited

Perhaps it’s me being clumsy, but in beta 24 I’ve had a recurring problem today: 6-7 times today, while I was typing, the blinking cursor (i.e. the insertion point) jumped away from where it should be and ended up where the mouse cursor was hovering inside the same document.

At first, I figured it had to be me inadvertently causing this to happen but after watching carefully, I no longer believe I’m the cause.
I have yet to discover a pattern. As far as I can see it has nothing to do with hitting the end of a line or causing text to wrap.

Has anyone else noticed similar behavior?

If possible try using a different mouse. This is to rule out the problem of the mouse failing with the buttons failing. Also, as is in some cases, you have the latest drivers.

Yes, that is a possibility I’ve considered.
I need to locate a mouse, as I’m mostly using Scrivener on my laptop. The trackpad is rather stiff, so I’m 99% certain I’m not clicking it inadvertently.

It could be a driver problem, but at least I have the latest versions installed and I’ve not seen the problem with other software. (Of course, I do 80% of my typing inside Scrivener)


I had a laptop that would sometimes “assist” me by clicking where the cursor was, automagically, if the cursor hadn’t moved in a while. Make sure that hasn’t been turned on by accident (but you’d see it in other apps, I would think).

If your hands are brushing the trackpad (the fleshy part at the base of the thumb often makes contact, in my experiences with trackpads), they may trigger the behavior no matter how stiff the trackpad is. I eventually turned it off and used a mouse instead. As I recall, there are things about a trackpad’s behavior you can change that may reduce accidental cursor activation. The delay after typing stops before the trackpad can activate was fairly critical (I put it at half a second, I think; it’s been a bit since I used that laptop).

Not sure if that helps.

If no one else sees this, it’s likely just at my end.
I’ll keep my eyes peeled to see if it happens outside Scrivener as well. (So far it hasn’t)

(replying to this old post because i didn’t find any more recent ones.)
I have this jumpy cursor thing all the time and it’s very annoying. I’m typing and all of a sudden I’m typing in another sentence, back a few lines. I’m not sure it jumps back to where the mous cursor is or just randomly.

I only have it with scrivener, so it can’t really be the hardware, though at the same time I wonder: I have it with my HP specter laptop now, I had it with a previous HP specter laptop, and I think I didn’t have it with another type of laptop that I used shortly in between.

Any solution would be appreciated. When it gets too much on my nervous I turn off the touch pad but only being able to navigate with the mouse isn’t the best solution either.


That is likely due to your palm touching the trackpad as you type.
There is another thread with a solution if that is the case.

The thread :

And a potential fix :

1 Like

I am the op for this thread.
By chance, I had the same experience just a week ago when I started using Scrivener again after a long hiatus.
This time, I had a strong suspicion my palm was touching the mousepad on my new laptop. I have been mindful of this possibility, and I have not noticed the issue since.

1 Like

Thanks. if it is my palm and the touchpad, i’d have that in other software too, no? but i don’t.
(plus, I have been mindful of that, and it still happens. conversely, if i purposely touch the pad with my palm, nothing happens, no cursor jumping)

But I’ll look at the suggested solutions.

When I made my original post, I too felt 99,9% sure it only happened in Scrivener. On the other hand, Scrivener is pretty much the only editor-type software I use on that laptop.

Still, I’ll keep my eyes open and report back here if it happens again.


i mean, if it’s not scrivener but the hardware, it should also happen at least on occasion when you’re typing an email, right?

I’ve studied it a bit more, and now i do believe that it jumps to where the mouse cursor is. does that imply another problem/solution?

Many laptops have a Fn key intended to completely turn off the touchpad.
Turn it off, or use this free touchpad blocker :

If the misbehavior doesn’t manifests itself while the touchpad is blocked, well… you’ll have your answer.

(In the event that the touchpad was indeed the source of the problem, note that the app I linked to above is a much better solution than turning off the touchpad, as it activates on its own whenever you type, and deactivates by itself again, a set number of seconds after you are done typing.)

If the text cursor is bouncing over to the position of the mouse cursor, this is evidence that inadvertent fondling of the touchpad is causing the problem, as that is exactly the symptom one would expect to see. Back when I bought my laptop, I had to tweak the Palm Check Threshold of the touchpad, because I was experiencing the same thing. Problem solved.

Do you have a setting like this for your touchpad? If not, it sounds like the software @Vincent_Vincent recommended does the same thing.

But there’s a simple way to prove/disprove this, as @Vincent_Vincent alluded to–turn off the touchpad as a test and see if the problem stops.


thanks jim. again, i find it strange that this jumping wouldn’t occur in other software. but anyway, the touchpad explanation seems to be the most logical, especially because indeed the problem stops when i turnt off (wonder if it could be a combination of touchpad settings AND scrivener)

i’ve been trying to conjure up the synaptics tab in my settings but for now without success, even after downloading the latest driver. continuing to look

Perhaps writing an email is not as exciting as using Scrivener ?


Yeah, on my laptop that option is buried, although I supposed t’s possible there’s a more direct route that I never discovered.

I’m on Windows 10. I search and open Touchpad Settings in Windows Search.

Click on Additional Settings on the right, under Related Settings. That launches Mouse Properties.

Click on Advanced Settings in the Touchpad section to get to the Synaptics Control Panel.

It’s possible your device doesn’t have this option. If that’s the case, the Touchpad Blocker app @Vincent_Vincent linked to upthread sounds like it performs the exact same function. The other thing you can experiment with is tweaking the Touchpad Sensitivity setting in Touchpad Settings, although that’s more of a brute force approach and could produce undesirable results in other ways. I would try Touchpad Blocker first, as it’s specific to the issue.