Beta 022 compile errors

Also on the windows version when I try to compile to PDF, it says that it requires Word to be installed (didn’t in 020.) Linux it produces an “unknown error.”

When compiling an ODT (linux and windows), I’ll get an error that it can’t save to that particular directory. A file is created at the place where I’d saved it, but when I tried opening it in open office/LibreOffice, I’m prompted to repair a corrupt file. (It’ll open after that.)

I’ve attached an ODT made with it. (Unopened by Open Office, so not repaired)

(Zipped because I can’t upload odt stuff.) (7.8 KB)

I am also STILL having problems with the compiling in the novel manuscript. I still have several pages of lines with only one letter so that a 340 page document is close to 700. This was to have been fixed two betas ago. Why is it still a problem?

I’m sorry you’re having troubles. Lee’s April 9th report suggests that it has been fixed for newly created projects, but that for older projects it still requires a manual fix because of the earlier bug:

Are you in fact having it as an issue on projects created in the new beta?

Another compile problem:

I compile a multi-chapter novel to Word .doc format. The first paragraph of each chapter is bold and centred directly under the title.

Note that this is a newly-created project and beta 022 is my very first install of Scrivener.

I tried your fix and it doesn’t change anything when I compile. The document still has hundreds of pages with one letter per line. So, you are telling me that I am going to have to rewrite a 340 page manuscript into a new project? it was beta 2.0 that was the first beta where I had this problem. I tis not even consistent. I have parts of multiple chapters involved and other chapters have no problem.

I cannot even export the affected chapters (I exported it into an .rtf file in the hopes I might be able to copy the text back into the manuscript without having to retype everything) without having the one letter per line. This is not just a compile error.

mtommos - could you please zip up your problem project and send it to so that Lee can take a look?

I sent it earlier this morning my time (PDT). I have been trying to go back into the .rtf file to see if I can get it to work. Sometimes I can get your fix to work but when it does, the margins for the entire document have to be reset because for some reason the margin ruler ends up with the left margin indicator set at 2 inches and the right hand margin indicator set at 0 inches and the whole document is offset to the right. The right number of pages just really wrong margins. Fortunately I do have a compiled document that has the correct margins from beta 1.9.

I have not had the problem with one-character-per-line, however I do have the problems with weird margins. (1" margin on the left, 1/2" margin on the right).

This is a project that was started under Beta 2.0


Compile to .docx does NOT work at all.
Everything seems to work fine, “conversion” starts, then the message saying that MS Word may need to bee installed, a chance to click ok… everything closes, and nothing done.
Most interesting behaviour on a computer with MS Office 2010 installed…

Pdf converts text within one single column of about 1".