Beta 1.6 available … rBeta6.tgz

Any chance of someone kindly offering their help to make a .deb package?


I’ve never made a .deb package before, but I’m willing to try. So far all of the instructions I’ve found want files included that are not in the tarball and that I am not certain how to make, but I’ll continue to use my Google-fu until either a) I succeed, b) someone takes pity and guides me through it, c) someone else just does it, or d) I dissolve into a whimpering ball of despair, unsure of my status as a tool-using mammal with opposable thumbs and a cerebral cortex.

(Or there’s always option e: “What’s that? Ooooooh, shiny! Was I doing something? Who wants to watch FIrefly with the sound down and make up our own lines? I’m a bananinja!”)

Sorry for the double-post, but if anyone was waiting for me to post a .deb, well… Uh, I give up. I am not nearly the tool-using mammal I thought I was, and I humbly beg someone else to do it before I tear my hair out. Pretty please?

My efforts were not a total loss, though–I discovered 1) an issue with the previous .deb that might need corrected by whatever kind soul builds the new one, and 2) a potential filename issue in the 1.6 tarball.

  1. Many files for the 1.5 Linux native beta didn’t install from the .deb (at least on 64-bit Ubuntu 10.10 Maverick systems). This included most of the phonon stuff–Which would account for the terminal buffers full of phonon errors when opening or creating a project. There may be (and probably are) other files that weren’t installing with the 1.5 beta .deb, as well.
  2. The previous Scrivener beta installed as scrivener-beta, but the new file is simply named scrivener. I don’t know if that’s an issue or not, but thought I’d mention it.

Incidentally, are the manual installation instructions on the wiki current? Even after replacing the file name, they didn’t seem to me to much resemble the structure of what the previous .deb installed on my system.

Hi all!

paste and copy:

sudo apt-get update
sudo apt-get install alien
cd ~/Downloads
sudo alien -d LinuxScrivenerBeta6.tgz
sudo dpkg -i linuxscrivenerbeta6_1-2_all.deb

but… nothing happens to my main menu :frowning:
I’ll investigate about this issue and I’ll report here

Perhaps I need to uninstall previous version first…

Followed these instructions, though I had to sudo the alien command. Package seemed to extract okay.

Running scrivener-beta from the prompt netted me “command not found.”


Isn’t alien for .rpm packages?

Alien works for tarballs, but it only wraps up the files already inside, so it won’t produce a .deb like the ones randywallace has been giving us (adding the icon to the menu, putting the command under /bin, etc.). I can take a look at it this evening and see if I can tweak the last .deb with the new beta content, but I’ve never put together a .deb package before, so no promises! If anyone else with more knowledge of this is champing at the bit to create one, please do beat me to it. :slight_smile:

RobHamm, I have no system running 64-bit Linux of any flavor, so I probably won’t be able to help with the 64-bit issues. I also suspect I’ll join you in the hair-tearing.

You rock. Just for the effort.

Me, I’ll probably give it another try, but it will be a bit later, since… Well, did you ever sit down to write and think to yourself, “You know, this things running a bit sluggishly,” then move to “I really should clean things up before I write,” and finally succumb to the dreaded “More guts than brains” syndrome, find yourself at, “Hey, I wonder what will happen if I do this,” and ultimately end up pleading with the computer gods and promising to sacrifice a chicken and a Windows sysadmin if only they’ll grant you this one miracle and do the whole Lazarus thing with your OS?

Why yes, since you ask, my motto IS, in fact, “Test to destruction!” And of course I hadn’t taken a backup first, because hey, what’s the fun of that? So I’ve been busily reinstalling and reconfiguring, etcetera, instead of doing Productive Things like hammering a .tgz into a .deb.

And that was a really long way to go to explain why I haven’t taken another crack at building a .deb. I just wanted you to understand that it was due to my stupidity, and not laziness.

OK, here we go!

As was the case before, the files are available on my webserver!

Sorry for the late packaging :slight_smile:

The packages are also linked below!

Ubuntu Package
Slackware Package

The packages are also available above!

You, sir, are a gentleman and a scholar.

For future reference, though, what tool(s) do you use?

Nothing special, this is the main command I run:

fakeroot dpkg-deb --build scrivener-beta_1.6beta

I could get more complicated with it, and implement a nasty rules file, but haven’t gotten to that. Its easy enough for me to just copy the files where they need to be for ea. release.

Thus, my workflow goes like this:

Step 1: Unpackage the original tarball.
Step 2: Prepare Environment
a: prepare main scrivener-beta_1.Xbeta directory (one for ea. release)
b: create DEBIAN, opt, and usr directories
c: create opt/scrivener-beta and put all the files from the original tarball in there
d: place the control file in DEBIAN
e: place the execution script in usr/bin
f: place the icon in usr/share/icons
g: place the copyright, etc… in usr/share/doc/scrivener-beta
h: update the changelog
Step 3: update the control file
Step 4: run the command above to build the package, using the scrivener-beta_1.Xbeta directory as the main argument
Step 5: run lintian to make sure I didn’t make any grave errors (ignoring the massive amount of library errors due to the precompiled libraries in plugins/)
Step 6: update my own system using dpkg -i and check that everything works right
Step 7: alien on the .deb to get a .tgz. RPM won’t work for ‘all’ arch but I don’t think anyone is using those anyway
Step 8: upload!

@Randy- Thanks. So basically it sounds like I was making it a whole lot more complicated than it is. Looks like the main place where things could go wrong would be the file structure, and all I needed to do there was copy the structure from the older .deb. For that matter, I imagine I could have just edited/replaced files in the old .deb and renamed it if I’d thought of doing so, correct?

yuppo, other than the control file, thats pretty much all you have to do. It is absolutely important, though, that you fakeroot the build, or everything ends up with user permissions that don’t make any sense.

The only real additions that I made were making the .desktop file, finding the icon, and writing the /usr/bin script! As long as those items are in the correct place, most systems should show the icon and run the script from /usr/bin (which should point back to /opt/scrivener-beta/bin/Scrivener, etc…).

Now, there is the whole other matter involving aspell for amd64 etc… etc… but I have a really hard time with understanding all these Ubuntu users who insist on using 64 bit ubuntu. regardless, I just haven’t gotten around to setting up dual debian paths for amd64/i386. All in all, though, its just a matter of dependencies…

Thanks, randywallace, for both the package and the explanation! I too was making it much, much harder than it had to be, and discovered at least half a dozen ways not to create a package properly. :laughing:

Hi, I’m using Linux Mint (which is Ubuntu based). I downloaded and installed the deb package with no errors. However, nothing happens when I click the scriviner icon in the menu. Any ideas?

What happens if you try to run it from the Terminal?

catalinux, you’re a genius, it works! You won’t believe this but I didn’t thing of running it from the terminal :confused:

go to main menu options, from System/Administration.
Browse to Office/Scrivener shortcut, right click on it, change application to application on terminal. Done!
You can find more instructions here

Thanks for the tip. I tried this link but the wiki is down at the moment.

Same problem with XUBUNTU on a Thinkpad T22. Any suggestions?