Beta 29 typing lag

Didn’t want to start a new topic and clutter up the board.

I’m sitll seeing significant keystroke lag with Beta 29, and I can show you how to replicate it. My test machine is running Windows 10 (1909) running on an i5-8600K, 3.6GHz, 16GB RAM, Scrivener 64-bit beta 29. The C drive is a 256GB M.2 drive.

Scrivener beta 29 fresh install, default settings and file locations accepted.

New Project > Fiction > Novel. Saved on my C drive.

Under Manuscript > Chapter > Scene, start writing.

Things are fine.

And then the more words you write, the longer the keystroke lag becomes. Typically, my scenes are not longer than 2000 words, but the more I type, the worse the keystroke lag becomes. There is literally a microsecond delay between me hitting the key and the letter appearing on the screen. I imagine most people might not see this, but I think I am probably a much faster typer than average.

I wonder if it is to do with how Scrivener handles memory - because to take a ridiculous example, if I create a single scene document of 100,000 words, Scrivener is now impossible to use - absolutely slow as molasses in every function, while I am in that scene.

Keeping the 100k scene in the document, if I manage to get out and create a new text scene underneath, and start working in that, we’re back to normality. But then the lag starts to grow, the more I type. Click back in that 100k scene, it’s unusable.

As I mentioned, my typical scenes in a draft are perhaps 2000 words, so the lag never gets to bad that I am typing AHEAD of what appears on screen, although it certainly feels like I’m close. In that 100k test scene, the keystroke delay (once the app starts responding again) is several seconds.

That 100k test might be stupid, but I’ve just done in the same in a new Word document (Office 365) with 1 million words, and there is no lag or hangups at all.

Repeating the same test in Scrivener 1.9 for Windows, there is no lag, no hangups, nothing at all up to about 200,000 words in a single document. If I hit 300,000, then I get a lag starting and the whole app begins to get bogged down, but I don’t know how many words I’d need to freeze the app entirely as in the beta.

Now, there is no way I would ever write like that, obviously, but as a stress test, I think it shows there is something wrong in beta 29. Even in a short scene of 2000 words, the lag is noticeable - again, I don’t lose letters or text, and I don’t type fast enough to start getting ahead of what is appearing on the screen. But it is there, and it gets worse the more I type.

Earlier I had pasted across a large chunk of text from Word (about 10k) into a single Scrivener scene, with the aim of chopping it up into separate scenes, but the sluggishness made it impossible.

I’ve had someone else replicate this on their setup - they reported some lag at 2,000 words (but hardly noticable, and they wouldn’t have seen it if I hadn’t raised the issue), more at 3,000 words. At 100,000 words, a very noticable lag, and at 300,000 words, a lag of several seconds.

This doesn’t happen in Scrivener for Windows 1.9, and doesn’t happen in any other Word processing application tested on the same machine (or indeed here as I type this in Chrome).

Any ideas? Changing the auto-save interval has no effect.

Split to a new topic, since the previous one was about an older, expired beta version. – Katherine

As a general rule, Scrivener is designed around the assumption that you’ll break your manuscript into smaller chunks. If you have 100,000 words in a single document, not only are you likely to have performance issues, you are missing out on most of what Scrivener offers.

But no, you shouldn’t be seeing performance issues at only 2000 words.


Are you serious? Did you even read my post? Of course I don’t have 100,000 words in a single document. I thought I made that very clear.

Time to give up on Scrivener I think. Nobody here has shown the slightest interest in this problem.

There is interest, unfortunately we cannot reproduce this problem and what you describe is very difficult to debug as it might be related to many issues closely related to your computer and/or installed software.

It would be nice, if someone else from the forum can also comment whether they experience the same problem.

Please, upload your demo project together with your exported Options, which might help us reproduce the problem.

Yes, I understand that. I thought I made that clear.

But people – not you – often do run into performance issues because they are using extremely large documents. Since this is a public forum and we encourage people to search to see if their question has been answered, comments that are not directly relevant to the current post can still be helpful for other visitors.


Because I have some year-end stuff that’s important to get done today, instead I created a test project to see if I experienced the typing lag.

I’m on beta 30, and a Lenovo X1 Yoga w/ 8GB RAM, Win10.

I did not experience any typing lag at 50k or at 100k.

At 200k, b30 started slowing down, but typing was still very doable.

At 300k, typing in the doc became so slow it would probably be unusable, but it wasn’t like Scriv completely choked and died.

Copy/paste was slow at 50k words and onwards, but so was copy/paste of that size in Word. Also, interestingly enough, navigating between documents in the binder slowed down considerably when one of them was > 50k.

While doing this test I had memory hog Quicken open, as well as Word and Excel.

FWIW, which probably isn’t much.


Thank You for the feedback, Jim!

This sounds like an issue I ran into with… I think it was Beta 23. It felt to me like the typing lag issue had returned (it WAS really bad at one point). However, I uninstalled it, deleted the directory, and then re-installed it in a completely new directory (not even the same name), and those issues disappeared. So that’s my first suggestion. Uninstall, delete the directory, and re-install into a completely new directory name. I’m not sure why this happens in some installs, but it does. I realize you’ve done this once (you said it was a fresh install, after all). I’ve done this myself – fresh install, and the install didn’t perform well. Not sure why; it just didn’t.

Some other possible issues (not saying they’re probable. Merely possible):
Make sure your SSD is less than 70% full. Scrivener’s manic save rate will amplify SSD performance problems, and cause Scrivener to slow excessively (we’ve had at least one report of this, and clearing data from the SSD solved the problem).
Do not sync with a cloud service while writing in Scrivener. This can cause typing lag.

Scriv should be able to handle 5k without much lag, but this varies a bit with your system. My normal system (Ryzen 5 1600x, 16 GB RAM, multi-TB HD) doesn’t choke on a document of 30k words (just tested). No noticeable keyboard lag. At 117k words (just tested), I can overtype the display (my typing speed, about 80 wpm, 100+ when I’m on a roll). But the program is NOT unresponsive for more than a tenth of a second or so.

My alternate system (i7, 16GB Ram, 750 GB HD) also has no issues with typing lag at nearly 5k per document. I have not formally tested this with Beta 30, but I was recently using it while away from my main machine, and when I loaded a few scenes at 5k+, it handled those just fine.

I’m not sure any of that will help. But it might.