Blinking insertion point with recent update

I was recently prompted to update to the latest version. Now my insertion point is blinking and I cannot find a setting to stop it. Is it possible to still do so? It does feel like going backwards to no longer offer this customization.

That’s no longer supported since v3.2.3 (Oct 2021): “Preferences for disabling insertion point blinking are no longer available on macOS 11 and above. macOS 11 and above do not allow insertion point blinking to be disabled.” (Apple’s decision!) Source: Scrivener Release Notes | Literature & Latte

Thanks for the response!

Do you know if there is a way to install a previous version? Or a workaround?

It should be possible to just download and install an older Scrivener version (I don’t think you want to downgrade macOS?), basically replacing the current installation.

Is it a good idea? I don’t know. Each version comes with bugfixes and improvements.


I see it now in the release notes for MAC,

I have a PC version too and the option appears to be gone there as well.

I have no idea what’s going on with the Windows version, sorry.

In windows it has always been blinking afaict

Downgrading Scrivener will only allow you to see a checkbox that does nothing. We removed the checkbox because Apple removed the capability and the checkbox wasn’t doing anything.

If you want to turn blinking off, you need to revert to an older version of macOS that supports the feature.

I was under the impression that gervaise only upgraded Scrivener, not macOS. :thinking:

I’m using the Mac version 3.3.1 (15588) and my insertion point does not blink. I cannot find a setting, however. Could this be a setting that carried over? The absence of blinking doesn’t agitate my seizures. It’s nice to have.

The manual, Sec. B.3.1 Options, lists a setting for insertion point blinking in Preferences under Editing, but the option is gone in the app, it appears.

What macOS version? If it’s 11 or above (Big Sur, Monterey, Ventura), the text cursor won’t will blink. (And the setting in Scrivener is gone since v3.2.3.)

EDIT: Wait… It is not blinking, but you can’t turn it on? :thinking:

EDIT2: As for how to fix it. I’d upgrade macOS. :wink: (If possible.) Or, and I’m sure someone will explain, why that’s a bad idea… If you export your Scrivener settings, there are two keys in it:



Both should be set to “false” (= not disabled). In theory modifying the settings file and re-importing it should do the trick. But be careful, keep an unmodified backup of that file!

That’s probably just a reminiscence of the function for which LL removed the checkbox.
I’d think that if the OS no longer allows it, that won’t change anything.
But what do I know ?

True, but If the setting somehow got stuck and works (on an older macOS version), but can’t be turned off in the settings… that still sucks.

1 Like

As noted above, the option was removed in 3.2.3 for installations on macOS 11 and greater, because changes in the OS prevented Scrivener’s ability to disable the blinking. The option is still available on earlier versions of macOS. The settings in Scrivener’s preference file thus will work on earlier Mac systems and do nothing on later ones.

That said, there’s a system preference for adjusting the blink interval that will affect various apps using Apple’s text view, including Scrivener. So on Monterey 12.6.5, I was able to essentially disable the insertion point blinking in Scrivener using the following global settings in Terminal:

defaults write -g NSTextInsertionPointBlinkPeriodOn -float 3600000
defaults write -g NSTextInsertionPointBlinkPeriodOff -float 0

Time is in miliseconds, so it blinks once an hour with the above example.

To revert:

defaults delete -g NSTextInsertionPointBlinkPeriodOn
defaults delete -g NSTextInsertionPointBlinkPeriodOff

Thanks so much for this info. Hopefully I won’t brick my Mac trying it. :stuck_out_tongue_winking_eye:

I should clarify that I am on the MacOS beta, 13.4. No blink.

I like the setting info. Will back it up!

This worked – thank you!! Such a relief.

Is there a way to do this?

Refer to the above for a system level “hack” that can adjust this. Apple removed the more straight-forward capability some time ago.