Block Quote not preserved in MultiMarkdown compile

Howdy y’all,

I’m having a hard time getting the Block Quote environment to compile correctly in MultiMarkdown. When I have text in Scrivener marked as a Block Quote, it still comes out in MultiMarkdown without any preceding >, and so the fact that it’s a Block Quote disappears. By contrast, if I put the > in by hand within my text in Scrivener, then the Compile process escapes it: I get \> in the resulting MultiMarkdown, and it’s still not a Block Quote.

I saw this topic with a slightly similar problem. To be honest, I have some Block Quotes with a blue surrounding box, perhaps from material I wrote a while ago. But now when I apply the Block Quote text style, the blue box doesn’t appear anymore. For the text in the blue box, if I put a > within the blue box, the Compile leaves it intact and those come out as Block Quotes in MultiMarkdown. But for my more recent Block Quotes, without the blue box, a preceding > is escaped in Compile and the Block Quote disappears.

So I guess two things are going on:

  1. I can’t get Block Quotes to compile to MultiMarkdown properly; and
  2. I seem to have two different Block Quote environments, even though only the default one appears in the style menu.

Does anyone have any suggestions on what I might do to get this working properly?

Peace out,

Welcome to the forum!

This sounds like it might be formatted in a table. I’m not a Mac person, so I can’t give you the commands, but place your cursor in the text that shows the blue box and look to see if it has table formatting.

Unfortunately I can’t help you with markdown at all. Someone else should chime in shortly…

That’s a good point. But I checked, and it’s clearly a Block Quote environment based on the style menu. My guess, based on the thread I mentioned above, is that the blue-bounded Block Quote environments are holdovers from an earlier version of Scrivener. But I’m really not sure…

I’m using Scrivener for macOS, version 3.3.6.

Thanks for the suggestion!

Peace out,

I wonder if the blue box you are referring to might be that you have Format > Preserve formatting on for those elements.


1 Like

The blue box definitely sounds like “Preserve Formatting” (found toward the bottom of the Format menu), but in the meanwhile you describe what it would be like to start a compile Format from scratch, without doing some basic setup to achieve things the built-in formats already have set up (like block quote conversion).

The “Basic MultiMarkdown” and “Basic Pandoc” starter formats are really vanilla, on purpose. I wouldn’t be shy about considering them similar to “Default”, except that unlike “Default”, they are actually tuned and designed to work for Markdown. One thing they have set up, for example, is wiring some of the basic stock style names to sensible Markdown outputs, like block quotes.

To find where that is on your own, double-click on the compile format you are using in the left sidebar of the main compile overview, and then into the Markdown Options section. For styles to be available here, they must be present in the main Styles list for the format as well.

Next up: it sounds like you have a bad setting turned on for how you want to work. If you want to be able to write with Markdown here and there, you do not want the option turned on to “convert rich text to multimarkdown”. As you have seen, that will escape everything that vaguely resembles Markdown and will generally make using it rather clunky (having to put those blue boxes everywhere by hand, or better yet, a style that achieves similar, and you will note the stock Formats have one for that purpose, which you could add to your project to make use of).

It’s a setting for people that have no clue what it is, no desire to learn it, and want access to LaTeX or whatever. In most cases I would say it’s not the best way to go even if you do fit in the category because it is not very flexible, and there are other ways to do everything it can, piece by piece as you need it, rather than all in one big on/off switch. But for “simple” cases I suppose it is okay.

1 Like

Howdy y’all,

Mark, totally right. Thanks! I hadn’t noticed that.

@AmberV, fantastic! Thanks for helping me understand the Markdown compile format. Since > for block quotes is standard in both Markdown and MultiMarkdown, I thought it would be part of the default compile preset. But your description helped me realize what to do: I had to select Scrivener’s Block Quote as an available style in the compile format, and then I had to map that to the MMD block quote environment within the MMD Options in the compile format. I hadn’t understood that two-step process before. Totally awesome.

Seems to work now. Thanks y’all for all the help!

Peace out,


Yup, that’s mainly because the “Default” format, or the one you get that is very close to that when clicking the “New” button doesn’t have any styles declared in it, so there is nothing that can be set up in that special pane. It doesn’t declare styles because most people using them are rich text users, and even declaring a style will change how it looks from the project, which might be unexpected, and would defeat the purpose of these being places you can start from that do very little, something you can build up from, if that is what you want.

Got it. That’s a very helpful explanation. I think your explanation has been incredibly useful for me for understanding the Scrivener compile system, which has always been the toughest part for me to grok.

I appreciate the help.

Peace out,