Bug in Outline custom date format dd mm yyyy

Added a custom Outline Date field to my project.
Not being American, set the format DD MM YYYY (ie NOT MM DD YYYY).
Enter a value for a document using the date-select dialogue, eg 28/8/22.
In Outliner, displays as “28 1313 2022”

Update (sorry should’ve said): Current version Scrivener just installed; Windows 10.

When reporting bugs, you need to specify which operating system you are using, and what version of the software.

Correct formatting dd-MM-YYYY works fine for me in the Inspector and the Outliner column…

Hi Antoni,
I have an IT background, understand the difficulties when we can’t reproduce a bug. Your reply made me wonder if the hyphens were significant, but I get the same result either way.
Attached are screen snips so you can verify my steps.



I am seeing same here with Scrivener 3.2.3. Can enter date into the column display. Entering the date via the calendar widget in the Inspector for “today” shows 20-0500-2022 in the display in the Inspector. When I change the date with the widget in the Inspector, the date does not change on the Outline view display.

Thinking ‘mmm’ doesn’t play nice with DateTime spinboxes. They don’t know how to spell abbreviated month names. :wink:

The month must be capital Ms.
It works just fine.



. . . . .



. . . . .



[I think mm (not in caps) gives the week/52]

and “mmm” seems off. I saw that, and you see it in your “25-3939-2022” i the above screen shot.

Probably that, not knowing what to do of the third “m”, it interprets it as

. . . . . . . . . .

Scratch that :


“mmm” doesn’t work. “MMM” seems to work. Per the “?” on custom dates, “mmm” not documented to work.

it’s just a display issue. If one changes the custom format without changing the data from ‘mmm’ where it’s wrong, to “MMM” it displays correctly.

Brain fog here, perhaps, but i think this is what I see.

“mm” is supposed to be for the minutes in the time (hours/minutes/seconds) context.


ah. explains it. I get now what you mean about the extra “m”. As I said, “brain fog”.

But unless it is just random luck, it seems to return the week’s number (x/52) in the year/month/day context.

Nevermind, I just verified, it doesn’t. No idea what 39 is.

But the point is that if you use capital Ms as per the instructions, it works.


[Actually, “39” was correctly the minutes of the hour at which I had initially inserted the date in the metadata field. So it (mm) was indeed doing its job right. ← I just noticed, creating the new above screenshot (which I should have left as is, but didn’t. Thought of it too late. Need more coffee.)]


Unicode is case sensitive:

I just tried the two that could have been of interest to me (week of the year / day of the year), but they unfortunately don’t work.

Oh well… (How am I supposed to finish writing my novel now ?? :wink: )

A bug, perhaps, in Windows as it works on macOS …


They are not listed in the instructions… which is already a solid hint.
Do you have them in the instructions ?

Yes. The help (question-mark icon) in the graphic links directly to this page, which details all the field patterns supported by UTS #35 in Scrivener.

Here is what we Windows users get :



I just found this, which also suggests that it is not supported for Windows (Any apps alike) :

But we can date something we did as BC. (Very useful – a must, even, one might say.) Not to mention that it is way more convenient to write “gg” than “BC”.

1 Like

Hah! Case-sensitive (thanks to sobs). Yeesh, cruel and unnatural punishment.
d MM yyyy works.

A simple improvement is to add the words “case sensitive” to the help text. BTW I hadn’t thought to click on the ? field help which might’ve given me the clue.

Thanks for your help; solved.

1 Like