Bug: Instacrash after 3.2 upgrade

I opened Scrivener this morning and it opened successfully. I saw my project, etc.
It popped up a dialog asking if I would like to upgrade to 3.2. I selected the option to upgrade automatically in the future (lol) and pressed “Upgrade and Relaunch”.

It never relaunched and every time I try to launch it myself, it crashes. I’m able to reproduce this 100% – Scrivener won’t launch without crashing.
I attached the first and last crash logs from this morning (just in case they were different).

I am going to uninstall and reinstall now because I want to get some writing done :slight_smile: I hope this is helpful.


Upgraded to 3.2.0 (macOS 10.15.7) and Scrivener is a no go. Just an empty white box in the middle of the screen when trying to open any project. Right-clicking the icon in the dock shows it’s an Internal Error message, but can’t actually see the error message.

Sent in the auto crash-report.

Rebooted - no joy.
Downloaded the installer from the site and tried again - no good.

Downgraded to 3.1.5 and that seems to be working again.

OK, trying to stay calm here but it’s not looking good.

I uninstalled and reinstalled (I moved the old application to the trash, downloaded fresh from literatureandlatte.com/scrivener/download and used the installer) and still having a crash on launch.

Is there some kind of database upgrade screw up??

Crashing on exception: Invalid parameter not satisfying: column >= 0 && column < _columnCount

What is your recommendation to be able to continue using Scrivener? Do you have 3.1 available anywhere … would that help? Is there some other way I should uninstall/reinstall? I’m dead in the water right now…

Attached the new bug report after reinstall.

Thanks @ SarsenLintel for the idea. Luckily I never deleted the old installer. I was successfully able to downgrade to 3.1.5. Crisis averted … Yikes

That’s handy.

For anyone else looking, L&L are good about making previous versions available, you can find 'em all here: literatureandlatte.com/scri … s?os=macOS

Just scroll down past the current version.

3.1.5 has been restored as the main download version on our site until I can work out what is going on here, as we have a bunch of users with this issue. It’s bizarre as we have tested 3.2 on a number of machines - I myself have tested it on 10.14, 10.15, Big Sur, and I’ve tested on more than one computer for each OS - and yet I cannot reproduce the crash at all on any of them. There must be a common factor for all users affected, and finding that is the key.

Questions for users having this problem:

  1. Do you have Pandoc installed?

  2. Do you have LaTeX or PDFTeX installed.

  3. What OS are you on?

Please try:

  1. In the Finder, open the “Go” menu.

  2. Hold down the Shift key on your keyboard so that the “Library” folder appears in the Go menu and select it.

  3. In the “Library” folder window that opens, drill down into the “Preferences” folder.

  4. Find the file entitled "com.literatureandlatte.scrivener3.plist”.

  5. Drag it to your Documents folder.

  6. Now try launching Scrivener.

Does that work? If so, please send the "com.literatureandlatte.scrivener3.plist” file that you put in the Documents folder to us at mac.support@literatureandlatte.com, as that may be the key to finding the issue (this file just contains the settings from the Preferences panel).

If that doesn’t work, please try downloading this build:

literatureandlatte.com//dow … uild_a.zip

(Note that this build is not notarised so macOS may report it as being invalid. If so, Ctrl-click on it and choose “Open” from the contextual menu.)

Does that build work?

If that doesn’t work:

  1. Launch Scrivener 3.2.

  2. Hold down the Shift key and keep holding it down - this will prevent any projects from opening.

Does Scrivener open successfully with no projects? If so, it is probably one of your projects triggering the bug. In that case, go to File > Recent Projects and try opening the latest project, and keep doing it for all recent projects until Scrivener crashes. When you come to a project that crashes Scrivener, please zip up that project and send it to us at mac.support@literatureandlatte.com so that we can find the cause of the crash. (We will delete the project as soon as we’ve found the issue.)


All the best,

Thanks Keith, I’ll try to play around later tonight and see what results I get.

With regards to some of your questions

No Pandoc

No LaTeX or PDFTeX

Catalina 10.15.7

Yes it did. I was able to create a new project, just saved onto my desktop, but it never actually opened on screen. When I downgraded to 3.1.5 and tried that project it said it was already open (so I guess the lock file was there at least).

Mind you that was with a custom template, Will try again later with a blank one and see what happens.

Aha! My project crashes it. Lucky repro. I’ll zip it up and send it to you.
(I don’t have any of those other programs installed)

SHOULD we have Pandoc, LaTeX, and/or PDFTex installed?

How do I even find out? They’re not the sort to be sit in Applications where we can see them, are they?

Searching far Name:pandoc finds nothing.

A search for Name:pdftex finds a ton of pdf-tex matches (Evernote entries).

Name:latex finds binaries probably placed there by the OS (Big Sur).

hi, I was waiting for the 3.2 because I only write in Dark mode, so I was quite impatient !
I finally missed the “official” release but downloaded the test build to give a feedback on a Big Sur fresh install, without nothing else installed in the list you gave, and it works without any problem for the moment.

No Pandoc

No LaTeX or PDFTeX

Catalina 10.15.7

Moved the plist, no change in behavior

Downloaded the 3.2 test copy, installed it fine, opened ok with no project, opened a project fine. However, both with and without a project, it shows the same update error. MBPr, 15", mid-2015, Catalina 10.15.7.

Good luck with it, it’s a strange issue.

I ran the test version uploaded and it works fine on my Big Sur. I upgraded from Catalina to Big Sur Beta to Big Sur official release. I don’t seem to have Pandoc, Latex, or PDFTex on here. So nice to see Dark Mode working again. Hope this helps.

If you don’t know, then you probably don’t have them. These are post-processing tools that might be used with Scrivener-generated Markdown files. They’re not part of the standard Scrivener installation; you would have had to install them deliberately.



with the new build I have the issue with the copy hint, because a project seems to be open, but it isn’t.
everything else seems to be fine.

I have pandoc and latex installed.


Big Sur fresh install on 2017 iMac. The system does not have pandoc or latex installed

I was too late to try the original 3.2 version from yesterday, so can’t test it. I’ve installed the alternative version (14233) and so far, on a quick test only, I’m having no problems, and there’s no clash with my previous preferences, or with the defaults.

BTW, the Big Surification looks good, and there’s obviously a huge amount of work gone into that and into fixing bugs. Thanks!

NB: I haven’t switched the Dock back on to look at the icon yet, but please note that when I do I shall be absolutely outraged that it a) looks different or b) is exactly the same as the last one.

(Seriously, the icon looks good, too…)

Just a quick update on this: I’ve found the underlying cause of the crash - it’s triggered by a workaround I put in place to fix another bug (typically). So I now need to find an alternative fix for the original bug. Fingers crossed this should be sorted by the end of the day.

I’m glad someone likes it!

You’ll always see that copy hint after the app crashes. If you read the full message, it says that you might be seeing the message because the app didn’t close properly, too.

No, you don’t need Pandoc installed (unless you are a Pandoc user who wants to use its formats with Scrivener) , and it turns out that this was a red herring anyway.

I’d be grateful if anyone who encountered this crash could please try this build and let me know if it resolves the issue:

literatureandlatte.com/down … 71120a.zip

Thanks and all the best,

Works for me, no crash! macOS Catalina 10.15.7

Hi Keith,
this version works without a crash on my 2016 MacBook Pro with Big Sur.
Nice work with the new icon :slight_smile:
Overall very good work!
Greetings and have a nice day!

Great, thanks! Hopefully, if I get a few more confirmations that this works, I can restore the update a little later.

All the best,