Bug Report - smart quote backwards after dash / em dash

Character says “What the-” but the closing smart quote appears as an opening quote (backwards) not a closing quote.

Anybody checking bug reports?

Here’s what the bug looks like:

“What the—“

Here’s what it should look like:

“What the— ”

Reported, acknowledged, and found to be an issue with the QT text editor. Reported to them as well. Numerous workarounds explained.

This is still happening. Is there any chance on it getting fixed at some point?

Where do we find the work arounds mentioned?


I’ve got the same issue. Also noted that sometimes after typing an em-dash followed by close quotes that the font size is reduced by one point.

Any pointers to the workarounds?


Sorry, should have said. This is the Mac version of Scrivener 3.2.3

This is normal on a Mac, as well.

The workaround is to create a closing quote by typing ‘Shift > Option > [’ (left bracket).

On a Mac, this gives a closing double quote. In this window here on the site, it also works.

1 Like


This bug still exists on Windows. On my Mac it is fine. Any way to log a proper bug report or do we just do it in the forum like this?


1 Like

Close the quote after the last word, move the cursor back two places with the left arrow key and insert the em-dash.
It’s become second nature in my Scrivener workflow.
(Side note: I use en-dashes and em-dashes so mine are substitutions, two dashes for an en-dash and three for an em-dash, which means it requires an extra space to invoke the substitution. That space is then before the quote closes, which requires pressing Del [who cares if it’s called backwards or forwards delete, we have Windows machines]. After that it’s cursor to the right and—normally—Enter.

1 Like

I reported this nearly two years ago. L&L suggested a workaround. I posted it here: Windows Scriv 3 Typography: Quotation after an em-dash becomes an open quote - #10 by ardenhag


Thanks, I’ve reported the bug.

Thanks, yeah, I’ve been working around it by doing “Blah–”" and then deleting the open mark before the close. But something they should really fix, and I’ve reported it as a bug. I use Scrivener on Mac as well as Windows, and it works fine on Mac, so it’s kinda annoying to remember as I flitter between the two.

I’ve since settled for a 2, 3, 4 solution.
In File > Options Corrections > Edit Substitutions I have the following:

  1. 2 x dashes are replaced by an en-dash
  2. 3 x dashes are replaced by an em-dash
  3. 4 x dashes are replaced by —”

It’s fine for me, since I’m on one operating system only.

Neat idea. I’ll wait to see what they say about fixing it, and if it’s going to be a while, I’ll copy this idea. I can do it across both OS so it’s consistent - it’s not something I want to have to think about as it kills the flow, and I want to limit the errors. Thanks,

1 Like