Can´t Import PDF Files

I am using the latest Scrivener version (0.0.26) and this error persists since the very first version I tried. I have reported it before and made screenshots available here:

It´s not a PDF file problem. I have tested many files (without author´s restrictions) and none of them opened in scrivener. I can open them with my PDF software (PDF Xchangeviewer). I am running windows vista 64 bits.


Beta 026 is missing a file it needs in order to be able to view PDFs within the project window, so I’m guessing that’s the problem here. You can download the missing file and read the instructions on copying it into your Scrivener directory here.

If you’ve already done that, could you provide a few more details on what exactly is happening when you try to import PDFs? Do you get any error messages?

Hi Jennifer,
I was just going to whine about pdf files, and there you are–with an answer.
I downloaded the .dll, and it worked perfectly
Thanks for the fix.

I have tried both your procedure and the new 0.29 version and the problem still persists. What happens had been described and illustrated here: Can't import doc files: Beta 1.7 and 1.8[BUG LOGGED] but I will repeat those steps. Worse yet, a similar problem is happening with the .DOC files. It has happened before, but seemed to be fixed a few versions ago (i don´t know since when it reappeared because I don´t try to import doc files frequently). Here are the screenshots:

PDF Importing Error

  1. Chosen PDF file for importing (file created by me):

  2. Import Warning:

  3. End Result: Empty PDF (0 pages):

Doc Importing Error

  1. Selected .doc (Ms word 97-2003) file:

  2. Import warning:

  3. End Result: A 1 page file with a link to the .doc file. When I click on it, the doc opens on MS Word:

Hope that helps.

I have just found out that I am not able to import PDF files to my projects, but I can import them to the most recent “scrivener interactive tutorial” project (it is not possible to import them to the older interactive tutorial project).

Here are the screenshots:

a) Successful importing - most recent Scrivener interactive tutorial project

b) Error - all other projects (empty PDF - 0 pages)

In case it helps, my PDF software is PDF XChange Viewer … nge-viewer

Hum, this is all very strange. Your default viewer (external to Scrivener) shouldn’t make a difference, although the program you use to create the PDFs might. If you produce a PDF from Scrivener and then try to import that, does it work? Second, do your project titles (that is, the .scriv file name) have any special characters, e.g. accents? It looked like only hyphens in the image, and I tested those and had no problem myself, but I do know there is an issue viewing PDFs in projects that have accented characters in the names, so that might be what’s going on here. Try renaming one of the projects temporarily to something with only Latin characters and see if that makes a difference to the ability to view the PDFs. (Rename the .scriv folder while the project is closed, then open it in Scrivener.)

If that doesn’t make a difference, would you be willing to attach one of the PDFs causing problems (or a sample one that likewise won’t import) to a post here or send it to support AT literatureandlatte DOT com so I can test with that PDF specifically?


You are right. This is really weird. I have just tried what you told me but it didn´t work. Here are the screenshots:

a) PDF file imported using scrivener most recent tutorial project file. It works 100%:

b) The very same PDF file imported using a new project named with only latin characters. Empty PDF.

The problem happens with all PDF files. I will send you the one I have used above. If it is not enough, let me know and I will send you the project file itself.

Thanks a lot.

Here goes the PDF

Thank you.
2001-12-03-senado-parecer-ccj.pdf (41.1 KB)

I have generated a back-up file of the tutorial. When I open it, the same error occurs. To make it clear: I can import the PDF and view it in the tutorial project, but I can´t view it when I open the back up file of the very same project.

Original - works ok

Back up - error

Edit: I have generated a backup file without any dashes in its name and the problem still persists.

If I use the “save as” feature with the tutorial project file, all the PDF files turn blank just like the screenshots above. The name makes to difference. The error happens even when I use only latin characters.

Thanks for all the additional data points. Are you working in an administrator account or a standard account? Likewise, did you run the installer as administrator? I’m still not able to reproduce this issue, even with the PDF you attached, and all I can think is that for some reason a library is missing from your installation. Try reinstalling Scrivener, if you haven’t already, and see if that fixes the issue. (If you want to uninstall your existing copy first, use the “Manage” button in Tools>Options… to save your preferences so you can load them again after the reinstall.) I’ll keep looking into this, but let me know if that helps.

I am running scrivener as an Administrator. I followed your advice. Not only I uninstalled the software but I also manually deleted its folder. I downloaded a new copy of the latest version, but the error still persists. I am able to import the PDF to the tutorial project only. I have attached a project I have just created, maybe it will help. There is a blank pdf inside.
comentarios-codigo-civil-definitivo|attachment (116 KB)

All right, I’m able to see all the PDFs in there. If you’re willing, here’s another test–two, actually.

  1. Are you able to import and view images? Try just importing some of the sample ones from Windows if you have them.

  2. Create a new user account on your machine and try opening the projects there to see if the PDFs are viewable. If so, then we’ll have at least narrowed down that the issue is related to your user account, and that may help find the problem.

Thanks for all the work you’re doing investigating this; I hope to have more helpful news for you soon!

This is getting interesting

Yes, I am able to import and view images.

Amazing. I created another admin account, another project and from there I am able to import PDFs. When I open the same project from my old account, I am still able to import the files. When I create new projects from this old account, I come across the error again.

I don´t understand. This is an admin account. The only difference I noted is that the newer has no PDF software reader associated with the files. I will try doing the same here.

Thanks for your attention.

Bingo. I went to my control panel and removed the PDF association with the PDF software reader. Once there was no software associated with the file, I was able to import the PDF, but only to the projects created after this change. The previous projects still present the error, but this is not important for me.

Thanks a lot.

Thank you for trying all this and for figuring that out! It shouldn’t make a difference, so that’s definitely a strange bug, and thank you very much for tracking it down. And I’m glad you’re able to get working again!

Thank you. I have reassociated the PDF file with the software reader and after removing the association again the error didn´t went away like before. To me it doesn´t matter, because in a few seconds I can create the project from my new admin account and open it from this one. I will perform more tests during the weekend for the sake of helping you out.

Thanks a lot and keep up the good work. I love your software.

I had the same problem here (running Win7).
On the turorial project, the pdf’s showed, but on any new project they didn’t.
Only after I dissociated the .pdf files from any program, using the program on … Vista.html
this software is needed for Win7 and vista, since there is no way on these edition to remove the association, only change it.

After I did this, the pdf’s started to show in the editor, but only for new projects, and and also the tutorial project.

The interesting thing is that the bug affect only project that were created or saved during the time when the .pdf files were associated. When I dissociated, those that were created before, still didn’t show, and those that were new did show up. When I tried associating the .pdf files again, I reverted the situation completely to the way it was before.

It is worth noticing that both me and amilcar run windows with an additional language.

Hope this helps anyone,

I also found out that the bug persists on every project that has non-English characters in its file name or even path (as I tried to place them in libraries that have names in my local languaue Hebrew).