Cannot Activate - esellerate.net domain expired

If you visit activate.esellerate.net or any esellerate.net page there is no site. The domain has expired and is for sale.

I just changed computers and need to reactivate my software to access some important project files. I’m supposed to be revamping a userguide for my company and can’t until I can open my project. I imagine many other customers are having big problems too. HELP!

Both of the addresses that you mentioned work for me (present what appear to be the expected pages) on both an iPad (Safari) and a Windows PC (FireFox). If the domain was expired, it now appears to be renewed and back in business. If you continue to experience this on the new computer, try from another computer and may need some adjustments made to the new computer or the infrastructure it is accessing the Internet via. Good luck.

I am still seeing the problem in my office from FireFox after clearing browser cache and Chrome but was able to access the page from a different location. :wink: I’m hoping it’s just DNS propagation hijinks and that any other user who experiences the same problem will be able to load the correct activation page soon.

eSellerate had some problems today which are now resolved, so please try again. If it doesn’t work, try again a little later, as it may just be that the fixes haven’t propagated to you yet as it can take a while to propagate across the internet. We contacted eSellerate as soon as we became aware of the issue, and they addressed it swiftly. It’s all working again fine for me now.

Were you actually being prompted to activate even though the eSellerate servers weren’t working, though? If so, that’s a bug I need to address. The way I’ve coded it, it’s not supposed to ask for an activation if the eSellerate servers fail - or, at least, if activation fails, it should at least let you keep using Scrivener in this case.

It may just be that I’m running an older version (my next task is to update from .4 to .6) now that I’m back in technical writing season.

What happened was I launched the program for the first time on a computer and it asked me to enter the activation key. I didn’t have the key on me (we bought this for my computer in 2011), so I was prompted to go to activate.esellerate.net. It eventually worked when I opted to log in from a different computer with internet access (my iphone sans wifi) and carefully typed in the code I was given, then typed the activation key back into my computer.

I’m experiencing the same problem. I haven’t been able to access the site esellerate. I was wondering if other people are experiencing the same thing and whether the site is down for everyone else? I can’t get into scrivener at all without it wanting me to manually activate via website.

I also have been prompted by Scrivener to activatate my registration, and, since that’s not working, am unable to use the app. Needless to say, this is a pretty big inconvenience as I use this app for work.

I know! this is insane. It’s my day off and I was going to put some serious hours into my book haha. I guess I’ll have to wait.

It should be working again now - as I said above, there were issues yesterday with eSellerate’s DNS, which they worked to resolve very swiftly, although it can take a day or so for the fix to propagate across the internet. It started working again on my machine last night, so it should be back up and running for everyone very soon if it’s not already.

I’m very sorry that this has caused inconvenience to our users, though. The bigger issue here is not that eSellerate went down for a few hours, but that the code I put in place to ensure such an eventuality wouldn’t cause any interruption to our users clearly failed. I need to fix that, but to do so, I need some more information. Could all of you who had this issue please let me know exactly what Scrivener did - what messages and errors you received? (When I say “exactly”, I don’t mean the wording, given that hopefully you won’t be able to reproduce it now, but just what sorts of things Scrivener ask you to do.)

What should happen is that Scrivener asks you to activate but in so doing, it should receive an error from eSellerate’s servers if eSellerate is down. If it receives any sort of error that indicates it cannot access the eSellerate servers - an internet access error, and eSellerate server error, etc - then it should show a message saying, “Failed to connect to server with error: …” And it should say that Scrivener will try to activate again the next time it is launched, but will continue to run in the meantime. That is, it should continue to work in this situation.

But from the posts in this thread, I assume that this isn’t what people are seeing? So what message did Scrivener throw up when you tried to activate? I’m looking at the code and I can’t see why this is happening, but if someone can tell me which error message they saw, then I’ll be able to see exactly which route the code took.

Many thanks, and my sincere apologies again for this inconvenience. With your help in finding what errors were generated, I will address this so that no one is ever locked out in this situation again - this is something I’ve worked to avoid but have clearly not got it right.

All the best,
Keith

Ok, so this is what happens when I click on Scrivener, it comes up with this message.


then I press ok and it says it’s contacting eSellerate Servers.

After a minute or two it comes up with this.

Now if i click next on “Activate using a web browser on thiss computer,” it brings me to an activation URL. I can’t actually access that activation URL (www.esellerate.net.

Great, thank you. Okay, it seems this is a problem in the eSellerate frameworks. I call on their activation code and pass a flag that tells their coder to prompt the user to manually activate if no internet connection is available. However, it’s clearly getting called even if an internet connection is present but there is a problem with their servers, which is obviously unacceptable. I’m going to get in touch with them now.

Are you still not seeing the eSellerate site up, though? It’s been back up for the best part of a day for me, so it’s strange it hasn’t propagated to you yet. Maybe try resetting your router or rebooting?

Okay, just to follow up on this - just hit “Cancel” in that activation panel. Scrivener should open and work fine. You’ll be nagged to activate each time you open it until it works again - which, as I say, will be very soon as it is propagating - but you can just hit “Cancel” to skip activation until such time as you are able to complete the process. So, Scrivener doesn’t lock you out! (It should still skip this prompt entirely if eSellerate’s site isn’t available, which I’m taking up with them, but for now just know that you can carry on using Scrivener.)

EDIT: Wait, that might not be true. If you have no internet connection the above is true (so a temporary solution is to disconnect wi-fi while you boot up Scrivener), but if you have an internet connection but cannot connect to eSellerate, you may well be booted out. I’m looking into this now.

Yeah, I’ve hit cancel and it comes up with this.


and then this comes up.

Now if I enter my license (automatically filled in and is correct) it starts over again with this.

And of course, if I press ok it comes up with “contacting eSellerate Servers…”

Hi,

I just edited my post - I can see what’s happening. For now, please use the following workaround:

  1. Disconnect wi-fi so that your computer has no internet connection.

  2. Fire up Scrivener and re-enter your registration details.

  3. When manual activation comes up, hit Cancel.

  4. When Scrivener opens, you can connect internet again.

This will allow you to use Scrivener without activation, but you will be prompted to activate each time you launch Scrivener, so will need to do the same each time you launch until you are able to activate - which should be within the next few hours; I’m surprised the fix hasn’t yet propagated to you.

My sincere apologies for this. Obviously the steps above should not be necessary just to open Scrivener while eSellerate has problems, and I’m working to remedy the issue so this will never happen again (so that if eSellerate goes down, you won’t get booted into trial mode just because you can’t activate).

All the best,
Keith

Awesome! It works. Thank you very much.

Great, glad you’re in. Again, I’m really sorry that you’ve had to jump through hoops to work around eSellerate being down. I’ve contacted eSellerate, and once I hear back from them, which I expect will be later today, I’ll start implementing the improvements that will ensure this doesn’t happen again, and get them into the next free update.