Can't keep the font?

Hello, I’m a newbie to Scrivener. While I’m using it, I’ve found a bug.


굴림 is a default (system) font in Korean.
(Pic 1. Before changing the font)

I changed the font like this and saved the file.

(Pic 2. After changing the font)

And then, after closing the file, I reopened the file. So this is the result.

(Pic 3. I used the same pic because the result was the same as Pic 1)

You can see it doesn’t save and keep the font.
I think it should be fixed.
Scrivener has other great features, though.

Thank you for trying Scrivener and for the bug report! We’re looking into this problem. Does this only occur for you when the font you’ve selected has both Korean and English characters in the font name, as in your example?

I was just looking into this to see if I could help, having lived in Korea; last time, taught design in a then-new graduate school, KAIS, which was a while ago. Though I’ve forgotten most of my Korean, I can still work with the text.

First answer is to Starlight. Ioa/Amber, maybe you could email him, as he looks to not be in touch, and I know you have the ability for that from previous work we’ve done.

Starlight, I’ve been able to get your situation to work. You can find a picture below. The way I did so, in the end, was to discover an English-named download of the extra fonts you want, Nanum.

You can get the whole set, including Extra Bold, here, as Windows OTF fonts: Nanum OTF Set

As you’ll know and I could figure out, the main site says the font is free to use for anyone. The page I found the Windows OTF font on is hangeul.naver.com/font.

When you install these fonts, then open Scrivener (or any other text program) you’ll find the fonts under NanumGothicOTF, rather than the Korean/Hangul name. I found Scrivener to handle Regular, Bold, and Extra Bold reasonably well. The Extra Bold will appear as its own NanumGothic fontname in Scrivener.

If you set text in it, any of the Nanum variants will save properly now, and also Compile or Print. If you compile to RTF, Word will successfully show the Nanum font variants, and will print them correctly.

The RTF doesn’t work quite so well for InDesign import (Place), but the text will be there, and you can quickly correct the font types by creating a style and applying it to all your titles, for example.

I also found a little difficulty with the Nanum font as far as how it’s handled in Scrivener compile to PDF: the text isn’t selectable in the PDF. However, if you print from Scrivener to Acrobat, then the PDF comes out ok.

This should give you a practical situation, Starlight, keeping in mind that Scrivener is a writing program, and not a page layout system like Word or InDesign.

Now, what do I have for the team, and before I fall asleep here Thanksgiving eve?

  • indeed, MimeticMouton appears to be on the right track, that full or partial utf-8 font names aren’t handled well.

  • There are a number of furry, funny things in what comes out the compiled RTF for this particular utf-8 font, anyway. The RTF is successfully eaten by Word, but not by InDesign. What’s more, though Word can print well from the RTF at least on simple examples, it can’t save itself in RTF, DOC, DOCX etc. with any better results. Symptoms include mis-labelling of the font targets: Regular, Bold, Extra Bold are not properly assigned. Easy to troubleshoot with the free release of this font, link as above. I didn’t have better results trying export as DOC.

  • one more interesting thing that turned up was a non or pseudo-font, which Scrivener probably doesn’t want to show as it’s not intended for use. Here’s what Adobe has to say about it; the Dov fellow is a prominent person there.

http://forums.adobe.com/message/3996613

You see the mangled fontname, if this font exists on your machine. It looks like ‘dobe’, at the end of the font list when you are choosing a font. If you choose it, the display on the unopened menu is the actual name: ZWAdobeF. I’d suggest making sure the font choice dialog(s) don’t offer that font.

Regards,
Clive

Edited to put in the Adobe link – really was half asleep last night! Happy Thanksgiving, all.

It always occurs when I select some fonts which have Korean characters in their names.
I think it depends on the system language.
I found that it doesn’t occur when the language is English.
(But mine is Korean because I work with Korean documents.)
So, the bug will not appear, though a font has its Korean name if Scrivener can find the English name.
You know, Nanum fonts have both the Korean names and the English ones. And on my computer, Scrivener doesn’t show those English names of Korean fonts.

I’m having busy days.
Thank you for the reply, both of you.

Thanks. Yes, it is specific to the system location setting, and Lee is working on a fix for this. As Clive said, it’s possible to work around it by using a font editor to supply an English name for the font, but obviously that’s not a chore we want to make you go through just to use your fonts! :slight_smile:

Good, sounds like 별빛/Pyolpich (Starlight) will soon have just the right fix from Lee’s expert shop.

I only wanted to clarify for any further troubleshooting then that the issues I found about RTF and Korean fonts only appear to come with this particular font. One of the nicest ones included with Windows, at least for my eyes from a time, is Batang (or even better, Adobe Myongjo if you have that), and it didn’t appear to have any of the problems.

Given the issues were also about handling all aspects of the font name and strength, these issues may go away with the fix you are working on – or not appear with the Korean-named version of the font.

Best to each,
Clive

Annyoung haseiyo, starlight.

Lee has made a new Beta release which has fixes for your Korean font issues.

You can find it here: Beta 1.5.0.6 Release Notes and Installer

Please download and try out, so he can hear from you if all is correct now.

Be sure to install it in a different location from your normal Scrivener, so you keep them separate. The suggestion is to specify [program files]/ScrivenerBeta for the installer, rather than [program files]/Scrivener as it will first suggest.

You can make a separate shortcut on your desktop for this Beta Scrivener, to easily start it, separately from the regular Scrivener.

Thank you for the great work :smiley:

I can’t wait to use it to see how it works.
But I may try with it in some days, since I don’t have a proper computer here.
Maybe the next month? That time, I can be home and install the beta version you made.
I’ll check it January and make a post.

Thank you again.

Today, I tried it and found all is correct.
So I can work with enough fonts.

Thank you again!