Centered *** compiles to left justified

I am using three asterisks on a line on its own to denote a scene break or POV change, etc. I don’t use these prolifically - there’s only 5 instances in the entire manuscript.

I have centred these occurrences in the Scrivener editor BUT when Scrivener compiles, they come out left justified. Any suggestions for what’s going on here and how to fix it?

Not sure if this is relevant but I’m using version 2.7.1 (26120) on OS X 10.11.2 (El Capitan)

  • CDM

If you go into the Formatting compile option pane, you’ll better see what is going on here. As text is processed during compile it can have its formatting cleaned up, and currently that is impacting not only your body text, but special formatting like scene breaks.

In this case, you can simply tell the compiler to not change the alignment of paragraphs. Click on the Options button in the top-right corner of the pane, and enable the “Preserve alignment” override (and optionally the “Centered text only” secondary option, too, both in the middle of the option dialogue.

If that doesn’t work for you, another approach is to declare an exception from the text itself rather than as a global option. Simply select the asterisks line (triple-click works for that) and use the Format/Formatting/Preserve Formatting menu command. As it sounds, this blue box will protect the contents from the compile routines, and is thus useful for things like epigraphs, block quotes, scene breaks or anything that requires something-other-than-body text. :slight_smile:

Thanks! Both solutions worked BUT the second solution (Format/Formatting/Preserve Formatting) caused the centred text to be displayed slightly right of centre - by about the same distance as the normal indent on the first word or a new paragraph. Not sure if that’s just a coincidence or not.

  • CDM

Probably not a coincidence! Check the ruler on the asterisk lines and make sure there isn’t a first-line indent applied to the line. Indents change the width of a line and that changes the centre point, possibly pushing it off of what we might refer to as the objective centre of the text block.

Preserve Formatting is by default very strict, everything in the editor will be passed through to the output (unless you change its scope in the Options panel mentioned earlier).

I should also note that it is possible to have Scrivener handle scene separators for you, in the Separators panel. That method does however require there to be two files adjacent to each other in order to insert something like three asterisks on a line between them. Whether you wish to put each scene into its own “card” on the Corkboard is a personal choice of course, but in case you were not aware of that ability, I figured I’d mention it. When used in this fashion you needn’t worry much about the formatting of separators, typing them in, keeping them preserved, etc.

Indeed there was an indent on the ruler for the centred lines in question so I’ve now fixed that. However, my 3 asterisks are STILL very slightly to the right of centre - only by about a character’s width but enough for me (and presumably others) to notice.

  • CDM

It’s hard to say without knowing more about your settings, I just ran a quick test using your described conditions on an otherwise vanilla compile setup. I started with the “Original” format preset, enabled override formatting and added a generous first-line indent to the paragraph style for output, compiled to PDF, took screenshot and measured the PDF in an image editing program. The middle asterisk’s centre-line was right down the precise middle of the text block (and the paper, in this case, as I had equidistant margins set up from the defaults).

A couple of things I can think of to check for:

  • Enable Format/Options/Show Invisibles and check for any invisible characters prior to the asterisks that might be pushing it to the right. That would be my first guess since you describe the offset as being about one character—or space.
  • The other potential is what I mentioned in aside, and as an extension of the issue with indents: justification is determined by calculating the middle between the left and right text borders not the paper, bet that defined by the first-line indent, block indent, right indent or left and right margins. So if you’re using offset margins for binding or the margins just aren’t equal for whatever reasons, you’ll find centre-aligned material to be off of centre for the sheet of paper, but it should be congruent with the text block.

No hidden characters or stray spaces. I get what you’re saying about where the centre is but it isn’t that it’s off centre relative to the page, as ALL the text is anyway due to the way I have the page set up. It’s slightly off-centre relative to the rest of the text on the page - include the header and footer text. I’ve attached a screen-shot of one of the pages from the compiled PDF to illustrate. Look at the line with just the centered *** and you’ll see it’s slightly more to the right compared to all the other text on the page.

Hmm, yes it is definitely off, but I can’t think of what else might cause that. Just to make sure of one thing, you are using the centre alignment button on the format bar (or Format/Text/Center) for this line, and not a centre-aligned tab stop?

Yes, I’m using the center align button on the button bar (see it here coloured blue because it’s selected.

My suggestion would be to try a format that you can examine more closely. PDF just gives us what amounts to a photograph of the results, but if you compile as RTF then we should see precisely what is going on with the ruler and the line settings in general, even just by dropping the compiled RTF back into the Binder and checking out the separator lines with the formatting tools.

Here are the relevant lines from the compiled RTF:

\cf0 ***

The space preceding the \ appears to be correct and not participating in the displaying of the text. I even tried removing it and it didn’t affect the position on the screen of the three asterisks.

  • CDM

I did some more tinkering and it seems that this problem occurs everywhere the centre align (using the centre align button on the toolbar) is used - anywhere in the project!

OK, I’ve come to the conclusion that this must be a BUG in Scrivener. I’ve just created a brand new project and created a single line with an X that’s centred. It’s STILL off-centre with respect to the page numbering, which IS perfectly centred.

There must still be a setting somewhere that is getting in the way. I had tested things earlier to make sure there wasn’t a common bug, and just did another test with four different lines, using different techniques on each. I expected three of the lines to fail based on their settings, and one to work, aligned to the true middle of the page and the page number at the top and bottom.

The project is attached so you can take a look at the settings and what I’m doing. Hopefully there is a clue, I would also try compiling it yourself to see if you get different results than the compile version I included in the Binder (both have Document Notes to explain what I’m doing and the result I get). (28.3 KB)

I’ve attached the results from what my compiled version looks like and it does look like it’s producing the results you expected.

Great, I would see what is going on in the 4th line then and compare that with the lines you are making, maybe even drop this test file into your project so that it can compile with your actual settings rather than my simulation of them. There must be some difference between the methods if one is in the middle and the other does not.

How do I do that? Better still, can I show you the actual project I have so that you can figure out what’s going on?

Sure, go ahead and just respond to the last e-mail I sent you, with your attachment.

Is there a way I can make it available to just you (i.e., not make it public)? It’s also quite large, as there are quite a few illustrations in the project. I can place it in a dropbox and provide you the link (privately)?

You should have an e-mail from me on the 19th that you can reply to, maybe check your spam folder if not. Or if you can’t find it, just send in a new e-mail to us, and be sure to reference this thread URL in the message so that the support person that receives it can forward it to me (like you did the first time).

When you e-mail us it will be kept confidential, no worries, it goes to a separate system than the forum. And yes, e-mailing a Dropbox link is fine as well. I can just download it that way and share a fix back to you, or just describe it if the fix is simple.