Chapter Numbering

Is there a way auomatically to insert chapter numbers at the beginning of each chapter?

I am certainly no expert, but if each chapter document is titled “Chapter 1” etc., and you check to print document titles when you compile, each chapter should come out with the correct title. Also, if you start with Chapter 1 and add a new document below it, Scrivener will automatically number it Chapter 2 and so on. This has been a great feature for me as I am converting a work-in-progress over to Scrivener and breaking my chapters into scenes. As soon as I split my chapter into the first scene and make it a sub document, each subsequent split is automatically numbered (I use 1.1, 1.2 for my scenes). As long as you don’t check the title box for sub sections when you compile, you will only get the titles for the chapters.

feel safe in knowing that if I have missed the mark, MM or one of the other experts will correct me.

EO

“Nothing beats the love of a good woman, but the affections of a naughty one are a close second.”

Using the novel template, it puts the following variable in each chapter folder:

CHAPTER <$W>

Upon compile, this is replaced with the correct chapter number. I’m not sure if this will be the final solution, but it seems to work well for me now. To add it manually, view the folder as document ‘scrivenings’ and paste this code where you want the chapter to appear. You then just have to make sure the folder/text is included in your compiled documents.

Hope this helps!

You can use the menu to insert the <$W>* part, and that menu item will tell you if it’s going to give you 1,2,3… or ONE, TWO, THREE, or One, Two, Three, or I, II, III…

The menu item can be found here:
Edit -> Insert -> Auto Number

It will just insert the code for that kind of auto-numbering, at which point, you can copy all of the text, including “CHAPTER <$w>” and paste it into the text for each chapter folder.

  • The letter “W” will not necessarily be in there; it determines what kind of numbering you will get, so it can be a lower-case version of the same letter, or an entirely different letter.

The variables can be included in the document titles as well (i.e., what you see in the binder) so that if your document is titled “Chapter <$t>: In which we meet the salamander king”, if you check the box to include titles when you compile the proper number (as a capitalized word, in this case, e.g. One) will be inserted. This way you can move your sections around freely in the binder without having to worry about renumbering everything manually.

Later, as the compile options get beefed up, this will be even cleaner and easier, as you’ll be able to assign a prefix or suffix to titles just at compile time, so you can save space by leaving out the repetitive “Chapter <$t>” from the title when working in Scrivener and just have it added (or even replace the working title) when you compile.

As already mentioned, you can find the list of possible auto-numbering options under Edit>Insert>Auto Number; these will insert the proper variable, and you can of course use that variable (copy/paste or just type it manually) throughout your document for whatever you’re doing.

Thank you, folks. What a helpful community this is :slight_smile:

Thanks for the pointers and for explaining what to expect in the longer term. :slight_smile:
Is there a way to restart numbering at the moment? I’d like to use what appears to be the scene number variable, <$sn> , but right now it’s numbering straight through, so the first scene in Chapter 10 is something like 51.

Thanks!

-Flatiron

Hi flatiron,

Generally speaking, you can use the tag <$rst> to restart the numbering sequence, so for instance <$n>, <$n>, <$rst><$n> would compile as 1, 2, 1. In this case, though, if you’re using the sub-numbering <$sn> tag, it should restart every time you encounter a <$n> tag, so you’d want to use the <$n> tag for your chapters and then the <$sn> for the scenes. As long as you’re compiling both the chapters and scenes, the compiler will increment the chapter number each time you hit a chapter and then reset the sub-numbering to 1 at the beginning of each chapter.

For example, say you’re using the tags in your titles and compiling the titles of your chapters and scenes to make an outline:

Chapter <$n>

  • scene <$sn>
  • scene <$sn>
    Chapter <$n>
  • scene <$sn>

should get you
Chapter 1

  • scene 1
  • scene 2
    Chapter 2
  • scene 1

Thank you so much for the explanation Jennifer! :smiley:

I’m happily using the reset switch, since I’m using the word version of the chapter numbering. But, now that I understand that it’s number and subnumber, it all makes sense.

-Flatiron

Hi MM,

One more question after working with this a bit, and my apologies if you have answered this elsewhere.

I see that there is some autonumbering in the Binder, so if I put a bunch of content in a text named Scene-1 and then use the Split at Selection option as I work through this content (dividing it up into scenes), I get:

Scene-1
Scene-2
Scene-3

Etc.

But, if I then decide that scene 1 is really two scenes, and use Split at Selection to divide it up, I end up with:

Scene-1
Scene-2
Scene-2
Scene-3

Where the second Scene-2 is actually the third scene, and all following scenes now are misnumbered.

Is there any way, other than manually, to renumber these?

Also, one observation about using numbering variables in the binder, is that if I have this:

Scene-<$sn>
Scene-<$sn>
Scene-<$sn>

and I use the Split at Selection on the second one, I get:

Scene-<$sn>
Scene-<$sn>-1
Scene-<$sn>
Scene-<$sn>

Where the autonumbering has been applied to the split off text. Is there a way to turn this off?

Thanks again!

-Flatiron

Hi flatiron,

The hyphen-number is automatically added by Scrivener to differentiate your splits; it’s generally assumed you’re going to retitle the new document to something more meaningful, although obviously that’s not necessary. It’s unrelated to the order in the binder, though; it just tacks on a number to the existing title regardless of placement. So no, there’s not a way to change that.

On the other hand, the number should always increment if the rest of the title is the same, so Scrivener creating a duplicate “Scene-2” is a bug, and I’ve logged that. If you already had Scene-1, Scene-2, and Scene-3, the next one should’ve been Scene-4, no matter in which of the documents you made the split. I realize that’s not going to help your numbering issue, but it will cause less confusion overall.

Also, the focus should jump to the new document’s title in the binder after the split, with the auto-created title selected and ready for you to overwrite, which will make editing the titles as you go much faster.

Probably wasn’t exactly what you wanted to hear, but I hope that helps.

I’m following this thread with interest. I think I did something wrong when I copied my WIP into Scriveners. I typed “Chapter 1” for the title, and hand numbered the scenes. I would like to change to make these automated, but when I use the file menu on my Chapter folder, for example, and then use the File->Insert->Auto numbering, the auto numbering options are disabled. I tried inserting the code into header part, but that didn’t do anything. Any suggestions for getting this to work?

Thanks!

Hm, the auto-numbering being grayed out there is a bug, so I’ll mark that down. You can type it in manually, though, which really will be faster. It’s <$t> for the title-case word. And remember it’s not going to be replaced with a number until you compile, so while you’re working in Scrivener it will still look like “Scene <$t>” or what have you.

Hi MM

Thanks for your help. Unfortunately, I experimented by changing my “Chapter 1” to "Chapter " and compiled. It came out "Chapter ". Then I tried changing the name to " but then I just compiled and received “”. Any more hints?

Thank you!

It looks like you’re using a capital S whereas you should use a dollar sign: $

That was it. It looked like an S to me in the Forum. Thank you!

I realize this is an older topic, but it’s exactly what I was looking for and I feel like I’m missing something obvious. Where do you check the box to include titles in compile? I’ve looked in compile and the general settings, and can’t find it at all!

EDIT: Of course, as soon as I post the question, I find it. For anyone curious, it’s the “formatting” category in compile.

By the way, I would say that using these <$w> auto-numbering thingies in the name of your documents isn’t necessarily the easiest way to title your chapters unless you are absolutely settled on how to title your chapters.

If you chose the Novel template at the beginning of your project, or if you just choose the “Novel Standard Manuscript Format” compile preset as your starting point, then Scrivener will typically start your chapters with “CHAPTER ONE” and then on the next line, use the title of your chapter folder* on a line below it. You can customize all of that by going to your compile window and Looking at the Formatting pane.

By using the compile settings instead of titling all of your documents “Chapter <$w>” or whatever you want, you gain certain advantages. These advantages include the following:

  • You can use meaningful (to you) titles to your chapters, which is helpful when you are doing any revisions; “What what chapter 7 about again?”. You can change the compile setup to exclude those names if you just want “CHAPTER ONE”.
  • If you change your mind about using Roman Numerals, or number-words in all caps (ONE, TWO), you only have to change the auto-numbering symbol in one place.
  • Similarly, if you don’t want to use the word “Chapter” before each number, but just the bare “THREE” or “III” or “3”, you also only have to change that in one place.
  • You can have a distinct way of formatting your chapter headings from the body of the text, even going so far as to use one font for “CHAPTER V” and another font for it’s title.

Note that there is absolutely nothing wrong with doing things the way this thread has outlined. Scrivener is very flexible, and will get more so as the Windows version adds features, so you should always do things the way that makes sense to you. I just wanted to share an ultimately time-saving method (though it is a bit more technical). Happy writing!

I had a question and it seems this thread is closely related to the topic, so I thought I’d ask it here instead of creating a whole new thread.

I often want to compile an individual chapter from my manuscript, however the auto-numbering system appears to only number chapters based on their order in the compile, and not where they are in the manuscript.

So if I compile the entire document it will number them all fine, but if, say, I compiled only Chapter 6-10, it would auto-number from 1 and number them 1-5.

Is there any way to tell the auto-numbering to either begin at a specific number, or begin the count from the beginning of the manuscript?

And if not, is there any intention to do this in a later version of Scrivener?

I have another question too but I’ll ask that in a separate thread.

Just wondering if anyone has any ideas on this question?