Chapters lost in compile

Today was my first attempt at compiling a file for a novel. I had problems with italicised text all being rendered in the compiled file as underlined, non-italicised text.

But I also had another problem.

The manuscript is made up of 37 chapters. The compiled file did not include three of those chapters (7, 8 & 9). It took me forever to work out why the book was six thousand words short, but eventually I found the chapters that were missing.

So I tried another compile - and, sure enough, those three chapters were not ‘ticked’ for inclusion in the final, compiled file.

I have no idea why that might be the case. Can anyone point me to a setting that might have caused this?

It’s a bit of a mystery. Of course I can in future make sure all the chapters are included by checking the tick boxes, but I would like to know why on earth this happened in the first place.

At the moment I am regretting not just sticking with Word.

ron

1 Like

have you tried compiling to Word and taking it from there? seems as if your work in Scrivener might be done if compiling now is so important. just a thought.

I bought Scrivener because it came highly recommended for writers who want to compile their output to a variety of formats. Advice has been given in another thread regarding the font changes, which I should not have brought up a second time here. For that I apologise.

But I am still mystified by how three chapters were ‘unticked’ when I went to compile the document. Presumably I’ve made a mistake to cause that, and I’d welcome any tips to avoid making the same error.

To be honest, I bought and use Scrivener because of its ability to help me, the author, create the manuscript. Now my work is compiled to TXT for input into a LaTex machine. I minimise my fiddling with much of this compile stuff, frankly.

You apparently bought it for its ability to output to a variety of formats. Yes, it does that, but it requires taking an effort to understand how to create and maintain the configuration for each of those many output formats you want. It does indeed have a lot of flexibility and capability and because of that I’m impressed and use it. But I’ve invested the time to learn, and continue to learn, how to do it.

Just seems to me that if you like and can use Word, then compile to DOCX format and use Word to do your final formatting, or pass on to the editor/publisher and let them handle.

Sorry, but beyond trying to get you back into your comfort zone for something so important to you, I don’t have any more recommendations. When I’ve helped other authors in past, we’ve sat down and looked at the settings and worked through it. Doing that here, in a forum, when you need all this done “now” (as I think you said in another posting) is not really going to be effective given your deadlines.

Thanks for taking the time to reply. You are of course right, I need to invest more time in learning the program. I also value the features available to me in the writing stages. But that was when I thought the compiling job would be rather straightforward.

The urgency I talked about was a need to get some readable files out to some volunteers who will quickly give me review feedback. In the end I did it by manually going through a 75,000 word file and changing all the hundreds of examples of underlined text to italicised text, which cost me an hour or three.

Thanks again.

I do need to compile RIGHT NOW, and right now the compile function is converting all italicised text to plain text underlined.

Do I really have to wait for a new version to be released?

I’m not sure what you mean about waiting as your only option. I provided two suitable options in the very paragraph you appear to be referencing (the last in this post). And VeronicaS appears to have gone with the third option of nuking all styles—that’s always there as well (though the way I would do it is different and less destructive. I would delete them from the panel before compiling, it takes a few seconds to do that, compile, and then revert to a backup and continue editing), though I think the two I described are less of a workaround as that is, and more just another legitimate way of using the software.

I confess to not doing very well understanding the instructions you are giving. I have the latest version of the program, and when compiling to either .doc or .PDF files, it is changing my sole variation from standard text (italics) to plain text underlined. That happens when compiling to either .doc or .PDF. It seems that expecting the program to do something fairly intuitive (i.e. not to modify my file) is wrong. I’ll go back and read through it all again. Thanks.

I see the point of confusion. The thread you were posting in was a discussion about a bug that can cause italics to be removed under certain specific conditions—not about italics being deliberately transformed by the compiler to standard manuscript conventions: underlines. I’ve thus merged the digression back into your original thread here to reduce confusion for future readers.

Now if you don’t need underlines, that’s fine, not everyone does these days. In this discussion the individual was actually asking how to turn that feature on, in a compile Format that didn’t do so by default, but the instructions provided there will of course lead you to the right place to turn them off.1

The various compile Formats you can select from, in that left sidebar when you compile, are all documented in the user manual—particularly where they might produce results that do not conform to every person’s individual expectations, like this. Refer to Appendix D.2.3, Manuscript (Courier), for an example. (Which, I just spotted is lacking a cross-reference. I’ll get that fixed for the next revision.)

I couldn’t tell you why, but there are a number of ways to change that setting, and I suppose any one of them might have been accidentally clicked at some point:

  1. If you click on one of the sections in the Draft folder that is marked to be excluded, look on the right-hand side of the text editing footer bar. You should see a page icon with an “X” slashed through it. Click that, and it will acquire a checkmark.
  2. The setting is also in the Metadata tab of the inspector, though that is a little more difficult to get to and accidentally toggle.
  3. Likewise you can add this setting as a column in the Outliner view.

Those are the three main areas where this setting can be changed in the writing area. The only other place is in the compiler itself.


1. As for whether or not it is “intuitive” for the compiler to change your entire layout to standard 12pt Courier manuscript from whatever font you were writing in, but not intuitive to do other transformations—I don’t know. I have long come to the conclusion that this word has become essentially meaningless, and is mainly idiomatic for, “I haven’t learned that yet”. :wink:

3 Likes