Closes after 17 seconds

I think my last update was several days ago and it’s been working fine.

Today I open Scrivener, and it looks like everything is fine, but after about 17 seconds, it closes.

I can make a quick edit, save, close, re-open just fine. But after 17 seconds, it will close no matter what I’m doing.

I got the same problem this afternoon. Uninstall - reinstall doesn’t help.
But switching to the non High DPI Beta resolve the problem (for now). But I’m on a Notebook, which means small screen, so responsive feature is quite important, so I will need High DPI on the future…

Just happened to me. Opened Scriv for the first time in a few days. Updated last week. Closed down several times but now has remained open.

Same thing here. Have never had a problem with past betas, but this morning Scrivener x64 is consistently crashing to desktop after about 15-20 seconds, no matter what I do.

I’ve attempted uninstall/reinstall with no luck. Project files are on my local hard drive, so there’s no network drive issue involved. I can also load Scrivener and leave it at the opening screen, without loading any previous project or session, and it will still crash after about 15-20 seconds. Running it with the logging batch file likewise doesn’t help.

The only success I’ve had here was to install the 32-bit version. That seems to work fine without crashing, and at least allows me to work and have access to my project files.

Still happening.Yesterday it stayed open and usable after about five attempts. Today it won’t remain open at all.

Updated today. The same problem here. After ~20 sec Scrivener closed down several times. Win 10 x64.

Try booting into Safe Mode and disabling your anti-virus/Internet security program.

If Scrivener doesn’t crash after those two measures are in place, then the problem is not with Scrivener per se, it’s that something external to Scrivener is forcing it to shut down.

The next thing I would try is making sure that Scrivener is whitelisted in your AV/security program, so that it is allowed to run and the security program knows to leave it alone.

Thanks for the suggestions, but following your instructions made no difference. It still closes within seconds to a minute after opening.

This is a long shot, but has anybody experiencing this checked File->Options->General->Startup->Automatically quit…?

If it’s off, what happens if you turn it on and change the amount of time to 60 minutes? It’s possible that something flipped the switch on this feature internally and set it for about 20 seconds, with or without actually showing up in the interface, but as likely as that, toggling it on but setting the time to something much longer might override that phantom setting.

Edit: Maybe this is a 32 vs. 64 bit bug? What happens if you uninstall and then install the other “bit version”?

I uninstalled the 64 bit and installed the 32 bit. It’s working, so maybe it is a difference in the “bit version”.

Sounds familiar.

The latest install of Scrivener for Windows Beta has been crashing on me since yesterday (Dec 3), regardless which file I am opening, either after a couple of seconds or after opening, sometimes it also freezes.

Yes, 32bit version is working normally. 64bit constantly crashing.

Could you please run Scrivener using ScrivenerLog.bat from the Scrivener installation folder. Leave Scrivener running and upload the log file(generated with the “log” subfolder) or copy/paste the text contents of the console window. Thanks!

I can launch Scrivener 64-bit with the bat file and create a new blank project, but at no point is a Scrivener\log subfolder created.

cmd line output is:

[code]C:\Program Files\Scrivener>ScrivenerLog.bat

C:\Program Files\Scrivener>rem @echo off

C:\Program Files\Scrivener>“C:\Program Files\Scrivener\Scrivener.exe” --log

C:\Program Files\Scrivener>pause
Press any key to continue . . .[/code]

Sorry, missed to mention, run ScrivenerLog.bat with Admin rights, Shift+Right mouse click > Run as Administrator.

Oops, I fixed it.

To be clear: I was on 64-bit and that was the version that was closing after 17 seconds.

I installed 32-bit, then installed 64-bit and now it’s not crashing.

So I don’t think logs will help now.

It’s doing it again, so with Admin rights, I get the log file. No errors, just warnings. Here’s the end of it:

Info: No PostScript name for family: "SimSun" Info: No PostScript name for family: "Modern" Info: No PostScript name for family: "MingLiU_HKSCS-ExtB" Debug: Auto-Quit timer started. Debug: Auto-Quit timer stopped. Debug: Loading project: "D:/Dropbox/Code/Learning.scriv" Warning: libpng warning: iCCP: known incorrect sRGB profile Warning: libpng warning: iCCP: known incorrect sRGB profile Warning: libpng warning: iCCP: known incorrect sRGB profile Warning: libpng warning: iCCP: known incorrect sRGB profile Warning: libpng warning: iCCP: known incorrect sRGB profile Info: Loading Documents: "6762D961-1212-4C9E-B860-814D7C9492EC" "MySQL / Mongo" Info: "10:52:17.807:Loading RTF file:D:/Dropbox/Code/Learning.scriv/Files/Data/6762D961-1212-4C9E-B860-814D7C9492EC/content.rtf needed 0.005 sec" Info: "10:52:17.807:RTF Markup processing: needed 0.001 sec" Info: "10:52:17.808:Documents Load Time: 'MySQL / Mongo' needed 0.007 sec" Info: "10:52:17.809:Full Load Time: 'MySQL / Mongo' needed 0.008 sec" Info: Loading Documents: "5CF5ABA4-5B8C-44D9-8EBD-816DED10FD80" "Unable connect IIS Express" Info: "10:52:17.922:Loading RTF file:D:/Dropbox/Code/Learning.scriv/Files/Data/5CF5ABA4-5B8C-44D9-8EBD-816DED10FD80/content.rtf needed 0.002 sec" Info: "10:52:17.922:RTF Markup processing: needed 0.000 sec" Info: "10:52:17.922:Documents Load Time: 'Unable connect IIS Express' needed 0.002 sec" Info: "10:52:17.923:Full Load Time: 'Unable connect IIS Express' needed 0.004 sec" Warning: QObject::connect: No such slot SCRMainWindow::zoomTo(int)

32 bit version seems to be working here, too, on a 64 bit system.

Thanks for the log file snippet guys. Do you experience the crash after reinstalling the 64bit version of Scrivener, or it happens only after using the automatic update?

I’ll just add my two-pennorth. Non-hidpi works for me but RC 64 bit doesn’t. In both cases I follow this procedure:

  1. Uninstall existing version.
  2. Restart PC to help clean out any rubbish - can’t do any harm.
  3. Install new version.

I have tried running the 64 bit installer as administrator and without, No difference.

Scrivener.exe has also been whitelisted in F-Secure in case that was an issue.

My post headed “RC13 closes after opening” relates to this issue.