Comment Box Questions

I have no idea how you got that fancy box with the “previous/next” arrows and the “delete” function…

image

All I get is a simple box :

image

image

@AmberV @kewms @MimeticMouton

  1. Select some text (a word or two)
  2. Click
    Inked2022-04-05 14_37_52-Window_LI
  3. insert text to the newly created comment/footnote
  4. Hover the word you had selected in step 1

@LattePhoenix

To rather get the preview of the comment/footnote the way I do, CHECK THIS OPTION :



P.S. @AmberV , there seems to be a bug here as I can’t get the popup to work by clicking on text that is assigned a comment/footnote. I uncheck
image
… but it doesn’t change anything for me.
→ Even Alt+click on the comment/footnote doesn’t work.
[EDIT : OK, I managed to make it work. For some reason, it seems that I had to first click on one of my comments/footnotes once with the inspector hidden to trigger the behavior. It works as it is supposed to now.] (I undertand that it has to be “impossible” to display the comment/footnote to trigger the popup, but before that, being on another pane didn’t work either. Unlike now.)
image

Alt+click when the option is checked still doesn’t work tho.
[EDIT2] And now that works too. (Don’t ask me by what sequence I “fixed” it, I have no idea.) Although I get a strange mix of the two :
image

And that
image
is just not happening if the comment & footnotes pane is visible… (Perhaps what I was doing “wrong” just before EDIT2)

[/bug report]

As noted earlier in that section of the manual, comments and footnotes will always display in the inspector if that is open to the comments/footnotes pane. With the option to “Open comments in inspector if possible” selected, clicking a comment/footnote will cause the inspector to open if necessary and switch to that pane to show the linked comment, whereas with it deselected, the comments/footnotes will show in the popup whenever the pane isn’t already visible.

That’s just the way the hover text works, unfortunately. Moving your mouse off the link should make that part disappear, so only the popup shows.

image

I guess image is what confused me.

But it still doesn’t change the fact that
1: I was stuck for a while with things the way they are when image is checked.
(I did at least three reboots of Scrivener, and things only started to behave properly, as I earlier said, once I clicked on text that is assigned a footnote while the inspector was being completely gone.)

And 2: that @LattePhoenix can’t see the hover text comment/footnote content at all.
I mean this : image
(Assuming he/she did everything I suggested. (Assuming, again, that I provided the right and complete settings in need of being adjusted in order to make it happen.))
I was able to make myself see the popup (reverse engineer his/her state), but not the other way around.
It’d be nice of you, @MimeticMouton, to review what I recommended if you may. Thank you :slight_smile:

Three ways of viewing inspector comments/footnotes have been referenced through this thread: in the inspector, in a popup note (alternative to the inspector view), and as an infotip (aka tooltip) that displays when you mouse over a link.

  • The size of popups is not adjustable; when there is more text than can display in the popup area, you will need to scroll.
  • The size of the infotip box is not adjustable but will expand automatically to fit text; this can be affected by Windows settings, so it’s possible something has been altered on an individual system to truncate that. Nothing in Scrivener allows you to change it. There is also no way in Scrivener to enable or disable the tip box, so again, if that’s not displaying, it may be a system setting.
  • The notes in the inspector will always expand vertically to fit the note, and the inspector itself can be widened by dragging the edges (either expanding into the editor on the left or widening the entire project window by dragging on the right).

You can change the default behaviour of opening comments to always open them in the inspector by going to File ▸ Options... and ticking Open comments in inspector if possible toward the bottom of the Editing tab (as @Vincent_Vincent screenshotted above). Or if you prefer to keep the popups generally, you can hold the Alt key while clicking a comment link to switch the behaviour just at that time and open the selected comment in the inspector, so you can view the whole text more easily. As long as the inspector is open and displaying the comments and footnotes tab, your clicked comment links will show the comment there, rather than in the popup.

As long as the inspector is displaying some other tab, not comment & footnotes, then the comments should open in popups once the changed option is applied, even if the inspector is still open. I haven’t been able to reproduce the problem you unfortunately had where that behaviour didn’t take effect until the inspector was hidden; any chance you can replicate it and share the steps to trigger it?

I’ll give it a try.
. . . . . .

As above you cannot change popup font but you can change the font size of the comment in the inspector and have option of double clicking comment in the body of writing to automatically open the inspector window.
file>options>editing>formatting

1 Like

I tried a couple manipulations, even creating a new test project, but I was unable to reproduce the faulty behavior.
Switching from one setting to the other and back works perfectly.
I have no explanation whatsoever for what happened.
But, anyways, this is such a mild issue that I don’t even consider it worth putting much time looking into it after all.

At least, if someone ever encounters it, we know what to recommend as a course of action :
“Just do what you intended to do, but first do it once with the inspector hidden.”