Compile not working in 3.2 [Workaround: pg. 2]

Ah ha! Done, bug report sent.If you’d like a sample project for which this occurs - well, like I said, I created a project in 3.2 and just typed “text here” in the first scene, but I can send the project as well if that would help.

The actual error is:

Exception Reason: Invalid parameter not satisfying: index < [_itemArray count]

… which … following the trace, looks like a font issue somewhere (I sent the full stack trace in the bug report, it looks like it’s trying to do an index of font and crashes somewhere NEAR there) but I didn’t select any fonts when creating the test project (and don’t have any special fonts in the project I’m working on either, as it’s a draft.)


Oh, and other routine troubleshooting thing to do: reset your preferences.

I just tried the reset preferences dance - removed the plist file, restarted the Mac, restarted Scrivener, opened project, set show internal errors on in Preferences; selected File|Compile. Same error.

Ah, I found something that looks promising, it may have to do with having set a global font override in the past (if you created your test project from a template, it may have had that set as well). You could try this:

  1. In Finder, right-click on the test project that you created, and select “Show Package Contents”.
  2. Drill down into the Settings folder, and delete the ‘compile.xml’ file.
  3. Now restart Scrivener, load the project, and try compiling.

That unfortunately wipes out all compile settings, as you would imagine. So if that is not something you could afford to do in a live project, there is a more surgical approach that would involve editing the XML file to remove the font setting.

If you’re comfortable doing so, open the .xml file in a plain-text editor (TextEdit will work if that’s all you have), and search for “”. You’re looking for instances that directly follow a “” line. Delete the whole line containing the Font declaration, for each format that has one.

Obviously, I’d strongly recommend setting aside a backup copy of your project before doing this.

Or… if you can, just wait until the fix is out. We’ll have this fixed soon since it is obviously going to impact fair number of users.

BANG! That fixed it. Removed compile.xml, hit File|Compile, selected my options again (no big deal AT ALL there, obv) and… woohoo! Export into .docx successful.

Thank you!

Excellent! Thanks for the confirmation.

Do I assume this rather complex solution fixes the crashing problem not the fact Compile does nothing for some of us? I just tried creating a blank file from scratch from the standard Scriv fiction template. It does nothing when I hit Compile.

This fixes the problem you describe, but as noted, some of the templates may have this compile setting that causes issues. It’s usually safest to do a clean slate test with Blank, which is a project in its purest form, with very little assumption made to its configuration.

Yes deleted compile.xml kind of worked though what effect it has on a live file of 60k words I’ve no idea. I did notice that if I compiled to print it worked fine but then when I went back and tried to compile for docx (I chose print by accident not because I needed it) everything was back to scratch, Compile doing nothing and I had to delete the compile.xml file yet again.

Deleting Compile.xml works for me.

I should have added that, Mark… I’m running Mac Big Sur 11.0.1

This did work so thank you!!! Looking forward for the fix but this is a nice “in the meantime” fix.

Just updated my Scrivener to 3.2 and I can’t compile either. I am on a MacBook Air running Mojave 10.14.6, 10.14.6. I’m writing a screenplay. I print pdf and also to the Final Draft option. When I click Compile nothing happens. No compile menu, No options. Also I’m not a programmer so cutting bits of the program out isn’t going to work for me. Is there a patch coming out that can be downloaded?

I just updated to Scrivener 3.2 as well. I also updated my MacBook Air to Big Sur the other day. The compile button does nothing. And like #WOOLYPINKFOX I’m no programmer so would need a patch.

Same problem here. I’m also on a macbook air with Big Sur installed and updated to Scrivener 3.2 today. Funnily enough I switched user profile (I have a dedicated writing profile on my mac - I can get rid of clutter and temptation that way) and compile worked in the other profile.

As noted in the heading of this thread, the workaround is on page two.

yes compile not working since about 3 hours ago or more. someone is fixing the issue soon, but I’m not impressed
other issues I encounter more than once
-couldn’t log into to this forum with my password via support email link

  • but could log in on another browser (with same 'wrong" password)
    -Astrid at support prompts replied to my question about compile but it took me 3 times before I could contact her , so that bit wasn’t working either
  • I bought scrivener about 2 months ago, thinking it would make my writing life easier; so far it’s been a headache as there’s far too much detail tl learn especially about section types before compiling
    -also , I accidentally placed a folder inside a folder - it was supposed to be a simple job of clicking and moving it out, but I couldn’t do it
    -scrivener had better not ask me for any money soon for any upgrades -if they do - I share my experiences as much as possible online
    -the idea behind it is great -you add bits of writing, chop and change them when you want, break them up -sounds easy peasy-the reality is that it’s hard work. learning maths at school was easier at GCSE level. some of my degree and ophthalmic nursing study was easier
    I’m being honest
    -the last thing is that if I do end up abandon scrivener or whatever-i won’t buy anymore writing software packages - I have pages which is limited, but at least you get basic instructions . but no Ulysses or anything else
  • I don’t know what’s happening with the scrivener team currently or if will have repeated problems with it . some of you may say smugly-scriveners not for you. my reply would be it’s the most complex and only software since 2006 that’s had me in tears today. it’s because of a catalogue of problems with compile passwords and folders stuck in folders that I think now-what’s the next blunder going to be
    I am not a spiteful person, but will share experiences I encounter in the future online, in more public sites- factually, as and when they happen.
    I feel upset and angry and people should have some warning before they purchase something like this, which the concepts behind are great-but sticks and stumbles too much in reality -for me its given me hours of wasted time.
    I though software was supposed to ease time and help people.

I have Scrivener 3.2, build 14344 on macOS Big Sur 11.0.1 on a late 2015 iMac.

Compile does not do anything on this configuration, and I’m also one who does not edit XML or other system files directly so I am depending on a fix from the folks at LL.

Frustrating, but I urge patience to all, and stick with the software. It has helped me immensely, and I know the developers want to fix it for us quickly. I’m not a shill for the company–I just appreciate a really great tool. And yes, document structure can be an adventure until you get used to it.

Go developers, go! You can fix it.

UPDATE: FYI I did go ahead and try the workaround (editing an XML file) and while I won’t be doing that for every project, it did work for one.

It isn’t hard, Right click on the scriv file and show package then go to settings and delete the compile.xml file.
But I agree it’s a pain. I’ll be using something else for a little while now.

I’ll be releasing 3.2.1 tomorrow to fix this bug.

All the best,