Compile not working in 3.2 [Workaround: pg. 2]

Angry at whom? At the person who obviously did not try the 30 days trial version of “something like” this before buying?

Me, too. Help!

There’s a very generous trial for Scrivener which ought to be enough to allow people to understand what it’s like. And yes it is complex as any review of the app on the web will tell you
Honestly I don’t feel you should threaten to go around bad mouthing the app on the web because it hasn’t worked for you. Perhaps you should have done a bit more research beforehand.

Thank you, Keith!!! I appreciate it along with your support!

I came here to find out why Compile had stopped working, and then found this genius idea! I’m TOTALLY copying this. Thanks!

Thank you so much, Keith!! :smiley:

I’m on Catalina 10.15.7 and have the same issue. All was great, then updated to Scrivener 3.2, now I cannot compile. No errors, just no action after pressing the icon or using the drop menu or the keyboard shortcut.

Same problem here after installing the latest Scrivener update. I’m running MacOS Catalina 10.15.7 and am no longer able to compile. I click on the menu option and nothing happens! Help please!

Same here with Catalina on my Mac. Sure am glad I wasn’t getting ready to publish this week! Please let us know when there is an update to fix it. I would prefer that than to delete the 3.2 and reinstall. Something always seems to get messed up with reinstalls for me!

Mac user. Just upgraded to Big Sur and installed 3.2 update this afternoon. Compile function also not working for me. Thanks.

The .xml file deletion work around worked for me.

I sent in two reports, then went to the work around.


Great, and thanks for copying the entire post in a quote, as some people seem to be having difficulties in finding page two of this thread. ;)

Looking forward to 3.2.1 Keith!
Silver lining for those who also have Final Draft: It’s really easy to export the scenes of a screenplay to Final Draft using File/Export/Files/Final Draft (FDX). All the formatting matches perfectly in Final Draft. It’s possible to continue to work in Scrivener and then just export to Final Draft to print.

3.2.1 is now available via our site and has been submitted to the App Store. If you bought from us, please go to Scrivener > Check for Updates to grab the fix!

Relieved that the 3.2.1 update has fixed this very serious problem. Too bad I lost a half-day struggling with it. I suggest Scrivener post the fix in a banner at the top of the threads reporting this issue.

1 Like

Install V3.2.1 (the post before yours) which IINM fixes this and other problems!

Just installed it. Yes, it works! Compile is back. Thank you, Keith!