Compile to docx, all line breaks disappear?

When I compile my manuscript all line breaks disappear, making each chapter one very long paragraph. This happens if I use a stock format or if I try to create one of my own. My text in Scrivener has one line break after each paragraph.

Any ideas? Any information I need to provide?

It’s 3 steps:

  1. Select a Section Type for the scenes by right-clicking a Binder Item and choosing Section Type > Section
  2. Select File > Compile and click to Assign… button at the bottom of the middle column. Select the Section Layout for the Section Type. Click OK.
  3. Double-click the Compile Format you use in the left column. Click the second tab called Separators and make sure for the “Section” Section Layout, the “Section between sections” the “New Line” Separator is selected. Now click Save and Compile.

HTH

Thank you. Two issues:

  1. On step 3, the only choices I have are Single Return, Empty Line, Page Break, or Custom. I tried this using Single Line.

  2. The above does add a line between sections, but I still lose all line breaks in my text.

My structure is:

  • folder: Act 1
    • subfolder: Chapter 1
      • scene: Scene 1
      • scene: Scene 2

When I compile, Scene 1 (for example) loses all line breaks. In the editor, I have single line breaks after each paragraph. I’ve pasted into Word to make sure it’s an actual pilcrow, not a soft break. However, when I compile, all line breaks are gone and Scene 1 is just one long paragraph.

“He went to the fridge for a beer. ¶
They were out, so he grabbed a water.”

becomes:

“He went to the fridge for a beer. They were out, so he grabbed a water.”

There is an option in the Compile Settings to remove empty lines in text, but removing all NewLine characters is a different problem.
I can’t think of a reason for that to happen.

Do you have Format Replacements in your Compile Format?
Do you have Project Replacements in your Compile Settings?
Is a Regular Expression at work, replacing \n for nothing?

All Format Replacements are unchecked – those are the stock things like !fig($@) > <$n:figure:$@> but I unchecked them anyway. No custom ones have been added.

The other place I see Replacements (I think it’s for Projects?) is blank, none listed.

I just now tried adding a replacement, ¶ > ¶¶, but it only works on the line breaks between sections.

Just now, I found that some scenes have two line breaks after each paragraph, and that does work (my replacement above turned them into two, which I’ll undo). I’ll just go in and change all line breaks to two line breaks. It does seem, for future reference, that a single line break doesn’t always work in compile, even the stock formats.

I have screenshots but can’t find a way to attach them.

Markdown syntax has empty lines between paragraphs and so, if you’re compiling to Markdown and don’t have the empty lines, everything would run together.

ARE you compiling to a Markdown format?

If not, I see no way this could happen.

Sorry about that, uploading images is only allowed after a certain amount of posts or by special permission from moderators.

I’m compiling to Microsoft Word format. I just tried again, using Manuscript (Courier) which I haven’t edited, and it does the same.

i.imgur .com/bIOucdB.jpg

I’m strangely glad it’s not some easy setting I missed… but it did confuse me, why it was happening! I can add double line breaks, it’s not that hard to search and replace.

I would go through some of the suggestions in this previous discussion.