Compile to word introduces undeletable characters

Solution posed in post Word Manuscript Compile adds Multiple New Lines Before Chapter Titles does not work for me.
I am running Scrivener Version: (1463331) 64-bit - 03 Nov 2021 on windows 10 and Word 2016

After compile from scrivner (after changes described in solution above) the word document contains (red arrows mine to highlight. Not from compile)

These are not characters, but editing markers, similar to the invisible characters you also have enabled that show paragraph breaks and spaces. I don’t know how to turn them off in Word, but what they are indicating to you is that Scrivener has added bookmarks to these sections. Bookmarks can be used to hyperlink to these targets from other areas of the text, which is something Scrivener can do if you leave links in when compiling.

1 Like

@grNadpa You can toggle these “invisible but useful” things with the Pilcrow in the tool bar. See Screen shot. Google “word invisible character” for more explanation.

Screenshot 2024-01-14 at 20.16.46

1 Like

Thank you. I turned the Pilcrow on to show where the brackets show within the markup. It is the brackets I cannot get rid of – and which render Scrivener unsuitable for my needs.

Again, the brackets are there because you told Scrivener to insert bookmarks, which Word is recognizing as such. If you want to get rid of them, change your Compile settings so that Scrivener doesn’t do that. (Or delete the bookmark in Word.)

But since these are not printable characters, why is their existence such a problem that you’re willing to abandon Scrivener entirely?

1 Like

Thank you kewns

I cannot find where to change the compile settings. After all my fooling around, here it how it stands. How do I disable the bookmars.

Look under the gear icon in the right hand pane of the main Compile screen. I’m guessing that the option to insert links back to Scrivener is checked.

You could also click on the link in Word to see where it goes.

1 Like

Bottom left, likely.

Double clicking the “Default” Compile Format you use will also open the Compile Format Designer.

1 Like

Even if you don’t want to or cannot turn-off instructing Scrivener to send bookmarks Word as suggested by @kewms and @AntoniDol, you can in Word (Preferences) show/hide them. All under your control. See Screen shot.

While there in Preferences, take note of all the other useful options and things you can control in Word.

Thank you @kewms and @AntoniDol. Unfortunately I am unable to find the proper Compile Format Designer using your suggestions.

So I took your suggestion, rms, to format MS Word. My version of Word does not look like yours. I ultimately found it using this path: File > More… > Options > Advanced

That worked. Thank you.