Compile truncating last page

When I compile my stories, the last page is not included. The progress bar for the compile goes to 61% or 72% and then the progress bar disappears.

I am using Windows Scrivener release candidate 16.

I have tried compiling by selecting the manuscript (title) in the compile dialog or all the manuscript scenes in the binder and then the “selected” option in the compile dialog. I’ve tried including front matter and excluding it. I have compiled to PDF and to my printer (Brother laser).

To get all my pages included in the compile, I have to add a false scene at the end and fill it with at least two pages of gibberish and blank lines. I then have to remove the junk somehow from my compiled story. Sometimes the junk prints on the last real page instead of starting a new page. That’s impossible to remove from a PDF without expensive editing software.

Anyone else seeing this? How can I fix this, or does this need a bug fix?


I have this too. 3.3.6 on Mac. Can’t get last page to show up after compiling to PDF. The document just stops a page short.

This has happened to me from time to time, too. It generally seems to happen on very long documents (more than 350 pages). The last couple paragraphs will not be compiled. It might be due to a memory issue as I am using a somewhat old Mac, because sometimes it seems to fix itself.