Composition mode (and scrivenings), margin bug

Hi,
the right margin is truncated when using composition mode with multiple selected documents. It is kind of making it awkward and tough to read. (Feeling like the text had just vanished in the background rather than it is time to jump to the next line…)
Imo, it should be just as it is when a single document is selected.
Thanks.

P.S. Merry Xmas to everybody :slight_smile:

I just realised that it is not only in composition mode… Scrivenings are also doing this (although it is not as annoying as it is in composition mode).

tried in scrivening mode then composition mode with no truncation. My question would be are all the documents you are view at same magnification and is the paper width 100% can you show a screen shot?
Use the upload button in middle of the reply function.

Hi,
first, I tested the zoom at 100% without any effect. (Note that the zoom is per the editor tho, not per document (just to be sure that’s really what you meant.))
Here are some snapshots of the right side of both my main editor and composition mode.

Main editor, single short doc:
A-Editor view single doc
.

Main editor, single long doc with scrollbar:
A2-Editor view single doc long doc
.

Main editor, scrivenings:
(There is a hint of the problem here already… → Look at where the scrollbar is compared to the previous snapshot.)
B-Editor view scrivenings
.

Composition mode, single doc:
(Note that whether or not the length of the text calls for a scrollbar makes no difference to the margin if only a single doc is displayed ; it acts exactly like it does in my first two snapshots, although the scrollbar would appear over the left side of the solid black background as opposed to over the right side of the “sheet”.)
C-CompMode single doc
.

Composition mode, scrivenings:
:neutral_face: >>> This being the problematic situation <<< :thinking:
D-CompMode multiple selected docs
.

P.S. [Edit: not so sure about this anymore → ] Surely it has something to do with the scrollbar (which eventually fades away in composition mode, leaving more of the background instead – solid black, in my case.) → the right margin is truncated by the scrollbar in scrivenings… which is not the case for a single doc view, even with the scrollbar present. (Scrivenings always have a scrollbar, even if not necessary due to a short text.)

Look at paper width in composition mode if hover over the bottom of the screen in composition mode will see a toolbar and if set width to less than 100% can replicate above image, but also have to set paper position all the way to the left. Make sure paper width is set at 100%

GoalieDad, you and I are obviously not using the same version of Scrivener… Which built are you using ?
I am using v.3.1.1.0 (1463331) 64-bit - 03 nov. 2021 for Windows, and where your screenshot says “Paper fade” (bottom, all the way to the right), mine says “Background fade” instead…

Are you using Scrivener for Mac ??

1 Like

Had been on 64 bit windows version 3.1.0 but upgraded to 3.1.1 and bottom of screen is still the same with same build as you have and same update date. That is beyond weird would write to tech support and see what they say. I would also backup all projects in case have to uninstall and reinstall program.
I have no idea what is going on.???

I wonder if this is a situation where that resource has a different string depending on which version of English you’re using.

Background fade and paper fade are different commands. If you have a background texture, Scrivener assumes that’s how you want your background to look and won’t let you fade it, but you can fade the paper. (For instance if you want the text to “float” on your background.)

That is interesting I am using American version of English

Well, well, well… that being said, I would just like to point out that this is not really the issue here…
(Not at all my intention to be rude, but I’d rather say it now, before it is too late.)

To your original issue, @Vincent_Vincent, did you check the paper width settings as suggested?

I’d also suggest checking the Editor margins, in the Appearance → Composition Mode Preferences pane. (Is that in Tools → Options on Windows, I’m on a Mac at the moment?)

I did not assume any insult at all. However, British versus American versions of software could vary some terms. Not sure if that is issue or not

That’s all of the option(s) [ ← that (s) is sarcasm :stuck_out_tongue: ]

And yes, I played around with all of the available settings at the bottom of the composition mode window. Made no difference… [Edit : As a matter of fact, playing with the zoom factor again, I just realised that not only it doesn’t fix the margin, but at 50% the end of the text lines simply disappears behind the scrollbar… (I start having the feel of a margin at around 300% – which is, of course, purely dysfunctional.)]

As far as it goes, the only thing that (I think) I understood is that the issue is the absence of a margin when multiple documents are selected (scrivenings). The misplacement of the scrollbar that ensues leads to the issue in composition mode since the scrollbar fades away and disappears, being replaced by more of the background. And thus making it hard to read.

So I guess the question basically is : Why is there no right margin in scrivenings ? (as opposed to when a single document is selected/displayed.)

I cannot recreate this issue. Scrivenings works fine for me.

In this screenshot, left editor pane is in Scrivenings mode, right is in single doc mode. Both have a right margin.

Here are my editor options:

@Vincent_Vincent Could you please share your editor options, and I will try to recreate using your settings.

Best,
Jim

1 Like

@ JimRac

Here is what my install looks like with your settings. Left editor pane is in Scrivenings mode, right is in single doc mode. There is definitely a small difference in the right margin between Scrivenings mode and single doc mode.

When I set the Left/Right Editor margins back to my original 50 points, there is still a difference in left/right margins, but the perceived difference is small enough that I’d never noticed it in practice.

(Note that I needed to turn Scrivenings mode off and back on again by deselecting and reselecting multiple documents to have the settings change take affect in the left editor. This seems wonky to me.)

@Vincent_Vincent, my expectation is that if you increase your Left/Right Editor margins you’ll no longer experience the annoying “no margin” scenario. Is this the case?

Best,
Jim

1 Like

Yes, you are right. (I was actually playing just now with the margin settings.)
Setting a Left/Right margin of 0 points in Options/Appearance/Main editor made part of the text disappear under the scrollbar in scrivenings or be truncated in composition mode. Meaning that in the case of scrivenings (for some reason and as opposed to a single document being displayed), the scrollbar is set to be on top of the document instead of next to it. → The scrollbar grinds a slice of that right margin.

A margin setting of 50 (even 40 or 35) does the trick, indeed.

In my opinion, this should either be corrected or, alternatively, a minimal value for left/right margins in Appearance/Main editor should be imposed.

Thank you guys for the help. :slight_smile:

2 Likes

Thank you for the report! Using the settings you’ve described here, I was able to reproduce the problem and get it written up for them to fix.

2 Likes