Composition mode Text color override ignored

In Scrivener for Windows, (1812589) 64-bit, when I head into Options - Appearance - Composition Mode and try to override the Text color, the setting has no effect whatsoever. Whatever I select, the Text color on screen (after F11) remains dark grey/black. This was previously reported for the version 3 beta, but seems to still be present in the current Windows version. It pretty much makes dark-background Composition Mode unusable, as the text all but disappears against a dark background.

I think (if I remember right) that this is because your text/font is black, where it needs to be of the default color.


Thanks for the response, @Vincent_Vincent. Unfortunately, it looks like the Editor text color was already set to Default (I think that’s what you’re referring to, right?). In any case, I’ve set it to Default now, and it doesn’t seem to affect the Composition Mode text color at all.

What doesn't work - screenshots

What works - screenshots

. . . . . . .

It is not the font color that gets overridden in the options (1st screenshot)… it is the default font color.

This one:

Having your text of an actual color (black, red, blue… – anything other than the default)

will not be overridden.

Ah, and changing the Editing text color in Settings does not change the documents I already have! Yes, when I change the color of a specific document to Default, that document uses the overridden text color in Composition Mode. Thanks!

Which changes the issue to: how do I change the font color of about a hundred documents to Default in one stroke?

1 Like

- Backup your project.

  • Go to project settings, and check to see if this project uses its own formatting:

If this option is checked: do the next step in that panel. If unchecked, do the next step in the options…


  • Select all your documents in the binder.

  • Then, in the menus: Documents/Convert/Text to default formatting.

  • Make sure to check these boxes in the consequent popup:

Note that if you used different fonts here and there without doing so using styles, that’ll be lost.
Hence the initial backup of your project.
(Though note that unless you intended to compile “as-is”, you would have lost exactly that at compile, should that be the case.)

If you used styles, these will have to be redefined to use the default font color. (But that I am not 100% certain. It might just work without.)

The alternative is to manually select all and change the font color in each documents one by one.

Yes! @Vincent_Vincent, thanks a bundle for the quick and clear responses! This did the trick.

1 Like