creat new project not working

I am trying Scrivener for the first time. I just downloaded it (v 1.53) I am running snow leopard.

Installed it and opened Scrivener.

When I “create new project” in the opening window, and name it, it comes back with “can’t find file”, as if it were trying to open an existing project.

Screen shot attached.




Sorry you are having problems. That is very strange indeed - that message normally comes up when you try to save but you have moved the file, or if the file was corrupt in some way. Are you trying to create the project from a template (Novel etc) or from the Empty project template? If the former, try with “Empty” - if that works, you may just need to reinstall the Extras, as it may be that the templates have become corrupt in some way. I would also recommend repairing the permissions on your hard disk using Disk Utility just in case this is a problem, especially as you are using Snow Leopard - upgrading to 10.6 has caused a number of permissions conflicts on different machines I know of.

Let me know how you get on, and hopefully we can get you up and running as soon as possible. You can also contact me directly on support AT literatureandlatte DOT com (although bear in mind that I’m in the UK so it may be tomorrow before I’m able to get back to you in detail now).

All the best,

Thanks for the response. I’ll try what you suggest.

But to answer your first question, I tried both Empty and a screenplay template (I think). Same result.

I also tried deleting and reinstalling the app.

I’ll repair permissions using Onyx and get back to you.


If it’s happening with the empty project, that really is strange - it suggests that only part of the new project is getting written to disk, so that when it then gets opened Scrivener rejects it. Hopefully a permissions fix will solve it, but if not let me know.
Thanks and all the best,

Okay. This is kind of weird. I repaired the disk because Disk Utility recommended it, and I repaired permissions. There were a couple of them out of whack.

Then I started scrivener, created a new project in the default location (~/Documents/), and got the same error as before. So I tried again, using a different directory (desktop) and it worked!

So I look into it further and I don’t have the ability to make new folders in my Documents folder! My permissions in Get Info say I can read and write, but the new folder option in my file menu is grayed out… Very strange.

At any rate, it doesn’t seem like this is a scrivener issue, but some weird thing going on on my machine.

Thanks for your help. I hope scrivener works for me and I can end up buying a copy from you.


open a terminal window and type ls -ld Documents
you should see something like

mac:~ jaysen$ ls -ld Documents
drwxrwxrwx+ 43 jaysen  jaysen  1462 Sep  9 10:52 Documents

Post what you see and we should be able to get you back up and working.

I’m glad it helped at least identify the issue - that is weird that fixing the permissions didn’t fix your documents directory, though. Jaysen is a wizard and expert in all things like this, so hopefully what he says will help - thank you to Jaysen for replying and helping. (As I don’t know your level of computer experience, though, I will just clarify what Jaysen means by “open a terminal window” - go to ~/Applications/Utilities and just launch, then type in to that window what he says.)

All the best,

Jaysen, many thanks for your help.

Here’s what I get:

drwx------+ 33 nilsgore staff 1122 May 27 11:39 Documents


That would be what we refer to in the tech world as “not right”. The fix is easy, but there is a possibility that there is more that needs fixed. Opening terminal again can you type id
That should give you something like

Last login: Thu Sep 10 21:12:22 on console mac:~ jaysen$ id uid=502(jaysen) gid=502(jaysen) groups=502(jaysen),98(_lpadmin),81(_appserveradm),79(_appserverusr),80(admin) mac:~ jaysen$
At the end of the day we will need to run two commands in the terminal window. I just want to make sure I have all the info right the first time.

One last thing. This is all on a completely self managed system, right? Meaning you are not using a network managed mac (say a corporate system that is managed by an IT department).


Here’s what id gets me:

uid=501(nilsgore) gid=20(staff) groups=20(staff),204(_developer),100(_lpoperator),98(_lpadmin),81(_appserveradm),80(admin),79(_appserverusr),61(localaccounts),12(everyone),101(,401(

I am on a self-managed system. I work for a University and it owns my computer. My admin has an account too, but at the same admin level as me. He’s a windows guy (we have a windows network) but doesn’t like fooling much with the macs. There’s no network control of my mac.


OK, that makes sense. I think the windows side of things explains the non-standard GID.

Anyway, here is all you need to do.

  1. Open terminal
  2. type the following (what you type is in red):
mac:~ jaysen$ cd
mac:~ jaysen$ chmod 770 Documents
  1. Test your ability to create files/folders.

There are a few more tweaks that you could do, but this should get it. Let me know if you find other folders that you can not use properly (I would not be surprised if you did) and I can give you a quick script to fix the permissions for your home directory and sub directories.

I probably shouldn’t venture into areas that I don’t really know about, but this thread seems to deal with what looks like a similar issue. … 1291134001

Feel free to contradict me if I am muddying the waters!


Yes, no, not really.

Basically what has happened is the OS ACL has been changed to remove the group permissions. the groups is set properly (notice that in the ID his default group is staff (which is wrong, but legit)). All we really need to do is make the group perms correct. That is what the chmod does. There are a bunch of ways to do this, but the archaic way of setting specific bits is easiest. We could have replaced the 770 with g+rwx and done the same thing, but … I guess I am just to unixy.

Good, that means I can stop worrying about my permissions and do something I should be doing!


Let me say it this way… If you don’t have a problem, then you don’t have a problem.

A wise person once mumbled to me

He may be a backwoods hick, but he sure seems to have some wise ideas.

You might be interested to take a look at this article entitled “The use of crying over spilled milk: a note on the rationality and functionality of regret”:

And thanks for the technical explanations.

Best wishes,


I sincerely appreciate everyone’s help.

My problems seem to be getting worse—I now have several messages regarding permissions on a number of files in my Library, leading to problems of external drives not mounting, or not allowing me to read them…

One of the drives has all of my Time Machine backups on it. My plan was to restore the library files from a few days ago, when all was fine in my world, but it won’t even let me look at the drive, or get info on it. I tried to mount the drive on my wife’s mac, and the same thing there… So at the moment, I have a drive, with no way to get to it. I have DiskWarrior. Do you know if that will help me? Until now, I’ve used Disk Utility and Onyx to repair permissions and repair the disk. I don’t want to make things worse.

But back to the last thing Jaysen suggested. Jaysen, I did as you suggested (chmod 770 Documents) and it still won’t let me make a new folder.

Once again, thanks to all for your help.


Use it. It can fix things DiskUtility can’t touch.


Just to close the loop: I think my problem is solved after a lot of reading and piecing things together. My knowledge of command line interface is pretty thin, so I’m on a steep learning curve.

My external drive was set for nosuid (how, I don’t know). So using the info on I was able to regain ownership of the drive.

Many thanks for your help and interest. Now I can get back to evaluating scrivener, where this all started 2 days ago.