Custom audio play script not formatting correctly when compiled to odt. file format

For whatever reason, when I export my script to odt. to finish up final formatting, like adding: (cont’d) on lines that span a page break, or numbering the lines per page, the line spacing in the compiled odt. file is all messed up. However, in scrivener, the line spacing is fine.
This is in Scrivener 3.1.2 for Windows. In the compile menu I have the format set to script or screenplay, and in the section layout I have heading set to ‘As-Is’ and Section set to ‘Text Section’.
Is this a bug? (I suspect it is.) Or am I doing something wrong? (I very well may be.)
Here’s a link to the screeshots I took, since I apparently can’t embed photos into the post.

I should also note that this problem does NOT occur when exported to pdf.

If you compile to ODT because you are using LibreOffice, perhaps try compiling to RTF instead. LibreOffice is compatible. You might get a different result.

Thanks for the prompt reply.
I am using LibreOffice. Unfortunately, I got the same result with RTF and DOCX.

What if instead of compiling, you’d export your document as RTF?

image

image

You can test one document that’s causing a problem, if it comes out right, it’ll narrow down the issue to the compile process.

I just tried it. Same result as compile.

I’m thinking that it might be LibreOffices’ styles that’d be doing that.
I have no way of checking it out tho.

Are you problematic paragraphs assigned something else than the ones that are OK, in this list, once in LO?

Should you be willing to PM me one of your documents, I could figure it out (or at least try) with you.
You can even duplicate one of your problematic documents and replace the text with gibberish if you want. (As long as you don’t change anything to the way it is formatted, that is.)
Note that I am just a user like you. I don’t work for, or am not affiliated in any way with LL.

I’m updating LO right now to see if that fixes the problem. If not I’ll send over a file.

Were you in ScriptWriting mode ? In Scrivener, when you typed that text ?
Or did you use a standard document and perhaps used styles ?

Yes I was. I created a custom template with the script settings and made sure to use scriptwriting mode.

It looks as though your paragraph’s space before got interchanged for space after. (That is why I suspect LO’s styles.)

We know it is not Scrivener doing that, since you got the same result not going through compile, but rather exporting the file. (Your PDF being OK also confirms that.)

One other thing you could try, is to copy the text directly in a blank LO document.
From what I can see, you don’t get any formatting different from your compile format anyways.
Except for narrower paragraphs:
image

image

So how would I change that back in LO?

You’d first need to see if
image
have a different style than the rest of the text in LO’s styles list.

If all of your text is rather in a single style once in LO, it could then mean that ALL of the space after(s) got shifted. In that case, that’d be an easy fix. Although you shouldn’t have to, normally.

All the styles are set to ‘Normal’.

I don’t use LO a lot so I’m a bit lost when it comes to the details.

“Normal” that’s the style’s name?
Or rather “Default Paragraph Style” ?

I think it’s the default paragraph style. When I collapse the dropdown under “default paragraph style” “Normal” is still visible.

I’d need a sample document in order to help you further more.
At this point, I can’t do much more than direct you, which is highly limited in the present circumstances.

Thanks for your help. I’ve found that selecting all the text and setting the line spacing to 1 and then going through and adding a space between the end of the line and the next character’s dialog works. So I guess that’s what I’ll do for now.

That’s what I meant when I said that the space before got shifted.
Good.

You could do it for everything at once, if you right click / modify the “normal” style in LO
then :

That’ll work / not work, depending whether the formatting comes from line-breaks or carriage returns.

Either use space above, or space below; but from your screenshots, I’d say use space above.

Of course, you shouldn’t normally have to do any of this…