Edit footnotes and comments inside of note - not inspector

I just did something by accident that triggered something I was looking for and now I cannot reproduce it. Hopefully someone can help me.

I was trying to find an easy way to add and edit comments right inside of a text file but it seemed like this can be done only in the inspector.

Right when I “gave up” I deleted all my test footnotes and comments from the inspector window and noticed that there was a “leftover” inside of my textfile. It was just an empty space, the size of “one letter” with a frame around it. So I clicked on it in order to highlight it for deletion. When I clicked it, a small textwindow (if I remember correctly it was named “footnote” opened just underneath it and it was directly editable - Exactly the way I was looking for.
It was NOT the floating thing looking like a tooltip/postit that appears when hovering over an existing footnote/comment.
So I did enter some text and closed it. This created the footnote in the inspector.
BUT I was not able to open/edit this window again. I tried everything, undoing, redoing, deleting…

Does anyone have an Idea how I did this? : )

EDIT: to make my question a little bit clearer. I am looking for the way to open this Comment/Footnote editing Window right inside the text.

Could you clarify what software you’re using, please, and on what platform? You posted in the Scapple forum, but Scapple doesn’t support footnotes, Inspector or otherwise.

1 Like

Sorry, that was by accident! Are you able to move/delete the post?
It was supposed to be posted to the Scrivener/Windows/Support section.

EDIT: I was able to move the post by myself. I was not aware I could to that ; )

Select File > Options > Appearance > Textual Marks.
If you tick the box Decorate Comments and Footnotes anchors as Links, the text associated with a Comment will have a blue underline by default, similar to a normal link or hyperlink.
If you want to initiate/start a new comment while working on your text, add the following button to your Format Toolbar.

To do this, select View > Customise Toolbars > Format Toolbar… use arrows to add and position as required.

While in your WIP, highlight whatever word/phase/paragraph/piece of text you like and click on the icon.
A comment window open, like this…

Clicking anywhere outside the window makes the window disappear, but fear not, the comment is still there and available in the Inspector’s Comments. You never need to access it through the Inspector if that’s you use case. Just click on the decorated text.

I don’t use decorated text in this way, that’s why you don’t see what I highlighted in blue and underlined.

If you’re into finger gymnastics, Shift+F2 will open a comment in the same way as the icon.


By accident—we all do strange things when the muse is flowing and our creative minds are out of this world.

To clear deviant comments/footnotes, use Inspector > Comments and press X in the top right hand corner of the comment. Or the Delete option, if you adopt the comment window approach.

1 Like

THANK YOU Kevitec, for this very detailed and helpful answer!
I already thought I might have just imagined things after trying for more than an hour to get the comments window back and it did not work!

So I am very happy to see that the “comment window” really exists - thanks to your screenshot.
BUT… I still don’t see it and I can’t seem to make it appear following your instructions.

Now I am trying to figure out what’s going on.
I guess that this window might be an option that is turned off by default? I just opened another old Scrivener installation that I have on another machine and it is the same. When I hover over a comment or click it, all I see is the floating, non editable box that looks like a tooltip
Here is a screenshot from the scrivener tutorial project footnote

Whatever I do, I cannot seem to get THIS:

When I follow your description

highlight some text>click the comment button this window does not show. Instead inspector opens and an empty comment is created in the list. I can then edit the comment and close inspector. But if I hover over the highlighted section in my text, I only see the “tooltip” and when I click it, the desired window does not open. Instead of it, the inspector opens.

I have absolutely no idea what I did different yesterday to make the window appear for a moment.

You’re probably using Page View (Alt+Shift+P to switch in and out of the mode).
Page View comes with limitations.

1 Like

Thank you so much Kevitec, I finally got it!! ; )

The cause was indeed a setting, that I previously had under suspicion to be the cause but due a special circumstance did not work either at first. So I did not check it again (details below)

For everyone else who is interested, the solution is described here:

It works only after unticking the following setting in options:
options>editing>options tab>go down to Footnote&comments>uncheck “open comments in Inspector if possible”

When testing it, the Inspector MUST NOT be open while it is set to “Footnotes and Comments”. Otherwise all comments and footnotes will be still opened in the inspector only.
While using this feature, the Inspector can only be open if any tab except the “Footnotes&Comments” is active, or the Windows don’t show up.

BTW: I think this sould be unchecked by default.

Interesting discussion and useful tidbit. Interesting you do not need to check decorate comments and footnotes as links for this to work, but to keep inspector closed must add the icon in the toolbar or use the keyboard shortcut.
Always get useful insights from here and people’s endless inventiness.
Think the keyboard shortcut is Shift + F4 not Shift + F2

1 Like

I think Shift+F4 closes Scrivener, if I’m not mistaken, which would create a whole new unintended dynamic. :unamused:

I enjoy having the Inspector present at all times, else I’d have nothing to distract me from writing like a dog that can stop eating and dropping :poop: all over the place.

I guess you might have manually changed it. For me it’s also Shift+F4 ; )

And about having the Inspector present at all times… me too ; )
This is actually the “special circumstance” (in combination with the Footnotes&Comments Tab active) I mentioned and the reason why the comment windows did not work for me.

What’s your list of Shortcuts say.

I’m renowned to be a non-fan of the practice, to the extent that I’d never change them beyond experimenting with how to do so.

That is interesting! My list of Shortcuts says… well, Shift+F2 :thinking:
I bet GoalieDad will get the same result.

I wonder how that happened and I have two theories.
a) the Shift+F2 Keyboard Shortcut was already taken by another application at the time Scrivener was installed and it automatically assigned F4 as an alternative. (but this is rather unlikely)
b) maybe this setting came with one of the several custom themes that I tried.

Perhaps it’s related to the update steam followed.

And I’ll raise you my menus???

All right, I’ll fold. :shushing_face:

Erm, as a Pesky Mac user, I tried to install Scrivener for Windows to run under Crossover/Wine (which I’ve done many times, but I forgot to delete/rename the text-to-speech module, which blocks Scriv running under Wine!) but in the process of setting it up and launching it, I was offered the choice of running the current shortcut set, or the previous one (I don’t remember when the change was made). Is that why you have these Alt-F2 vs Alt-F4 differences?


Wine… nope, I don’t touch the stuff.

1 Like

But the point was that I was offered a choice of which set of shortcuts to use. So are those whose set-up is different from yours running the other set?

Don’t touch Wine? All the more for me then! :rofl:


Don’t recall such an offer at all.
I think there’s a difference among some of us with the move a folder/file to trash shortcut, too.
Mine is Ctrl+Del, for others it’s Shift+Del.
Mine’s in line with included S3 for Windows List of Shortcuts.