Empty line above titles after compiling?

Two years ago I compiled a book in Scrivener 1. After that I’ve upgraded to Scrivener 3, but I’ve imported the compile settings from Scrivener 1. Now I’m trying to compile two books in Scrivener 3, one of them being an updated version of the book I’ve made with Scrivener 1.

However, unlike in my compiled word/rtf-documents made with Scrivener 1, in the documents I generate now, every page with a title has an empty line above it (mostly Courier 12, for some reason, the standard font, which I don’t use), with varying line spacing (1-1,15 I suspect).

I don’t want this. I just want the titles at the very top of the page. I can’t seem to find the compile-setting to turn this off. I’ve picked page breaks for separators.

Can anybody help me out and tell me how to get rid of those empty lines above my titles? My books have loads of chapters, so I don’t want to have correct all titles manually. I’d rather find a real solution.

If you try a compile to PDF and don’t end up with these unwanted lines, it might very well then be something else that is not happening at compile.

Else, could it be this :

Or Word’s own doing ?

Thanks for your thoughts, Vincent, but unfortunately it seems that 0 blank lines is already selected.

When I export to pdf, it looks more like it did two years ago. So what else could this be?

PS, Only now I see that the titles are a different font, Palatino instead of Times New Roman, which is the rest of the text.

I thought it had to do with this, it was at 2.0. When I turn it down to 1.0 the title (as depicted in this screen) snaps to the top. However, after compiling, in the actual project, it just decreases the space between the title and the first line. And there is still a line above the title…

I see you have three different section layouts (top half of your screenshot) with the title option checked.
Did you verify all three of them ?

And why compile to RTF if we’re talking Microsoft Word ?

I did. Experimenting with them all.

If you click that 1,0x tab, you get an option Other, which brings you to a Line Spacing screen. Not sure how that works

If that “other” option has a “before paragraph” value other than 0, set it to 0pt. That’d be your issue right there.
Again, check for all three of your section layouts.

I’d think so too.

Alas, they’re all at 0 pts. Maybe that changing Multiple to Single might help.

No. It wouldn’t.
. . . . . . . . . .

:grey_question:
Why not compile to Docx instead ?

Perhaps that’ll work better.
P.S. I always end up with unwanted “empty space” when opening Scrivener’s spawned RTF in LO.

Because that causes trouble with the ToC.

Why, would that solve this?

Worth a try.
If not as a definitive thing, as a diagnostic mean.

Could be your margins too :
image

Although that would affect all of your pages…

I’ve just tried compiling to docx instead of rtf. Doesn’t make a difference.

The thing is, all the non-title-pages are good. No extra blank lines on top.
So that wouldn’t make it a margin issue, right?

Right.

Maybe check that your section layouts are truly using the separator that you intended :
image

Wow, that something so basic as NOT having blank lines above a title would prove to be this difficult.

It looks like that when you have your title selected at 1,5x or 2,0x, that the page uses 1,5 or 2 from the top of the page. That is not what I want. I want 1,5 or 2 space BELOW a title, not above it.

‘Use default separators’: those are all page-breaks

Because RTF is Scrivener’s native format and I believe in the Windows version it still first compiles the RTF which it then passes through a third party converter to create the DOCX. Word must be better at converting RTF to DOCX than any third party converter.

On the Mac, though, KB has rolled his own DOCX compiler, but as I always use RTF, as my word processor is also native RTF, I don’t know if there are any issues … certainly nobody seems to be reporting any.

:slight_smile:

Mark

1 Like

That would only make sense if you have a carriage return as your section layout’s or title’s prefix.

I’m sorry, Vincent, could you explain that to me?
P.S. I really do appreciate your stick-to-it-iveness

From the section layouts tab of the compile format:

image