European stressed vowels problem

I am a newcomer to Scrivener. I write in different European languages with stressed vowels (Portuguese, Spanish etc.). The system keyboard, at this moment, is the Spanish one. Then, for example, to get an acute a (á), I press the accent first (´), because it acts as a dead key, and, then, the vowel (a). In Scrivener, the result is “´a” instead of “á” a lot of times, but not always. Keep in mind that this problem doesn’t appear with the other installed programs in my mac. Any suggestion?

What other programs are you using?

Mac Scrivener uses the Mac OS text system, which it shares with TextEdit. Microsoft Word, on the other hand, uses a different system supplied by Microsoft.


There is a bug that I think that Keith et al. are conscious of and will solve one day. If it works like on my Mac, the bug pops up when I’m writing in Scrivening mode AND the Inspector is open. It might be the same on Windows.

Thank you very much for your answer. Before purchasing Scrivener, most of my writing was done with Aquamacs. Anyhow, no problem with Textedit or Libreoffice. I don’t use Microsoft Word. In Scrivener, the only heavy customization I am using is a home made “dark” theme: turquoise text on black background. I believe it’s a matter of time between the dead key and the vowel pressings but I don’t know.
I am using an i7 Macbook Pro.

Yes, the inspector is open. I’ll close the inspector and I’ll report.

No relationship with the bug referred by Matsgz. Interesting discovering: if I slow down my typing speed (more, even a long time between both key pressings), no problem. Any suggestion?

More information: when I press the “dead” key, Scrivener outputs a small yellow box waiting for the next key. This doesn’t occur in any other installed program.
If it’s impossible to solve this problem, Scrivener is not usable for me (or any other serious typist).

What version of OS X do you have?

Are you writing standard text, or in scriptwriting mode? Are you using any keystroke expanders? Automatic spellchecking? We’ve encountered a similar issue with some Asian languages, where the more different applications are “watching” the text, the more of a pause there can be in the generation of complex characters.


Thank you very much for your message.
I am using Mavericks. I started from a General Non Fiction template and, then, I am writing standard text. No keystroke expanders at all. I have switched automatic spellchecking off but it doesn’t make any difference.
System input sources are set to Spanish-ISO, but the op sys language is English.
Are you able to reproduce the behaviour I have outlined? I really like Scrivener but it’s impossible to work in European languages without solving this issue.

I forgot to mention I have been playing with Key Repeat and Delay Key Repat params in System Preferences without success. I have also switched Scrivener language from English (my usual choice) to Spanish without any improvement.

The yellow box you refer to is the standard Mac behaviour when you use ‘Alt + a letter’ to generate an accent. For example, to get á

  1. I press “Alt e” - this generates a yellow box with the ´ accent inside it Alt + e.png
  2. I then press “a” and this generates “á”

I don’t use the Alt key to generate an accent. I use the dead key available in Spanish ISO keyboard (´) and, afterwards, I press “a”. So, the yellow box doesn’t appear in other programs, only in Scrivener.

Is it the same yellow box as shown above? If so, could Scrivener be treating your ‘dead key’ as if it’s the Alt/Opt key?

Yes, it is.

I think that’s what happening then. Someone with greater knowledge than I might be able to help with how to remap your keyboard in Scrivener (I know how to add menu shortcuts, but this is something different).

Thank you very much for your advice. I’m waiting for a solution from the Scrivener’s Technical Support. It’s a serious problem for any European user.

That needs to be emended: it’s a serious problem for you, and maybe for others using the Spanish keyboard setting, but not for all European users. There are many European users, Spanish, Italian, French, German, Swedish …, who have been using Scrivener for years and never had this problem. The only report I have seen of it, is in Matsgz’s post above.

That is not to devalue the problem you have, but it is wrong to extrapolate from your experience to all European users


In the meantime, have a look at the Keyboard Viewer (accessible either via System Preferences or it’s already showing in your menubar). In particular hold down the Option key which shows you all the diacritics which are accessed via that key. The ones in orange are accents that can be used over more than one letter, so you have to press Opt+char, then the letter you want the accent over.

Thank you for your message.
The Keyboard Viewer shows the two dead keys present in Spanish ISO keyboard: ´ and ` (in orange, as you stated).
If I press the Option key, I see another dead key (~, in orange too), the one that lets me create Portuguese stressed vowels.

Just a correction: I have found something similar devices to the yellow box attached by ScriverTid in other programs (and even the same yellow box) but it works without any problem or limitation to my typing speed.